1. Check out our companion app, Forums for Android! Download from Google Play

General Rented movies have never worked.

Discussion in 'Android Devices' started by phredog, Mar 16, 2013.

  1. phredog

    phredog Well-Known Member
    Thread Starter

    Jun 16, 2012
    Software developer
    I use my GN1 as a media player only. I have rented several movies, but have never been able to watch any of them (granted I have not tried for about six months now).

    First of all, my phone is NOT rooted. Back when I had GB, I tried to root it, so I could rid myself of the dreaded voice assistant. Evidently none of the published methods work on the German version of the phone.

    I received ICS, and JB over wifi (i have no service on the phone) and everything appears to have worked as expected, so it is reasonably safe to say my attempts to root the phone did no damage.

    Anyway when I did try to watch movies, one of two errors appeared:

    "Can not play on a rooted device"
    "Can not fetch license"

    What error appears is random as far as I can tell.


Share This Page