Repo Init raises GitError('filesystem must support symlinks')


I am working on ubuntu 10.04 and try to download android source code. After initialize the built environment according to Initializing a Build Environment | Android Open Source, javac -version is javac 1.6.0_24. then, I run:
repo init -u git://

but it comes out these errors:
Getting manifest ...
from git://
Traceback (most recent call last):
File "/mydata/d-linux/Android_SourceCode/mydroid/.repo/repo/", line 238, in <module>
File "/mydata/d-linux/Android_SourceCode/mydroid/.repo/repo/", line 220, in _Main
File "/mydata/d-linux/Android_SourceCode/mydroid/.repo/repo/", line 125, in _Run
cmd.Execute(copts, cargs)
File "/mydata/d-linux/Android_SourceCode/mydroid/.repo/repo/subcmds/", line 237, in Execute
File "/mydata/d-linux/Android_SourceCode/mydroid/.repo/repo/subcmds/", line 110, in _SyncManifest
File "/mydata/d-linux/Android_SourceCode/mydroid/.repo/repo/", line 1464, in _InitGitDir
File "/mydata/d-linux/Android_SourceCode/mydroid/.repo/repo/", line 1497, in _InitHooks
raise GitError('filesystem must support symlinks')
error.GitError: filesystem must support symlinks

I have try to run the repo with python 2.6, python 2.5, and python 2.4 by editing the repo file exec python2.5 and exec python2.4. It result in the same error.
What is missing? what should I do now :thinking: