1. Are you ready for the Galaxy S20? Here is everything we know so far!

[RESOLVED] Soft Bricked - Can't flash with Odin

Discussion in 'Android Devices' started by Sunlis, Dec 28, 2011.

  1. Sunlis

    Sunlis Lurker
    Thread Starter

    I was trying to root my new S2, and after a seemless root of my Galaxy S a few months ago I jumped in a little carelessly. I was flashing an insecure kernel in odin but it failed with this message:

    Code (Text):
    1. <ID:0/003> Complete(Write) operation failed.
    2. <OSM> All threads completed. (succeed 0 / failed 1)
    Now I can only get into recovery mode. Kies can't recognize the phone. I've tried doing their little connection troubleshooting thing to no avail. Odin sees my phone, but it just gives that write error every time.

    The biggest problem is that I can't find the right ROM/Kernel/whatever to try a restore with. I'm in Canada and my carrier is Rogers, but every thread I search through only has Virgin and Bell listed for Canada. I was an idiot and I didn't copy down all of my phone's information in Settings before I did this - is there another way to find this info? In particular, it seems like I need to know my phone's kernel.

    At this point, I just want to get it back to stock. I can tip-toe into rooting once I get my phone back to normal.

    I'm a bit of a noob in all of this, so please try to explain yourself rather than just posting links. :)

    EDIT: It looks like I've figured this out. All too often I see, "Fixed it. Thanks anyway," posts and I'm left asking, "BUT HOW?" So...

    I first discovered that my S2 is a "Samsung Galaxy S2 Skyrocket" by Googling my phone's "Product Name" (SGH-1727R) and digging through a few threads and surrounding forums. Using that, I was able to find this forum and soon after this thread.
    I downloaded the stock TAR for SGH-1727R (link is from thread) and put the .tar inside that .7z into the PDA slot in Odin. I also unchecked EVERYTHING except for Auto Reboot. Removed my phone's battery, left it for half an hour (while downloading the .7z), then put it back in. Plugged one end of the USB into my computer, then held the volume down key and plugged the other end of the USB into my phone. When the phone asked, I hit volume up to continue. Computer recognizes the phone, click Start in Odin. Wait a few minutes and my phone reboots and is back to normal.

    I hope this helps someone else who finds themself lost and confused like I was. :)

    m00ts likes this.

    1. Download the Forums for Android™ app!


  2. m00ts

    m00ts Lurker

    Thank you very much for posting the fix, you helped save my phone! :)
  3. MrCrumbs

    MrCrumbs Lurker

    I can't thank you enough for posting your solution. I hate it when people just post "it's OK, I solved it", try contacting them after a year or two...
    You saved my phone, and I thank you! :)
  4. maxpro88power

    maxpro88power Lurker

    Made an account specificly just to say Thank you!
    Have a nice day or night
  5. I also just made an account to thank you. :)
    God Bless You.

Samsung Galaxy S2 Forum

The Samsung Galaxy S2 release date was April 2011. Features and Specs include a 4.3" inch screen, 8MP camera, 1GB RAM, Exynos 4210 Dual processor, and 1650mAh battery.

April 2011
Release Date

Share This Page