1. Are you ready for the Galaxy S20? Here is everything we know so far!

Revolution won't connect to home wifi

Discussion in 'Android Devices' started by icybri03, Jun 3, 2011.

  1. icybri03

    icybri03 Lurker
    Thread Starter

    I can't get my LG revolution to connect to my home wifi belkin router. When I go to wireless networks my wireless connection shows but when I click on it to connect it doesn't do anything. I can connect to other unsecure networks just not my own. Please help.:thinking:

  2. Haxcid

    Haxcid Android Enthusiast

    Is your network secure? What type of security is it using. You may need to look in your wireless router settings. (wep, wpa/wpa2, etc...)
  3. 1of7627

    1of7627 Well-Known Member

    My Revo connected fine to my home router, which is a D-Link DIR-655 using WPA2/PSK. It also connected to the public (nonsecure) wireless where I work (college campus). - MarkC
  4. hedylogus

    hedylogus Newbie

    to ditto Haxcid, that's a tough question to answer without details of your wireless setup. off the cuff, make sure you don't accidentally have mac address filtering turned on, make sure you have available IP addresses, etc. to indirectly answer your question though, it does not seem to be a phone issue (as no one else has stated any issues).
  5. speedtrap63

    speedtrap63 Newbie

    Also, check if your SSID is set to broadcast on your router. If it is, then check your encryption settings to be sure they are correct on both ends.

    I couldn't connect to any Netgear router with my Dinc if the SSID of the network was hidden. Haven't tried this out yet with the Rev, but I'll let you know if anything is different.
  6. Maguire86

    Maguire86 Lurker

    I know this is an all thread but I am wondering if someone could help me out.

    I bought the LG-P500 recently and am trying to connect it to my wireless router, Belkin. The phone one minute says it is connecting but then it disconnects. Does anyone have any idea of how to fix this?

    All help with this is appreciated.
  7. gagnon7

    gagnon7 Lurker

    how would one turn off the mac address filter if it happened to be on, and beyond that, how would you figure out if it was on? Haveing the same issue with my Revo, it does the whole "obtaining IP address" for a while then disconnects.:thinking:
  8. goalieman24

    goalieman24 Lurker

    I'm having the same sort of issues.
    It's interesting, as my phone has no issue connecting to my home WiFi. At the office though, it picks up the network but never connects... even though I'm sitting here with my computer connected wirelessly.
  9. pirahna

    pirahna Well-Known Member

    My phone sits there and gives me notifications that a wifi network is available when I am home and when I click on it it says it has been disabled and asks if I want to reconnect. I can not say how much I hate this phone, it makes my old Thunderbolt I also hated seem brilliant.
  10. sgschwend

    sgschwend Member

    Sounds like your phone is defective.

    I would recommend calling your provider's service line, have them walk through some of their diagnostics (which may be a help).
  11. blaket81

    blaket81 Newbie

    To the person asking how to disable mac filtering. You'd have to do it from a computer wired into the router (that way it's not trying to access it wirelessly). Other than that i can be of no help, my revo too is doing something weird with wifi. With the wifi at work my phone won't connect to it automatically. It stays connected but when i go out of range then back in it doesn't reconnect. I have to go to wifi settings, it shows the network as disabled and i have to go to it and hit connect. The phone doesn't behave this way with any other wifi network except the one at work (so far). Also, it's not a problem with the wifi at work because a lot of other people have a bunch of different types of phones (including android) and none of them have this issue. It comes down to revos being flaky when it comes to wifi. One of these times i'm going to forget to reconnect to it and go over my data usage, then i'll be mad!
  12. SecondToNone

    SecondToNone Lurker

    for months my phone workd at home just fine on my wifi then last few days it wont connect "samson galaxy" it finds the router "belkin" says its a secured network with wpa/wpa2 i click on it and it says " scanning then it says obtaining IP adress then says connected then says dicconected then says {disabled} all happends very fast ... like i said before i have been on this many time in past "its my house" i have never added or changed anything "live alone" i DO have auto updates on phone but besides that im at a loss

    o and im on my laptop atm and on the same router

    also my phone works just fine at work and other places with wifi


    ty JIM
  13. 61scout80

    61scout80 Lurker

    i just got my revo, and i'm having the same above problem. Any solutions?

    My router works fine with my ps3, wii, droidx, and my laptops. it also worked fine with my old lg ally and my wifes older lg. I have no idea why my revo won't connect.
  14. sgschwend

    sgschwend Member

    It should work easily, give your provider a call. They will ask you if you can get it to connect to any wi-fi, such as a coffee shop or a library. They will also check your setting for you.

    You could turn your network security off and try that too. Let us know what you find out.
  15. jollyrotten

    jollyrotten Newbie

    Mine says I'm connected to my home wifi but I cant log in to anything.
    I also dont know how to check "SSID broadcast settings" etc on my moms PC. Im a Mac user and this PC....its way to hard to find what I need.
  16. sgschwend

    sgschwend Member

    I know this is not the same, but I have had a bushel of trouble with the 4Ghostspot on this phone.

    As I continue to try and find a way to make the phone share digital data I have found that other makers have hotshot and wi-fi problems too.

    Motorola just put out an update to "3G/4G Data Connection stability and reliability"; note digital data handling and link stability implied.
  17. edubman

    edubman Lurker

    If other devices connects to router. That means router is ok. If other device can't connect to router, try rebooting router. If other device can connect to router. Try deleting the connection on the LG and remaking the connection.
  18. Evandaniel3

    Evandaniel3 Lurker

    mine is kind of doing the same thing but with my router when I try to connect my phone to wifi the routers wireless light starts blinking red and wont let my phone connect but as soon as I stop trying to connect it returns to green I feel like this has to do with the amount of ip's connected to my router or something but I don't know how to fix it. does anyone know a solution????

LG Revolution Forum

The LG Revolution release date was May 2011. Features and Specs include a 4.3" inch screen, 5MP camera, Snapdragon S2 processor, and 1500mAh battery.

May 2011
Release Date
Similar Threads - Revolution won't connect
  1. Homeuser66
  2. Phyllis Hedding
  3. darkdaz
  4. donb08
  5. Michael Syring
  6. Guitarist
  7. nicecap
  8. Samantha Lombardo
  9. Aquitaine
  10. Kang Chang Hock

Share This Page