1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Rogers & S4] Emergency Possibly Bricked!!! HTC One X

Discussion in 'Android Devices' started by jordan443, Dec 31, 2012.

  1. jordan443

    jordan443 Newbie
    Thread Starter

    Hey guys i have a huge problem. I have a Rogers HTC One X that is rooted. I installed cm10 and I didn't like it so I booted into twrp recovery and wiped EVERYTHING, I wasn't thinking. so there is no ROM on the phone. I have the stock ROM but I couldn't get it onto the phone because twrp wouldn't let me mount my SD. Whenever I looked through my files on TWRP after that, there was nothing on my SD. TO get the ROM onto the phone, I partitioned the drive to FAT32 and put the ROM on. It did not appear on twrp. I then panicked and relocked my bootloader and know my fast boot says I have a security warning. Now for some reason, TWRP was erased and whenever I try to flash it, this is the message:

    ERROR: could not get pipe properties
    sending 'recovery' (7332 KB)... OKAY
    writing 'recovery'... INFOsignature checking...
    FAILED (remote: signature verify fail)

    PLEASE does anyone know how I can just get it back to how it first was????
    (sorry for the long story, i'm panicking)

  2. GuitarG20

    GuitarG20 Clueless Senior Member

    Hi there Jordan and welcome to the forums!

    Unfortunately I don't know much of anything about rooting and flashing custom ROMs, but I am passing this on to other people in the hope that they know something about what to do next. Hopefully we will hear from them in the next few hours...
    jordan443 likes this.
  3. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member

    You won't be able to reflash TWRP with a relocked bootloader. If you unlock again, you should be able to reflash TWRP.

    Once done, boot into recovery, does it let you mount your phone to the PC now?
    jordan443 likes this.
  4. jordan443

    jordan443 Newbie
    Thread Starter

    I did what you said, I was able to flash TWRP and when I press the mount option, it wont allow me check "Mount SD Card". I think this might be because I wiped it. I had this problem before partitioning it to FAT32 as well. Any ideas?

    (I wiped it through the bootloader menu before I saw your post so theres no partition now)
  5. jordan443

    jordan443 Newbie
    Thread Starter

    I just tried to mount the sdcard using this guide:

    If you don't have an sd card, or your slot is broken you can try this trick, but you will need a custom recovery like Clockwork.
    Boot up your phone to recovery. And move your rom file to the adb directory, and start a command line ( cmd )
    adb shell
    mount data
    adb push D:\custom_rom.zip /data/
    Wait until the push finised, and restart your device to recovery again with "adb reboot-bootloader"
    mount data
    mount /data /sdcard ( mount the data folder into your sdcard folder, so your recovery will think that you have an sdcard installed )
    Locate the ROM .Zip file you wish to flash.
    Confirm the flash by following the on-screen instructions (ie: pressing the trackball, pressing the call button, etc.)
    If no errors arise during the flashing process then the ROM flash was successful, Reboot the device.
    With some root file explorer, remove the rom file if you don't need it anymore, to free up space.
    Or use adb to remove the custom recovery
    adb shell rm data/custom_rom.zip

    i ended up getting this error:

    Jordan:OneXRootTools Jordan$ ./adb-mac shell
    * daemon not running. starting it now *
    * daemon started successfully *
    ~ # mount data
    mount: mounting /dev/block/mmcblk0p35 on /data failed: Invalid argument

    I tried it again after partitioning the drive to FAT32, still didn't work:(

    I also tried to flash the ROM vie fast boot and got this:

    Jordan:OneXRootOneClick Jordan$ ./fastboot-mac flash zip PJ83IMG_Evita_UL_Rogers_WWE_1.73.631.1_Radio_0.16a.32.09.06_10.81.32.14L_release_254934_signed.zip
    sending 'zip' (590714 KB)... INFOstart check_usb: usb_ep0: type=128, request=6

    INFOstart check_usb: usb_ep0: type=2, request=1

    It seems to be stuck there
  6. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member

    By partitioned, do you mean format or have you actually partitioned the phones internal SD Card?

    I think at the moment, your safest option would be an RUU to restore your phone totally back to stock so we can start with a clean slate? Seem like a plan?
  7. jordan443

    jordan443 Newbie
    Thread Starter

    I don't really know much about RUU but i guess it's my only option. How do I do it?
    I already have the RUU zip for my phone (It's on Rogers)

    I just looked it up and it says I should have a RUU.exe? It doesn't seem that I have one.

    (My laptop can boot into Windows if needed)
  8. jordan443

    jordan443 Newbie
    Thread Starter

    I tried this but niether ARUWizard or HTC-Sync could find my phone:

    0. ensure the bootloader is locked, or relock it...before step 1. (thanks to h_zee13)
    1. download the ARUWizard.rar tool and have htc-sync installed and running.
    2. unzip it the ARUWizard.rar into a folder.
    2. delete the "rom.zip" in that folder or move to another place.
    3. copy your "PJ83IMG.ZIP" into the folder.
    4. run "ARUWizard.exe", follow the steps.
    note. if you are not on xp, please right click the "ARUWizard.exe" with administrator permission.

    Theres a USB glitch on my mac when I boot into Windows, is there any way to do it without having to use Windows?
  9. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member

    I'm not aware of any mac RUU programs, sorry :(

    Do you know what software version was on there before you rooted? Rather than messing about with that program, for RUU's, it's generally a simple case of plugging the phone in, then running the exe file. You'd probably have more success with that than messing around with a 3rd Party program.
  10. jordan443

    jordan443 Newbie
    Thread Starter

    I don't know what version it was, but anyways, I could only find one ruu for my carrier and it's only a 604 mb zip.
  11. GuitarG20

    GuitarG20 Clueless Senior Member

    Are you using the most up to date drivers? I had issues but they got resolved with an update. Just run the apple updater inside windows (assuming you're running boot camp)
  12. jordan443

    jordan443 Newbie
    Thread Starter

    Its only a problem with my phone, not any other devices

    I think it's the HTC drivers, but they installed fine. when I'm in Windows my computer won't detect it at all. not even adb or fastboot detects it

    but do you know anyways to install the RUU via fastboot because it's a zip
  13. jordan443

    jordan443 Newbie
    Thread Starter

  14. jordan443

    jordan443 Newbie
    Thread Starter

    I fixed the sdcard mounting issue with the stock htc recovery and a factory reset.
    I got the RUU zip onto my phone but when I try to install it it says it was unable to. any ideas?

    SO now I'm back to the original problem of wanting to get rid of cm10 and revert it to stock.

    The problem is that the only ruu for my phone is a zip that won't install
  15. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member

    How are you trying to install the zip file? With the stock recovery? If it's the correct file, you should just be able to put it on the SD Card, boot to the bootloader and the phone will do what it needs to do.

    If that fails, would you be happy with a ROM that was closer to stock than CM10.
  16. jordan443

    jordan443 Newbie
    Thread Starter

    how will I know if it's working and when it;s done? and should I have the stock recovery installed and should I have the bootloader locked??

    oo and if it makes a difference, my phone is S-on

    And another carrier that also carries my phone has an RUU for the same model (Evita) and it's an exe Would I be able to flash it?

    and what rom are you talking about?
  17. jordan443

    jordan443 Newbie
    Thread Starter

    I just installed a JB HTC Sense 4x rom and It is almost excactly the same as stock but the battery drains and its slow and laggy.
  18. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member

    Head back into TWRP, go to the advanced menu, then fix permissions, see if that makes a difference?

    Do you have a link to the ROM you went for?
  19. jordan443

    jordan443 Newbie
    Thread Starter

    I think it was just laggy when I was first using it but it comes with all these features that are pretty cool and it has a battery saver feature as well. when I turn it on the battery drains at 1% per 15 min of use.

    I would still rather use the RUU

    Heres the link:

    [ROM]12.31.2012 Newts JB v2.0.1 (Jelly Bean & Sense 4+) Stable - theMikMik

    (It's for Evita, not Endeavor)

HTC One X Forum

The HTC One X release date was May 2012. Features and Specs include a 4.7" inch screen, 8MP camera, 1GB RAM, Nvidia Tegra 3 processor, and 1800mAh battery.

May 2012
Release Date

Share This Page