1. Are you ready for the Galaxy S20? Here is everything we know so far!

[ROM] Galaxo and Recovery 6.1 released

Discussion in 'Android Devices' started by sado1, Aug 15, 2010.

  1. sado1

    sado1 Well-Known Member
    Thread Starter

    Galaxo - changelog:

    • minimal cpu frequency set to 120000 (fixes charging bug)
    • gapps now are restored using update zip instead of SAMSUNG.TAR
    • unified recovery for Galaxo and GAOSP
    • reduced aggresive thresholds
    • updated superuser app
    • Super Circle Battery integrated
    • optimised libdvm (by jakax)

    Download - rom and recovery: Download | drakaz
    Download gapps: Multiupload.com - upload your files to multiple file hosting sites!
    Topic - rom: Galaxo V1.6.3.4 (Donut) (Page 1) - Release - Drakaz's Android stuff
    Topic - recovery: Recovery V6.1 - Samsung Galaxy : Unified recovery for Galaxo and GAOSP (Page 1) - Release - Drakaz's Android stuff
    You can install it without wiping, if you want to just patch your Galaxo

    (ext4 support was meant to be a new feature too, but made the device crash and drakaz doesn't have time to fix it)

    Yathushan, abesh, mitmeister and 2 others like this.
  2. DaSchmarotzer

    DaSchmarotzer Blame it on me

    Nice surprise from Drakaz! Thanks to all the devs we have working for us. :D

  3. Lelouch

    Lelouch Android Enthusiast

    yep it was a massive surprise
    day before a new nightly build and day after the nightly build release new recovery v 6.0, a few hours later recovery v 6.1 and Galaxo v

    that was a big and massive surprise :cool:
  4. maurinet

    maurinet Well-Known Member

    Having a bit of a hiccup here, hope you can help.

    -I was running Galaxo with Darksense2.0 theme applied
    -Flashed recovery 6.1
    -Made Nandroid backup
    -Flashed Galaxo (restarted and checked that I was running; I could see the new battery indicator; had nonstop Force Closes of android.process.acore, default android theme is applied)
    -Restored Nandroid backup
    -Back to :S
    All works ok, but restoring the backup also seems to restore the phone to Galaxo (Phone Information displays I'm running Galaxo, I can't see the new battery indicator, Darksense2.0 theme is applied, all apps installed)

    How can I install Galaxo and keep all my apps, settings and user info without having to start from scratch?

    Can somebody confirm daily usage of Galaxo If so, can you post the steps you took to do it?

    Thanks in advance,
  5. sgx100

    sgx100 Android Enthusiast

    Galaxo getting more updates....:D:D:D
    The old war horse
  6. sgx100

    sgx100 Android Enthusiast

    Well the entire point of a nandroid is to save your life.
    Well you roll back to the latest backup...obviously dude it will roll back to getting rid of

    Wipe is necessary...Im not sure but its not advisable to do without it.

    As far as settings go ---> Install My backup.
    It can take care of settings, data and applications so that you dont have to reinstall them again.

    You can also try Titanium Backup ---> Mother of All backup apps ( even restore protected system apps)

    I just installed yday in the night....Applied the dark sense theme and lost out the battery indicator :(

    Actually even before seeing what the indicator was all about...I lost it :)
    Anyways Im not complaining ..... can get back to stock launcher anytime.
  7. maurinet

    maurinet Well-Known Member

    Ok, the way of installing Galaxo without loosing any apps or settings is easier than I thought.

    Just apply update.zip
    Restore gapps
    Apply theme

    Done! No need for restoring Nandroid backup.

    What I was trying to do was to "fresh install" and then add the apps through a Nandroid backup, it seems that you can't really do that. Instead, you have to install on top of

    Hope at least this experience helps other ppl
  8. avatar1983

    avatar1983 Lurker

    It seems I can't apply any themes with Galaxo I've tried DarkSense 2.0 with the advanced launcher, and DarkMix, with fixing permissions.

    I get the following Failure at Line 1: copy_dir PACKAGE:system SYSTEM:
    (there is presumably more, but its cut off)
    Sync data...
    Installation failed

    Anyone else have any luck applying themes to Galaxo
  9. maurinet

    maurinet Well-Known Member

    I was able to apply Darksense2.0 after doing a "fix packages permissions". I had the darksense file on the root directory of the sdcard, not inside any directory, and applied it using "apply any zip from sd". Hope that helps.
  10. avatar1983

    avatar1983 Lurker

    Hmm, that's exactly what I tried, and it didn't work out. Odd.
  11. Naruvam

    Naruvam Well-Known Member

    How are peformances on 1. 6. 3. 4? Same or are we maybe blessed with even more speed? ;)
  12. maurinet

    maurinet Well-Known Member

    Try downloading the theme again, your file could be corrupted... that's what I would do; then try again.
  13. sgx100

    sgx100 Android Enthusiast

    Try the Dark Sense 2.0 themes from here

    One of them failed for me on the .... but others worked.
    I dont rem'r which one.

  14. sado1

    sado1 Well-Known Member
    Thread Starter

    Hey, but .zip-installed themes need to be matched to new version, so you just need to wait a while until infect does that ;)
  15. maurinet

    maurinet Well-Known Member

    Negative, DarkSense themes are compatible with all 1.6.3.x (at least so far), I'm running DarkSense_ADW-Sense on my, all working well.
    Keep trying, it's possible.
  16. DaSchmarotzer

    DaSchmarotzer Blame it on me

    I didn't like the battery indicator thing, so I reverted back to Galaxo I didn't feel like changing the launcher and using metamorph to change the battery indicator.
  17. mitmeister

    mitmeister Newbie

    Hi Guyz,

    Updated to galaxo x.4. good to see updates still for galaxo. I took a Linpack score and returned

    MFLOPS: 2.895
    Time : 28.96 Sec

    Daily USE
    MFLOPS: 0.605
    Time: 138.51 sec

    using overclock widget. Anybody got better result with Galaxo 1.6.3.x. Fimware is Donut.JC6.
  18. bresslau

    bresslau Member

    It is certainly possible to install over without a wipe and without loosing settings and apps. I was also able to install an ADW version on it.

  19. mitmeister

    mitmeister Newbie

    Follow the Easy updating to GALAXO and dont do the factory wipe. Apply any ZIP from SD update for GAPPS instead of Samsung.TAR . All your settings stay as such. In simple words,

    1) Fix package permissions!!!
    2) Apply update.zip (Considering you are in Recovery 6.1 and have taken nandroid backup)
    3) Reboot again into Recovery mode.
    Fix package permissions!!! again just in case
    Apply any zip from SD - select GAPPS.
    6) Reboot you are in and settings stay as such.

    DarkSense theme
    DarkSense2.0_ADW-Standard.zip (Standard ADW Launcher 0.8.2)
    2) DarkSense2.0_Advanced-Standard.zip (Advanced Launcher with DarkSense Style)
    works fine for sure (Fix package permissions!!!) and even your settings for the theme stay.

    Cheers and Enzoi Galaxo
  20. avatar1983

    avatar1983 Lurker

    So I re-downloaded DarkSense2.0_Advanced-Standard.zip and it worked - I guess it must have been corrupted somehow. Which is pretty unexpected, since I was able to open it wit winrar and look around inside the zip.

    But whatever, it worked now, so I'm happy.
  21. Bomberman

    Bomberman Android Enthusiast

    Anyone noticing quite a bit worse battery life with the new version? Seems a fair bit worse for me :(
  22. weasel

    weasel Android Enthusiast

    I think I already know the answer, but is there a way to download these straight to the SD card ?? My dial-up is being very cranky this morning. I might get the recovery to download, but the rom could take until Christmas !
  23. Caroliano

    Caroliano Lurker

    avatar1983: did you reboot right before installing the Darksense theme?

    For instaling JIT and Darksense in galaxo, it seems that only this strict order works:

    1- wipe
    2- galaxo
    3- restore G.Apps
    4- boot like normal, configure market and turn-off.
    5- enter in recovery
    6- Fix premissions
    7- install JIT.
    8- boot like normal, delete /system/app/Lancher.odex with root explorer or:

    conect via ADB e type:

    adb devices
    adb remount
    adb shell rm /system/apps/Launcher.obex
    adb shell reboot

    9- enter in recovery
    10- install ADW

    I haven't tried this yet, I took it from brazilian galaxy list, and I don't know if galaxo changed anything
  24. crixalis

    crixalis Newbie

    gps still not working.. same problem like 1.6.X.X
    after installing gps work ok and after 2-3 days no satellite
  25. cyclometh

    cyclometh Lurker

    I didn't like the new indicator either. However, changing the indicator back to the original can be done by copying /system/framework/framework-res.apk over from I found out /data/dalvik-cache/ needs to be cleaned when doing this.

Share This Page