1. Download our Official Android App: Forums for Android!

ROM Manager Help!

Discussion in 'Android Apps & Games' started by mnt23, Sep 19, 2011.

  1. mnt23

    mnt23 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Sep 19, 2011

    Sep 19, 2011
    6
    0
    5
    Hi,

    I recently decided to root my Desire and install a custom ROM. All working fine, have installed leedroid 3.0.8.2

    However i wanted to partition my SD card, but unfortunately ROM manager hasn't been working. Whatever i do i get the same error, whether it was trying to set up a recovery backup or partition the SD card. It goes to the recovery screen (the black one with green text) and then says:

    ClockworkMod Recovery v2.5.0.7
    Waiting for SD Card to mount (20s)
    SD Card mounted...
    /tmp/recovery.log was copied to /sdcard/clockwor
    kmod/recovery.log. Please open ROM Manager to report the issue.

    This wasn't a problem before, as i could set up a backup just using the recovery menu. However I can't partition the SD Card.

    I've had a look for some soultions, most involve wiping the data & cache or reinstalling ROM Manager. Also, someone has suggested that syncing with HTC Sync v3 but none of these things have solved the problem?

    Has anyone got any thoughts?

    Cheers
     

    Advertisement

  2. Casual Pete

    Casual Pete Android Enthusiast
    Rank:
    None
    Points:
    78
    Posts:
    546
    Joined:
    Apr 27, 2010

    Apr 27, 2010
    546
    84
    78
    England
    mnt23 likes this.
  3. mnt23

    mnt23 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Sep 19, 2011

    Sep 19, 2011
    6
    0
    5
    Thanks! Hopefully i haven't done anything too untoward with ROM Manager :p
     
  4. mnt23

    mnt23 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Sep 19, 2011

    Sep 19, 2011
    6
    0
    5
    Just for completion:

    Using GParted turned out to be extremely simple, not sure why a lot of forums etc. say that ROM Manager is much easier. It also gives you a lot more control, I knew exactly what it was doing all the time, which is always nice.

    One thing which I haven't seen mentioned anywhere is specifically to put the backup of your SD card back onto the fat32 partition before remounting the SD Card in your phone. Makes sense, but first time I didn't do this and got a message on the phone asking me to re-format the SD card, obviously losing the partition.
     
  5. Intruder

    Intruder Android Enthusiast
    Rank:
    None
    Points:
    58
    Posts:
    345
    Joined:
    May 26, 2010

    May 26, 2010
    345
    16
    58
    Bradford UK
    Moral to the story I learnt a while ago.... Avoid Rom Manager at all costs !!!
    Using it is only laziness which we are all guilty of from time to time
     
  6. mnt23

    mnt23 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Sep 19, 2011

    Sep 19, 2011
    6
    0
    5
    Although, having partitioned SD card, was able to install apps i previously was being told i had no space for, mainly Swype, and also my contacts all got their pictures linked with Facebook etc.

    However have just tried to install Spotify and have already been told i've run out of space? Gave the ext3 partition on my SD card 1GB space, can't have run out already? Don't have any applications larger than 25MB and the only one that large are my contacts.

    On closer inspection, in the applications manager on my phone it lists the internal storage as 138MB used, 9.4MB free and the SD card as 3.7GB free (the full size of my SD Card). When i connect to my PC and mount it as a Disk Drive the size that my computer sees is 2.7 GB, so the partition is there, but seemingly not being recognised by my phone?

    Am going to have a look around to see if anyone else has had this issue, but if in the meantime anyone happens to notice this post and ahve a solutio i'd be more than grateful ;)

    Edit:> Having had a look around, i get the impression that A2SD should happen automatically? However a lot of threads said i should flash the ROM I wanted after I partitioned the SD Card. I tried to do this, however in the recovery menu, when I tried to select the file from the SD Card it said no files found. I then mounted my SD Card through the recovery menu and what i saw on it was totally different to before, lots of folders and files named with unrecognisable characters. Tried putting the .zip file for Leedroid on there, but when i then went to look for it again the phone still said it couldn't find any files.

    Edit2:> Formatted the SD Card to start again. Partitioned it, as before, then put the backup (which only had the files that the phone puts on the SD Card when it formats it) and the leedroid .zip file. Restarted the phone straight into recovery mode and was able to flash the ROM and since then phone recognises partitions properly and it seems to be going fine, hopefully, problem solved.
     

Share This Page

Loading...