1. Check out our companion app, Forums for Android! Download from Google Play

ROM manager signature varification failed-unable to backup

Discussion in 'Android Devices' started by shreybhatia, Oct 16, 2011.

  1. shreybhatia

    shreybhatia New Member
    Thread Starter

    Oct 16, 2011
    i have been through all the related posts about same situiation in different devices . and now im HIGHLY CONFUSED !

    i'm in procedure to install MIUI custom ROM to my samsung galaxy s2 ((BUILD-gingerbread.xwkf3, kernel- ROOT@DELL101 #2 ))

    what the sequence i have followed till now-
    1] replaced kernel with insecure XWKF3 kernel using odin3-v 1.85
    2] used S2Root 1.4.3 TO root my phone
    3] downloaded ROM manager, Titanium backup . did titanium backup of my applications successfully
    4] tried to use ROM manager for nandroid backup, >> flashed clockworkMod recovery. then selected reboot into recovery and what i see
    Installing oackage
    finding update package...
    opening update package...
    verifying update package...
    E:failed to verify whole-life signature
    E: signature verification failed
    Installation aborted
    i rebooted phone, using the option mentioned there
    PS-i see no option for backup and recovery to select with volume up and down keys as mentioned in procedure

    5] I replaced my insecure kernel with original one related to my build
    6] i tried again with ROM manager , same condition
    7] used quick root to start into recovery page , its successfully applied multi-CSC , but still i see no option for backup and recovery

    now i have read certain posts, and they have given solutions, that i can't understand a bit
    i can't stick the links as its my 1st post but the have given the solutions like
    >>>HI, this is because your now running the 3e recovery,

    look into the cf-root kernal, this includes root and the 2e recovery.

    This will fix it for you.

    You will also be able to add a lagfix to your froyo aswell, I myself use this kernal
    >>.have u try to copy downloaded ROM to Internal Storage? then reboot to CWM and install zip from sdcard>choose directory.

    I fixed that problem. Simply select apply sdcard:update.zip
    Then reboot
    Open Root Manager
    Select "Backup Current ROM"
    (may be you should reboot)
    Thats all. Goog luck!

    i thing the last one is the solution, but im not sure if i should do it or not, will i lose my data? what does this option actually mean ?

    i have no idea what is CF-root and update.zip where is internal storage , whats sd card, and how to mount sd card to phone and many other terms, im hella frustrated now :( :(

    please do something !


  2. Mcyber

    Mcyber New Member

    Aug 13, 2011
    shreybhatia, I am new on this forum therfore I can not post links.
    Email me, miha.cyber@gmail.com

    I had totaly the same problem.
    Here is my solution.

    Flash CWM through the Odin.
    Here are the instructions:
    I can not post links...so email me.

    My phone was already rooted so i didn t use Superoneclick from the poste.
    You can flash Roms, do bacups....the same thing as with Rom Manager throuh CWM (ClockworkMod-Recovery).
    dlee1975 likes this.
  3. Slug

    Slug Check six!

    Aug 1, 2009
    Mobile phone retail
    Inverness, UK
    No need to post links.... all the necessary info is linked in the S2 Rooting Guide at the top of the page. ;)
  4. Rudedawg

    Rudedawg Well-Known Member

    Jun 24, 2011
    Southampton UK
    I too had the same errors from Rom manager. I uninstalled and went back to CWM. I was using VillainRom at the time...at least untill I part/bricked the damn thing hehe.
  5. dlee1975

    dlee1975 New Member

    Oct 25, 2011
    Hello Miha/Shreybhatia, I am almost in the same exact situation as Shreybhatia, same everything. I would be very greatful if you either one of you could please forward to me the explanation of how to fix. I have read through the admin posts referenced, but am still confused. If you could please email me an explanation at dleedlee1975@gmail.com it would be greatly appreciated.

    Thanks in advance.

  6. ironass

    ironass Well-Known Member

    Aug 17, 2010
    Keeping one step ahead of the Tax man
    Cotswolds, England
    Hello and welcome to Android Forums dlee1985. :)

    The instructions you require, and loads more information, are contained in the "sticky" at the top of the first page and entitled, "Samsung Galaxy 2 Root Guide" as mentioned in post #3 by Slug. See here:-


    contained in that is the guide "CF-Root v4.1" which is a step-by-step guide to rooting your phone and getting CWM Recovery. See here:-

    [19.10.2011][CF-Root 4.4] KE*, KF*, KG1/2/3/5/6/7, KH1/3/4, KI2/3/4/8 - su+bb+CWM4 - xda-developers

    I'm guessing that you may have been trying to use ROM Manager which can cause problems.

    Hope this helps. :D
    dlee1975 likes this.
  7. dlee1975

    dlee1975 New Member

    Oct 25, 2011
    Thanks Ironass/Miha, definitely appreciate the responsiveness and the help, now have MIUI ROM up and running! Cheers :D
  8. dlee1975

    dlee1975 New Member

    Oct 25, 2011
    And to confirm if anyone else is experiencing the same issues, ROM mgr was not working with the set up referenced previously in the thread, have to flash the new ROM using CWM, then worked perfectly.

Share This Page