1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Rom] [Stock] Jelly Bean 4.1.2 (M040)

Discussion in 'Android Devices' started by Doctoror, Dec 4, 2013.

  1. Doctoror

    Doctoror Well-Known Member
    Thread Starter

    Problems:
    1) Wi-Fi did not connect after password entered. Fixed by toggling Airplane mode.
    2) USSD requests return messages in unknown language
    3) In APN settings no "New APN" menu (APN can be set via "Offline SIM APN" converted to system app) thanks to ncdad1969's answer in this thread).
    4) Rooted via CWM root (link to root zip is in the description)

    CA-201L problems:
    1) Camera not working for some reason.

    Installation:

    1) If you are installing on C811 and upgrading from M020
    Install these at once, don't reboot until installed all zips.

    Install CA-201L_aboot.zip
    Install C811_M040_bootloader_no_aboot.zip
    Install baseband_M8960A-1.5.38_C811M040.zip
    Install C811_M040_system_boot.zip

    Noob steps:
    The extended steps will be.
    1) Put CA-201L_aboot.zip, C811_M040_bootloader_no_aboot.zip, baseband_M8960A-1.5.38_C811M040.zip and C811_M040_system_boot.zip to Internal Storage or SD Card.
    2) Flash Clockworkmod recovery using Flashify. This will replace your stock recovery with one that has more features.
    3) Then boot into Clockworkmod using adb. To do this,
    Turn on USB debugging in your device (Settings -> Developer Options -> USB Debugging), install the drivers to your PC, install adb (and you can take a look at the brief tutorial) Connect the device to a PC, open command prompt as administrator and type
    Code (Text):
    1.  
    2. adb reboot recovery
    3.  
    command and hit enter.
    If you get "adb is not a command" - it means no adb in your PATH, google around and you will get how to fix it.
    If you get "device not found" - no drivers or bad drivers or you forgot to enable USB debugging or the phone is not connected or not powered on.
    4) After it boots to Clockworkmod, choose "install zip from sdcard" (or external sdcard if the files are on SD Card), install the files in sequence in which they are listed on this post (actually sequence doesn't really matter, but I would go flashing starting from bootloader :) ).
    Clockworkmod guide
    5) Go back to main CWM menu, choose wipe cache, wipe data / factory reset, then choose advanced -> wipe dalvik cache.
    6) After that you can choose "reboot system now".

    2) If installing to CA-201L
    Install C811_M040_system_boot.zip

    3) If you already running C811 M040 and just need to recover stock M040 system
    Install C811_M040_system_boot.zip

    Mirrors:
    CA-201L_aboot.zip
    C811_M040_aboot.zip
    baseband_M8960A-1.5.38_C811M040.zip
    C811_M040_bootloader_no_aboot.zip
    C811_M040_system_boot.zip

     


    #1 Doctoror, Dec 4, 2013
    Last edited: Nov 28, 2014
  2. Best Answer:
    Post #5 by thamkt82, Dec 5, 2013 (1 points)

    1. Download the Forums for Android™ app!


      Download

       
  3. rjglenn

    rjglenn Android Enthusiast

    Somebody needs to try this. I tried a different one this morning, it did not go well, which is okay because the phone was borked anyway. Next...
     
  4. unitypunk

    unitypunk Android Enthusiast

    im too busy the next few days to attempt, sucky
     
  5. rjglenn

    rjglenn Android Enthusiast

    124 views and no reports? Come on guys, somebody step up and take one for the team. This is for folks who are running the CWM recovery. You are already off the update path and are going to have your phone replaced to run 4.1.2, which BTW runs great on this phone.

    Doctoror is our developer, he lives in Ukraine. Surely you all have seen the news reports about what is going on there. Imagine spending one month's salary on any single purchase and then having it break. He wants Jellybean on his phone but breaking it means he just lost something that he paid a ton of money for.

    It's easy for us to get a replacement. Place the call, jump through the hoops, and the next business day FedEx is at your door. Doesn't work that way for Doctoror...
     
    Doctoror likes this.
  6. thamkt82

    thamkt82 Newbie

    @doctordor
    Was up rom in CA201L ok .... How to install CWM recovery and setting FC bug fix
     
  7. xmguy1

    xmguy1 Well-Known Member

    I'll give it a try. I'm gonna see if I can get by without wiping all my data. Worse case I go back to recovery and restore my current cwm backup. I'll report back. However I'm in situation where I can't get a replacement either from Verizon. But seeing its in CWM I don't have much to loose.
     
  8. nobitapr

    nobitapr Newbie

    I'm up rom complete to CA-201L. But it have some error:

    1. Can't connect wifi (I'm trying in my home again)
    2. Can't add APN in Mobile network settings
    3. It's show messenger Warning: (loop about in 5 min)
    Warning
    This SIM card is from an unknown source.
    4. I'm get unknown language messenge when i excute *101#

    P/s: I can call and receive calls

    [​IMG]

    [​IMG]

    [​IMG]
     

    Attached Files:

    Doctoror likes this.
  9. i up room c811 M040( no recovery) and my phone is bootloop at now loading screen. please help me
     
  10. Doctoror

    Doctoror Well-Known Member
    Thread Starter

    Hi. Thanks for the feedback.

    "This SIM card is from an unknown source." is a problem with all Verizon ROMs.
    It can be easily fixed
    http://androidforums.com/casio-g-zo...oming-calls-sim-unknown-source-popup-fix.html

    About the WiFi and other stuff, maybe it woun't work with CA-201L. The ROM was made for C811.
    My Hardware version is 1.1, and I see yours is 0.3.
    The only thing that I think might help is installing all partitions from C811 to CA-201L (currently in zip there are only updated ones)

    I will post a ZIP with rest of images after I receive them so you can try it on CA-201L.
     
    thamkt82 and nobitapr like this.
  11. Doctoror

    Doctoror Well-Known Member
    Thread Starter

    What phone do you use, is it CA-201L or C811?
    Did you install it via CWM?
    Have you performed factory reset and clear cache and dalvik cache after installing?
     
    lehoanghiep_1112 and thamkt82 like this.
  12. Doctoror

    Doctoror Well-Known Member
    Thread Starter

    Alright, I've got exactly the same problems.
    Wi-Fi works after you trigger Airplane Mode.
    Maybe it's due to that I've had Korean initialization_410_tool installed before.
    I will try flashing the non-updated partitions after rdwilson or someone else provides me.
     
    nobitapr and thamkt82 like this.
  13. nobitapr

    nobitapr Newbie

    1. Wifi ok at home
    2. Can't add APN in Mobile network settings
    4. I'm get unknown language messenge when i excute *101#

    Thanks Doctoror :)
     
  14. rjglenn

    rjglenn Android Enthusiast

    I was not able to get the wifi to work on the US Verizon C811 after flashing the 410 tool, or the 470 for that matter. Once we flashed the C811 images my wifi worked. There must be something in the 410 tool that messes up all the radios in the US version of this phone.
     
  15. nobitapr

    nobitapr Newbie

    I can't connect wifi at company. I'm setting manual wifi to static ip and set DNS is 8.8.8.8. It's work to me. Hope it work for your case.

    P/S: I'm connect wifi at home success with dhcp
     
  16. motumbo

    motumbo Member

    Ok. I could confirm this zip file works like a champ. No issues except those already mentioned here. Please have in mind that updating takes a long while, for me it was almost 15 min. Use a stopwatch.

    Edit: In fact the no "new apn" setting is not really an issue, it is, in my opinion, a new VZN trick to make it harder to use phone in GSM mode.

    Edit2: I started to have battery issues after update. I installed Better battery stats and it seems the problem is a partial wake lock named audio out. Googling it I found it could be cleared out turning sound off, rebooting phone and then enabling sound back after reboot. It worked for me.
     
    piludo36 and nobitapr like this.
  17. rdwilson

    rdwilson Newbie

    PM me with what you need and I will do my best to get it to you.
     
    Doctoror likes this.
  18. Doctoror

    Doctoror Well-Known Member
    Thread Starter

    Thanks. You already gave me that after I posted this message. It didn't help.

    Maybe it's a problem all of you stock OTA guys have but aren't aware because you don't use GSM?
     
    thamkt82 likes this.
  19. motumbo

    motumbo Member

    I'm a gsm user and I have no issues after flashing your jb rom. What issues are you talking about?
     
    thamkt82 likes this.
  20. Doctoror

    Doctoror Well-Known Member
    Thread Starter

    Executing USSD codes return strange result in unknown language. As mentioned by nobitapr:

    [​IMG]

    My provider's USSD code for balance is *100#. Instead of balance message it returns something similar

    [​IMG]


    Yes, my locale is en_US.
     
  21. motumbo

    motumbo Member

    I have that issue too. But gogling it I've found that this bug is also an android bug and it is called dial pad bug. I had issues before in 4.0.4 dialing my voicemail number *123 I had to dial +*123
     
  22. rjglenn

    rjglenn Android Enthusiast

    Perhaps it is set up differently than what you are expecting.

    On verizon, when we dial USSD codes we get a text message. For example, if I want to check my account balance the phone places a call and I get a voice message thanking me for calling and telling me to check my phone for a free text message with this information, and about that moment I get noitification of an incoming text message.

    If the phone is programmed to place a call to VZW here in the US to obtain that information it going to certainly fail.

    Or maybe not, I'm speculating...
     
  23. nobitapr

    nobitapr Newbie

    Update: Reply SMS is ok by using Hangouts.

    Two error is:

    2. Can't add APN in Mobile network settings
    4. I'm get unknown language messenge when i excute *101# (I'm calling 901 to do same thing so this error no big problem)

    Thank all!
     
  24. thamkt82

    thamkt82 Newbie

    Hi
    2. Can't add APN
    ---> Install HiAPN Global set APN is ok ....
     
    nobitapr likes this.
  25. Doctoror

    Doctoror Well-Known Member
    Thread Starter

    I haven't found anything like this in google.
    Well, adding + at the beginning of USSD for me results in "Invalid MMI code" message.
     
  26. motumbo

    motumbo Member

    As I told you this issue has to do with operator configuration. I've seen in Google people with Windows phone complaining about same issue. Adding a "+" worked for me to get into my voicemail in Movistar Colombia but I've this problem with phone out the box, here in Peru where I'm now with Claro I cannot use ussd to check balance. I tried adding plus, swapping star for pound and it doesn't work.
    Summarizing this issue is not your update's fault it is part of the upgrade as well as the apn editor disabled.
     
    Doctoror likes this.

Casio G'Zone Commando 4G LTE Forum

The Casio G'Zone Commando 4G LTE release date was April 2011. Features and Specs include a 3.6" inch screen, 5MP camera, 512GB RAM, processor, and 1460mAh battery.

April 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...