1. Are you ready for the Galaxy S20? Here is everything we know so far!

[ROM] The Fourth (and Final?) Wave | Droid Incredible

Discussion in 'Android Devices' started by adrynalyne, Aug 28, 2010.

  1. adrynalyne

    adrynalyne Android Expert
    Thread Starter

    This is not unlike my previous “wave” series roms. Its just the stock 8/26 (official?) leak with tweaks.

    Changes since Third Wave:

    Pulled directly from RUU, deodexed, zipaligned, rooted and busyboxed (is that a word?)

    Backup Assistant removal script removed—Moved BA and service to /data/app for easy uninstall.

    3G Hotspot removal script removed –Moved 3G Hotspot to /data/app for easy uninstall.

    Latest super user 2.3.4 from Chains DD.

    New script added (but not made by me): fix_permissions. You can run this via adb or terminal emulator. Fix permissions will not work from ROM Manager with bash shell.

    Nano text editor added.

    custom kernel, stock speed, conservative governor set by default. SetCPU can return it back to on demand, if you wish. Kernel also supports wired tethering.

    Basic file Manager add to /data/app/.

    Latest flash added to /data/app/.

    Spare Parts added to /data/app/.

    QuickOffice added to /data/app/.

    Pdf Viewer added to /data/app/.

    chrometophone added to /data/app/.

    Link: http://adrynalyne.us/files/roms/sw/fourth.zip

    MD5: 681D591827F8F02AAB040AE5B2ADB232

    1. Download the Forums for Android™ app!


  2. Timbo2969

    Timbo2969 Newbie

    Any chances of a Frankenrom B7 based off the new leak?
  3. Two_cents

    Two_cents Well-Known Member

    I got a quick question... what would be a reason I would need to run "fix permissions"? I have run all your roms and have searched but all I see is people asking why it wont work... what exactly does it do for me? I have never had a problem where I would have to fix permissions maybe?
  4. Two_cents

    Two_cents Well-Known Member

    wow my first error... blah...
    E:no space left on device
    E:error writing boot
    E:failure at line 96

    maybe I got the wrong md5.. how do I check it?
  5. lafester

    lafester Android Enthusiast

    Thank you for confirming my error.
    I just redownloaded and am going to try again.

    edit -- same thing with new download
  6. Two_cents

    Two_cents Well-Known Member

    i'm going to give it a go after work... nandroid back to 3rdwave... I dont know why I even want to upgrade it works great I'm just a flashaholic I guess
  7. mikehippe

    mikehippe Lurker

    I got the same errors and am booting backup........

    edit: same errors again, but seemed to boot fine.....
  8. lafester

    lafester Android Enthusiast

    Just fyi you don't have to restore backup after the failed install.
    It will take an extra minute or two to boot but it will be ok.

    (tried installing four times now lol)
  9. Muerte_X

    Muerte_X Member

    I got the same error. I went ahead and let it boot...thinking it would just be a wiped version of the old ROM I had (second wave) and I could check/redownload the file. The MD5 does match.

    I have the newest clockwork and the 2.15 radio, and S-off.

    But, It actually looks like it worked. At least as far as I can tell. The build # is 3.21.605.1 and so far, the few things I've tried have worked. The apps all seem to be there. I guess I'll go ahead and continue setting it up and see what happens. I always have my nandroid if it craps out, lol.

    Edit: Just to update, I've been using it since I posted earlier with no issues. I guess even with the error, it still worked. Changed over to the King Kernel BFS#1 and installed the smooth icons with the transparent notification bar. I miss the stock sms, but I guess it was causing problems. My quadrant scores and Linpack scores are a bit higher than when I was using the Second Wave :) I noticed the flash works a lot better in this build, the phone will wait a few seconds and adjust to the flash before it takes a picture. So now things don't get washed out by the flash when you take a picture close. (I don't remember any other 2.2 builds doing this, but I could be wrong)
  10. roninld

    roninld Member

  11. Timbo2969

    Timbo2969 Newbie

    Adrynalyne has addressed this issue on his blog here. This is what he has to say:

    "This apparently is needed for some of my ROMs, so I am providing it to you. It is installed via HBOOT, and requires s-off. MAKE A NANDROID BACKUP BEFORE FLASHING. You may need to restore it after."

    Here is a direct link to the hboot .92 file, but I would go to the site instead.

    Thanks again for the prompt response Adrynalyne.
  12. adrynalyne

    adrynalyne Android Expert
    Thread Starter

    Yes, as soon as I can get to it.
    Damn_Smooth, crimton, gadget! and 3 others like this.
  13. adrynalyne

    adrynalyne Android Expert
    Thread Starter

    It can help with force closes and such. Random things. Kind of like a chkdsk in windows. Nice to have but rarely needed :D
    Two_cents likes this.
  14. adrynalyne

    adrynalyne Android Expert
    Thread Starter


    I apologize about the whole install error bit. I worked with folks over IRC, and it only worked for those on the .92 HBOOT. I think its because I used the official RUU ramdisk for my kernel.

    Please let me know how it pans out after flashing HBOOT.
    Timbo2969 likes this.
  15. Timbo2969

    Timbo2969 Newbie

    I appreciate your dedication to the community. I know that you are in school now and time is crucial, but you still take the time to help us out with new roms. Good luck in school and again, thanks.
    adrynalyne likes this.
  16. Timbo2969

    Timbo2969 Newbie

    It's all good. As always, you came up with a fix.
    adrynalyne likes this.
  17. Two_cents

    Two_cents Well-Known Member

    I guess this answered my earlier question of if we will need the newer version of hboot.. thanks for the quick fix as always... might want to put in the first post about needed hboot.92 for proper install.. it only took 2 seconds to install it
  18. lafester

    lafester Android Enthusiast

    Just be careful with this hboot file.
    I was coming from stock (s-off only) and the phone will not boot with this version.
    Not a big deal if you have a micro sd reader on your pc but just to let people know you should have clockwork installed before using this.

    on the plus side the rom just loaded up and now i get to play with it :)

  19. xkingofgodzx

    xkingofgodzx Android Enthusiast

    I installed this the other day and wow, its a lot better than the third wave. everything feels more responsive and its really snappy. I did re-download the kingkernel though so i could oc. I only have one issue and im sure this is an easy fix, backup assistant keeps force closing on me. Anyone know what to do?
  20. Timbo2969

    Timbo2969 Newbie

    I tried to record a video earlier and I selected "720p". When I went back to check the settings, "720p" was no longer an option. It was totally gone. Does anyone know the fix for this?

    Edit: Nevermind. It was because I selected "H.264" after selecting "720p". You have to keep it on "MPEG4" if you want "720p". I learned something new today. I don't mess with the camcorder too much. I was just trying to get some footage of my grandson.
  21. mangler1055

    mangler1055 Member

    where is the fix_permissions file? and how do i execute it? i'm at the shell via adb, but not sure what to do next. thanks.
  22. kuykendallc

    kuykendallc Newbie

    I was getting the same thing and ran the Backup assistant zip located in the post of the 3rd wave. The force closes have quit since running that.
  23. xkingofgodzx

    xkingofgodzx Android Enthusiast

    Thanks for yhe help, the .zip was actually located in the second wave though.
  24. Adamx

    Adamx Android Enthusiast

    does hulu work with this rom?
  25. Deleted User

    Deleted User Guest

    I flashed this ROM and everything worked great except on the home screen it will not show my location and weather. I just see the time and it says "My Location" under the time. First I thought it was GPS not working. I opened Maps and it worked just fine. Locations is activated. I have found no obvious setting not checked. Is there a setting to be checked that I am overlooking? I have the exact same issue with Sky Raider 3RC3 as well.

HTC Droid Incredible Forum

The HTC Droid Incredible release date was April 2010. Features and Specs include a 3.7" inch screen, 8MP camera, Snapdragon S1 processor, and 1300mAh battery.

April 2010
Release Date
Similar Threads - ROM Fourth Final
  1. Little_Ad 1059
  2. SquiddyKat
  3. Yesi Trotamundos
  4. Yesi Trotamundos
  5. Yesi Trotamundos
  6. kumaranil13k
  7. kumaranil13k
  8. 67defalt
  9. RianRusdani
  10. 14km

Share This Page