1. Are you ready for the Galaxy S20? Here is everything we know so far!

Root access not working fully?

Discussion in 'Android Devices' started by jfix71, Nov 3, 2010.

  1. jfix71

    jfix71 Lurker
    Thread Starter

    Disclaimer: I'm pretty new to Android rooting, and just found this awesome site!

    So I tried to root my Incredible using unrevoked3 while using 2.1update1. I did this before having come to this site and hadn't seen the thread on here describing all the steps necessary to do after running it. I didn't think it was working, so I manually installed 2.2, and then reran unrevoked3. Just mentioning all this in case it could have messed up unrevoked3 once it was ran the 2nd time.

    Right now (I think?) I can get su access when running the terminal emulator on my phone; the # comes up when I execute "su", and I can then execute commands. However, when I run adb (Windows 7 command prompt, run as admin) I can't type anything once I try to get su access, though it does show a #:

    C:\>adb shell su

    It just sits there and I can't type anything... Once I ctrl+c out it will then execute anything I tried typing while it was sitting there in the normal command prompt shell.

    I've read that this may be because "if my boot.img has ro.secure set to 1, it drops permissions after it loads". This doesn't mean much to me :) just sounded like it could be right?

    Thanks for your help!!!

    1. Download the Forums for Android™ app!


  2. andreezy

    andreezy Well-Known Member

    wouldn't it be...

    adb shell <enter>

    su <enter>

    and if you are rooted, it would change the prompt to a:
    # sign
  3. jfix71

    jfix71 Lurker
    Thread Starter

    ::facepalm:: Yes that worked, thanks! I still have some other troubles though, for example if I try to remount, I get:

    C:\>adb remount
    remount failed: Operation not permitted

    Which leads me to believe that I don't have certain privileges I should... And if I try adb root:

    C:\>adb root
    adbd cannot run as root in production builds

    This is part of what leads me to believe I am having the problem with the OS resetting some permissions or something as my initial post indicated.

  4. REYES

    REYES Member

    Why do you need to run "adb root" command? and what does the "su" command do? I have done a lot of shit with my phone and am confused as to why you need to do this. Please elaborate? Thanks.
  5. andreezy

    andreezy Well-Known Member

    Basically, after you type the SU command, and it gives you the pound sign, it lets you perform commands the normally aren't allowed. Be careful with what you are doing, though. that's why it is protected in the first place (well, besides big red being able to stop you from using your phone for what you want to use it for without additional charges, ie wireless tether).

    You can do serious damage poking around in root particularly using MV and RM statements.

    Once you are rooted, and have utils like clockwork recovery, and apps like rom manager, it (for the most part) handles all those root commands for you, such as mounting, remounting, etc. The only other real reason to use adb root shell is to manually change your bootanimation, sound, or enable/disable blaotware apps that get thrown in there by the carrier.

    If you end up loading something like virtuous rom, great rom devs like RMK and adrynalyne have toggle scripts to help you perform these adb duties programatically, seriously reducing the chance of less experienced users really horking things up...

    and don't get discouraged... I was you about 160 posts ago... there's so much to learn here at AndroidForums!

    Hope this helps a little...
  6. jfix71

    jfix71 Lurker
    Thread Starter

    I'm attempting to install Superuser on my phone but it keeps failing. I followed their link to try to this forum post (scroll down past the QR code) and am trying to execute the adb commands to make it so that I can install it (I didn't want to try doing it on the phone's terminal because I don't know the specific line/directory I need to remount for my phone, as the dev mentioned it varies per phone). Since when I try to do adb remount it says permission denied, I was trying to do adb root because I thought it may allow me to then run adb remount.
  7. REYES

    REYES Member

    OHHH, you're talking about prior to rooting. I'm an idiot. I already know about all that garbage as I use CWM to mount and unmount system/data/sdcard etc and remove apps/unwanted crap and add ringtones and all that jazz.

    I was thinking something different.
  8. iowabowtech

    iowabowtech root@android:/ #

    I'm confused now. I thought you already ran Unrevoked and obtained Superuser priviledge? (SU = #)

    Did they change something with Unrevoked so it doesn't drop SU into the app drawer autmatically? Been a long time since I actually messed with the rooting process, maybe I'm remembering it wrong.
  9. jfix71

    jfix71 Lurker
    Thread Starter

    Yeah so I did run unrevoked3, I do think I get SU, I do get the #, but when I try to use adb it won't allow me to remount or call adb root (restarts the adbd daemon with root permissions) which I was thinking would allow me to then remount. All of this was so that I could use adb to allow me to install the Superuser app. Is there a difference between having root access while in a terminal on the phone/through adb versus having the ability to remount with adb?

    Edit: to clarify, I have an app called "Superuser Permissions" which unrevoked3 did install, but I was hoping to install the Superuser app above which seems to be more useful/have better functionality than the one that came with unrevoked3. When I try to install it it fails, and they have instructions on how to fix this (scroll down to right after the QR), which requires that I use adb or a shell on the phone itself to run some commands. I was trying to not use the shell on the phone because the dev claimed that the line executed to remount varied depending on the device, and I didn't want to mess anything up!
  10. iowabowtech

    iowabowtech root@android:/ #

    Idk man, I use a cable and mount system via Clockwork, then run the commands in the command prompt on the PC.
  11. sdrawkcab25

    sdrawkcab25 Extreme Android User

    Isn't the updated version of superuser in rom manager?

HTC Droid Incredible Forum

The HTC Droid Incredible release date was April 2010. Features and Specs include a 3.7" inch screen, 8MP camera, Snapdragon S1 processor, and 1300mAh battery.

April 2010
Release Date

Share This Page