1. Are you ready for the Galaxy S20? Here is everything we know so far!

Root Root achieved

Discussion in 'Android Devices' started by n0tall0wed, Oct 12, 2013.

  1. n0tall0wed

    n0tall0wed Android Enthusiast
    Thread Starter


    Advertisement

  2. stevestone

    stevestone Well-Known Member

    Yes 100% working.. But still there are no people around for development. Its a lovely device.. Thank brother..

    I am trying to backup complete stock for our device.. If you are interested in development let me know..
     
  3. Akumin

    Akumin Well-Known Member

    Just wanna say Root worked 100% for me. Now question I'm coming from the EVO V 4G. I had that phone rooted and S-OFF. Will we need to S-OFF with this phone as well to flash new roms when they become available as devs start hopefully pumping out roms. by the way I am using the Virgin Mobile Supreme (ZTE Vital)
     
  4. stevestone

    stevestone Well-Known Member

    NO, s-off, kind of thing in ZTE. all phones are sold as unlocked bootloader.. virgin supreme & vital is same device. I guess difference is in carrier block..

    I have got partition infos for zte vital. also trying to dump complete stock rom..
     
  5. Shabbypenguin

    Shabbypenguin Extreme Android User

    oh dear lol, i meant to publish teh cwm i had for this device.

    anyone mind putting up a build.prop for this device?
     
  6. stevestone

    stevestone Well-Known Member

    Yes... I will
     
  7. stevestone

    stevestone Well-Known Member

    Link of build.prop for this device...

    https://db.tt/ZLqOT2z9

    I tried to contact you on irc channel... let me know if you need anything...

    Recovery.fstab file in case you need it..

    https://db.tt/Po6mJroC

    Thanks...
     
  8. Shabbypenguin

    Shabbypenguin Extreme Android User

    ok so it was a long time ago that i was screwing with this, i dont recall any bugs so please bear with me. if memory serves me right i couldnt get internal storage working in recovery. should go without saying by flashing this you put yourself at risk etc etc dont blame me if your girl leaves you for a newer phone etc etc.

    anyways https://mega.co.nz/#!4VAh1CxT!Nb7RTUvLU74RK5BOgsbh3QN2Hb9EPyUhIy1hf-qdjBs


    download teh file and name it recovery.img and put it so its in this location /sdcard/recovery.img
    adb shell
    su
    dd if=/sdcard/recovery.img of=/dev/block/platform/msm_sdcc.1/by-name/recovery
    reboot recovery

    youll find yourself in cwm 6.0.4.4 :) let me know of any and all bugs and ill try toi work em out.
     
  9. kdmstng66

    kdmstng66 Lurker

    Flashed this to my Virgin Mobile ZTE Supreme however when I boot into recovery mode I just get a black flashing screen and have to pull the battery to get out of it. Any idea what the problem could be?

    Thanks!!!
     
  10. junkie2100

    junkie2100 Android Expert

    i can tell you exactly what the problem is, that cwm was for the vital not the supreme. kernel is.likely different, if someone were to unpack the recovery i. the kitchen and replace the kernel with the correct one for the supreme itd probably work but as is it will probably not

    boost force and metro avid are nearly identical too, swap out the kernels and you can swap software all day with little problem, but straight avid recovery wont boot, you have to unpack and replace the zimage(kernel)
     
    kdmstng66 likes this.
  11. Shabbypenguin

    Shabbypenguin Extreme Android User

    id much rather build from source for the supreme than swap zimages and have mismatched stuff going on, if someone grabs me a copy of recovery.img from it ill whip it up quickly enough.
     
    kdmstng66 and junkie2100 like this.
  12. kdmstng66

    kdmstng66 Lurker

    So I assume I would need a stock recovery.img to restore the stock recovery on my ZTE Supreme now, or is there another way to go back?

    Thanks!!!
     
  13. junkie2100

    junkie2100 Android Expert

    yes you would need the stock recovery img its the only way to get it back that im aware of

    and thanks shabby, yea i wouldnt normally make a release that way but when making a simple test or for someone who isnt set up to build, unpacking and replacing the ramdisk in their recovery is easier

    if its anything like the avid/force the cwm/cm repos should be nearly identical, if you swap the kernel, we even used the same kernel source just switched from elden defconfig to hayes
     
    cerebrus21 and kdmstng66 like this.
  14. stevestone

    stevestone Well-Known Member

    This phone do not have any fastboot mode, its only have ftm mode. I tried to flash recovery from ftm mode through recovery....but i get not such file found read error... I m unable to mount sdcard for adm in ftm mode? As for survival, its da only way ?

    Any command to mount sdcard? Su works there??
     
  15. junkie2100

    junkie2100 Android Expert

    it does have fastboot mode, they all do. type
    adb reboot bootloader
    the screen will go to the green android guy you see when you first turn it on, thats fastboot

    as far as mounting sd it can be done manually but i really sont feel.like going through all that when all you have to do is boot into android and do.it from there
     
  16. stevestone

    stevestone Well-Known Member


    Hello, Thanks for building up recovery for vital but I tried to flash your given recovery on my zte vital, It doesnt worked. It gave me blank screen.. Then again i flash stock recovery..

    if you need anything please let me know ....


    abd reboot bootloader, Just gave a blank screen no green logo, only charging led, and no device detected on pc.. I tried with both volume key, it just qmload_usb, and detected it as DFU diagnostic port.. .... Till yet i m unable to find fastboot mode. If we are stuck on boot loops, this device will be hard to recover... :eek::argh::argh:
     
  17. Shabbypenguin

    Shabbypenguin Extreme Android User

    you flashed teh recovery and it isnt working?

    odd because i used this recovery a while back ago and it worked fine... i wonder if they changed sceens for production.
     
  18. stevestone

    stevestone Well-Known Member

    Yes :) maybe possible.. please let know sir, if you need anything.. or steps to make recovery?
     
  19. Shabbypenguin

    Shabbypenguin Extreme Android User

    well i need stock recovery dumped from teh device, it could be they changed teh panel and all i need to do is swap the prebuilt kernel. unfortunately since you flashed that yours has been replaced (unless you were super awesome and backed it up first? :D
     
  20. stevestone

    stevestone Well-Known Member


    HAAAA.. I alway backup my things first... ;) , I reflash my device to stock ;)

    https://www.dropbox.com/sh/rycikcvwmg1oz7x/U0AvfBIWw_

    stock recovery, boot.img, build prop and partitions info... ;)

    let me know if anything else.. THanks..
     
    kdmstng66 likes this.
  21. kdmstng66

    kdmstng66 Lurker

    I flashed your stock recovery back to my ZTE Supreme and got my recovery back and working again. :)

    Thanks!!!
     
  22. stevestone

    stevestone Well-Known Member

    Oh great... It means our recovery are same vital & supreme.. also in system.img i found all the 3 boot animation, virgin, sprint and metropcs...
     
  23. junkie2100

    junkie2100 Android Expert

    hey shabby, what is the codename on this thing anyway? like what defconfig would it use?

    ive got a hayes board recovery in the force, elden board is avid, and im working on a gordon. they all share the same basic kernel source and everything, so you may luck out and be able to use the same source those do for everything with a few tweaks
     
  24. junkie2100

    junkie2100 Android Expert

    somebody should upload a config.gz and a build.prop

    config.gz is in /proc
    build.prop is in /system
     
  25. Shabbypenguin

    Shabbypenguin Extreme Android User

    quantum, and it wouldnt really be lucking out for me. i have no plans to use source built kernel for cwm. prebuilt works fine enough for me :)
     
Loading...
Tags:

Share This Page

Loading...