1. Are you ready for the Galaxy S20? Here is everything we know so far!

Root arrives for 4.1.1, and 4.1.2

Discussion in 'Android Devices' started by Xelios, Apr 13, 2013.

  1. Xelios

    Xelios Android Enthusiast
    Thread Starter



    toya656 likes this.

    1. Download the Forums for Android™ app!


      Download

       
  2. pegs520

    pegs520 Well-Known Member

    I tried this and his bootloader unlocker.

    They both worked great. No problems at all for me.
     
  3. seVer

    seVer Android Expert

    isn't that special... have to sign in to get the file? crap.
     
  4. recDNA

    recDNA Android Enthusiast

    Is there a custom rom in which everything works 100%?
     
  5. pegs520

    pegs520 Well-Known Member

    Not that I've found. I'm sure we'll see one soon, now that the boot loader has been unlocked.

    I read that cm10 just had a few things missing, and that they're a lot closer to fixing it than they were before.
     
  6. recDNA

    recDNA Android Enthusiast

    Thanks. I don't need root access unless there is a custom rom significantly better than stock.
     
  7. Xelios

    Xelios Android Enthusiast
    Thread Starter

    Yeah for now there's no real need to unlocked the bootloader, but root gives you a lot of other options to mess with.

    Personally I'd avoid CM10 for now, it has a lot of issues. After running it for 2 days, I just couldn't stand it. 10.1 is missing the camera and NFC, so that one is considerably more stable, just missing a couple features. It's only a matter of time until we get full blown CM, and thats when it'll definitely be worth doing everything.
     
  8. recDNA

    recDNA Android Enthusiast

    Agreed, I hope the exploit still works. I don't like rooting stock because I fear a pushed update borking the phone. With a custom rom no updates. I wonder if cm10 makes use of dual processor when it does work.
     
  9. Xelios

    Xelios Android Enthusiast
    Thread Starter

    Rooting stock doesn't cause an update issue unless you start deleting bloat and stuff. Freezing it is better, but that can be done via JB anyway. My personal favorite thing to do with root was to adjust the LCD Density, so everything was much smaller on the screen. Stock looked way too large imo. Of course this causes an issue with the play store, so yeah, more issues abound.

    But yeah it works, don't think I've seen anyone have an issue. The sad part is, Rosenberg says that he might quit working on Moto devices since the exploits are becoming too difficult to find. So I guess if you don't do it before the update, you might be SOL in the future. Can't really blame the guy though. Fortunately rootkeeper kept root through the OTAs so far, so hopefully that keeps working.

    CM10 was using both cores but I don't know really what the hell it was doing. I think it was keeping them both on at all times, since my battery life was atrocious. It's just an experimental version though, and far from daily driver quality. But Hashcode is on it, so once the custom kernel and all is working, it should have long term CM support.
     
    recDNA likes this.
  10. zimmy

    zimmy Member

    Don't know what I'm doing wrong, but I couldn't get the exploit run.bat file to do anything. You are supposed to run the file from a pc right?

    I clicked USB debugging, ran the file, and it stopped after "daemon started successfully".

    So what am I doing wrong?
     
  11. recDNA

    recDNA Android Enthusiast

    Did you install the newest Motorola drivers
     
  12. zimmy

    zimmy Member

    When i plugged in the usb, it said windows was searching for drivers which it found and installed... Do you have a link i should use to find latest drivers?
     
  13. Xelios

    Xelios Android Enthusiast
    Thread Starter

  14. zimmy

    zimmy Member

    Hmmm.... Still not working for me. Says waiting for device, and when I try to run it a 2nd time it tries pushing the exploit, and then ends up saying "device not found".

    Am I missing something? I'm in USB debugging mode and have run the updated drivers...
     
  15. zimmy

    zimmy Member

    I decided to try using the Motochopper exploit from my work computer since it wouldn't work from home. Our corporate antivirus software wouldn't let me extract the files, saying there is a trojan virus in the pwn file?

    Any clue why that would be? Is the AV software mis-identifying something? (Or did I just install a virus on my home PC?)

    Mark
     
  16. Xelios

    Xelios Android Enthusiast
    Thread Starter

    Sorry, didnt notice the previous message. Dunno why itd be showing up as a virus, but it isnt for sure. Everyone else has had good luck with it. I can't really help you a whole lot as I haven't used this utility though. Try running it as administrator maybe?
     
  17. Lars

    Lars Android Expert

    Most Android/Linux exploits are trapped as dangerous. It's normal as it is by definition a way to break the OS. Even windows AV sometimes has them in their db.
     
  18. hawkeye7169

    hawkeye7169 Lurker

    Waiting for device...
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *
    That is the error I am getting on my macbook pro running mountain lion.
     

Motorola Droid RAZR HD / MAXX HD Forum

The Motorola Droid RAZR HD / MAXX HD release date was November 2012. Features and Specs include a 4.7" inch screen, 8MP camera, 1GB RAM, Snapdragon S4 Plus processor, and 3300mAh battery.

November 2012
Release Date
0
Reviews
Loading...

Share This Page

Loading...