1. Are you ready for the Galaxy S20? Here is everything we know so far!

Root Captivate with no USB cables. EASY

Discussion in 'Android Devices' started by enjoimark, Aug 11, 2010.

  1. enjoimark

    enjoimark Newbie
    Thread Starter

    Ok, I know there are tutorials on the root process with the "one-click" root, and some using your pc and USB drivers, and blah blah blah.

    This is the EASIEST way I think, and I just did it, so i know it works.

    I was at work today and I wanted to root my Captivate. All I have is my work pc, and my Captivate. No USB cables or anything. I had one powerful tool though... the Internet.

    You will need these 2 apps: Linda File Manager and Dropbox. Free in the Market.
    Go to Dropbox - Home - Online backup, file sync and sharing made easy. and download that to your computer. Sign up for it, it is cloud based file sharing. It's awesome, I use it every day. Already a user, great.

    On your pc, go download the root update file here: SGH-I897 Root Update.zip - File Shared from Box.net - Free Online File Storage

    Rename it to update.zip
    Open up your dropbox and put it in the "public" folder.

    Now on your Captivate, open up dropbox and sign in.
    Open the public folder and tap the file "update.zip" to download it.
    Now open up Linda file manager.
    Tap "SD card", open the folder "dropbox". open "public", then tap and hold "update.zip". Choose CUT.
    Now just hit the back button all the way back to the SD card.
    Tap the menu button, tap EDIT, then tap Paste.

    Close all apps.

    Turn the phone off.

    Now just boot in to recovery.
    Hold down both Volume buttons at the same time.
    While holding those 2 buttons, hold the power button down.
    ONCE THE WHITE AT&T SCREEN POPS UP, RELEASE THE POWER BUTTON, BUT KEEP HOLDING THE VOLUME BUTTONS UNTIL THE RECOVERY SCREEN SHOWS UP. (You'll know it when you see it)

    You will now see the recovery screen.
    Use the volume keys to scroll down to "reinstall packages", hit the power button to select it.
    Let it do it's thing.

    BAM. 1-2 minutes later, your phone is rebooted and you now have superuser in the app drawer.



    This seems a little lengthy, but if you are already a dropbox user, it will go by fast.
    I rooted my Captivate in less than 5 minutes.
     


    Shashmanshma and jdCaptivate like this.
  2. narcoden

    narcoden Newbie

    You can skip a bunch of the first steps... i simply emailed the update.zip file to myself from my PC and saved it onto my phone.
     
  3. enjoimark

    enjoimark Newbie
    Thread Starter

    Yea the really funny part is you can just use Browser on the phone to go to the link and download the file, then move it to the sd card.

    Didn't realize that until right after I posted this.

    I feel like a jackass hahahaha
     
  4. sgennuso

    sgennuso Newbie

    I read all kinds of articles on rooting the captivate, the easy way IS just emailing yourself the file and the captivate automatically saves it to the right spot. Then from there its less than a 10 sec root. Way easy....
     
  5. nluna87

    nluna87 Lurker

    This isnt working for me! can anybody help it just keeps saying that theres an error every time i select reinstall packages. please help ive been trying to do this all day. does the zip file need to be extracted before its transfered to the phone or not?
     
  6. sgennuso

    sgennuso Newbie

    Download the update.zip file and make sure it is named update. If you have previous update files saved delete them otherwise new file will be named update1. Email the update file to yourself and save it. Phone will automatically save it to right location. Reboot phone while holding both up &down volume buttons. Let go of power button when world phone logo pops up. Select reinstall packages and the phone takes it from there. Should take 20 seconds tops.
     
  7. sgennuso

    sgennuso Newbie

    If the above fails, download the free one click lag fix from the market. It has a one click root in the app. Works great. Good luck ;-)
     
    jdCaptivate likes this.
  8. Macaveli918

    Macaveli918 Lurker

    Everytime I try to reinstall the packages it says it can't and has bad written under it so idk what to do because I followed all the steps, please help.
     
  9. Macaveli918

    Macaveli918 Lurker

    now its saying

    E:Can't open /sdcard/update.zip
    (no such file or directory)
    installation aborted

    wtf! i tried to root once before but it didnt work so i already have a superuser permissions app but my phone isnt rooted could that be a problem?
     
  10. jdCaptivate

    jdCaptivate Android Enthusiast

    This is the method I used! Worked flawlessly (also following directions from others in the thread).

    Downloaded and installed Quadrant Standard Edition.

    Score: 2184
     
  11. okmonalisa

    okmonalisa Lurker

    rooted my captivate in 2 seconds with the lag fix. :p thank you so much;):rolleyes::cool:
     
  12. WigginLSU

    WigginLSU Lurker

    So I seem to be having trouble getting to the recovery mode, everything else is easy but no dice ont he recovery. I got my Captivate about 4 days ago and decided to root it this weekend. I've read re-read and watched videos on how to enter recovery mode, but my phone simply will not. Is there any way to root the phone without entering recovery mode? Or has anyone else had this trouble and noticed a better way to get into recovery mode?
     
  13. RulyLeviii

    RulyLeviii Lurker

    I'm having this EXACT same problem, if anyone knows how to fix this, please email me; elgar149@gmail.com
     
  14. RulyLeviii

    RulyLeviii Lurker

    YES! Thank you! I finally got my phone rooted because I saw your post and tried this. Literally, two seconds.
     
  15. reinbeau

    reinbeau Klaatu barada nikto

    Ryan's One Click Lag Fix definitely is the easiest way to root!
     
  16. burls

    burls Newbie

    so much easier than other ways ive tried!!!!
     
  17. AKA_Rizzo

    AKA_Rizzo Member

    If all I have is Launcher Pro and I DL this do I need anything else ?
     
  18. meglette

    meglette Lurker

    i have tried both ways, the long down load this download that way and then i emailed myself that zip file and downloaded it on to my captivate and when i "reinstall packages" on the recovery screen it says "signature verifiction failed, installation aborted". what do i do??
     
  19. beatdroppah

    beatdroppah Well-Known Member

    ummm are you on stock froyo 2.2? if so, i you may have to get a modded 3e system recovery installation. its a modded version of the stock recovery menu, and its modded so it skips the signature verification step. i had to do that on my stock 2.2 to flash serendipity the other day

    EDIT: to save you some time, here is the link to the modded 3e recovery thread on xda forums

    http://forum.xda-developers.com/showthread.php?t=909213&highlight=recovery+modified
     
    harlgal likes this.
  20. write.artie

    write.artie Newbie

    THANK YOU SO MUCH!!! My USB will only charge no data, which is why i needed to do it this way.

    THANKS AGAIN!!!!!
     
  21. i followed the steps that you listed and the file is on my phone and i renamed it update.zip and did everything correctley but when i went to reinstall packages it said the file didnt exist can you help me please if you can my name is dylan guillory look me up on facebook please and thanx
     
  22. bluetides904

    bluetides904 Lurker

    Will this app really work? The one click lag fix/one click root?
     
  23. bluetides904

    bluetides904 Lurker

    What is the easiest way to root this phone so I can unlock it to use other service? I have already prepaid $40 and ported my number over to a prepaid service and can't unlock my phone to use their sim card. Can someone help me on this? :(
     
  24. bolts2

    bolts2 Newbie

    I think you may find your answer in the link below, but I also need to unlock my phone for a similar reason and I want to know if you have to first unroot before unlocking? And then what unlock tool?

    http://androidforums.com/captivate-...uide-how-root-official-2-3-5-kernel-swap.html
     
  25. harlgal

    harlgal Lurker

    Well all was good until after I opened the zip file in dropbox...think that was ok but when I opened Linda File Mgr -->SD card there was no dropbox icon, nothing... so now I don't know what to do sitting here with phone wondering what the heck do I do now....??? Anyone with any quick thought??:thinking::thinking:
    Thanks!
     

Samsung Captivate Forum

The Samsung Captivate release date was July 2010. Features and Specs include a 4.0" inch screen, 5MP camera, 512GB RAM, Hummingbird processor, and 1500mAh battery.

July 2010
Release Date
0
Reviews
Loading...

Share This Page

Loading...