1. Are you ready for the Galaxy S20? Here is everything we know so far!

Root for Concord II - failed with Impactor, VROOT, Towelroot, baidu, framaroot or SRSroot

Discussion in 'Android Devices' started by JesseKnows, May 29, 2014.

  1. JesseKnows

    JesseKnows Member
    Thread Starter

    I got my Concord II yesterday. Looks nice enough. Camera has focus! Sounds plenty loud; enough so I installed Silent Boot to stop it annoying the family while I was tinkering.

    Unfortunately did NOT succeed to root with either Impactor, VROOT or SRSroot. Will wait a couple of weeks and look for success. Won't even try to unlock in case I need to return it - I really want root
     


    sur00t likes this.
  2. sur00t

    sur00t Newbie

    I tried Kingo root and it did not work on my ZTE Concord II (MetroPCS) phone.

    Hoping for root and unlock soon.
     
  3. JesseKnows

    JesseKnows Member
    Thread Starter

    More failures:
    baidu root 2.4.1
    framaroot
     
    sur00t likes this.
  4. bakageta

    bakageta Member

    I've had no luck with any existing root exploits, but there are a couple of vulnerabilities that have potential. The .asec vuln patched with 4.4.3 is a good candidate offhand. There was also a recent linux kernel vuln (CVE-2014-0196) that could have potential - I'm not seeing the z730 kernel source so I can't check further at a glance, but most of 3.4 was vuln so there's a possibility.

    Either way, we're going to need a new exploit thrown together, or a custom recovery. There's no problem getting various exploits onto /data/local/tmp and running them at least, it could be worse.
     
  5. NetSpeedZ

    NetSpeedZ Android Enthusiast

    Posting here in hopes someone will find root for the ZTE Concord 2 on Metro PCS and I will be updated soon with good news :)

    ------------
     
  6. bakageta

    bakageta Member

    Anyone had a chance to give Geohot's latest root a try? I don't have the phone on me to test, but if no one else gets around to it I'll try later this week. While it's targeted at the S5 devices, it uses a kernel vulnerability that was not previously exploited on android, exactly the kind of thing we're looking for.
     
    Lawrencecaples and JesseKnows like this.
  7. JesseKnows

    JesseKnows Member
    Thread Starter

    I tried towelroot from Geohost, does not seem to work - after it's done its thing (and the phone reboots) SuperSU does not find root.
    Is there some other step not mentioned?
     
    sur00t likes this.
  8. JesseKnows

    JesseKnows Member
    Thread Starter

    I gave up and returned my Concord II. Now using an LG L70. Unlocked and rooted in minutes.
     
  9. jumplove

    jumplove Lurker

    Don't gave up :c I needed this phone to be rooted :p
     
  10. Levi0187

    Levi0187 Member

    Is anybody getting close to finding a way to root this yet. Aren't the devs Android God's? Lol. (Ego boost) Don't let this crappy undercut be a tarnish on all your guys's abilities. First phone ever that I've been unable to find any root.
     
  11. trapaholic408

    trapaholic408 Newbie

    Assumed this phone would have root. Now all my titanium backups will have to wait :'( someone pls find a way to root this phone...
     
    rob nash likes this.
  12. trapaholic408

    trapaholic408 Newbie

    Bump bump bbbbbbbumpppp
     
  13. sur00t

    sur00t Newbie

    I really like this phone, just wish that unlock wasn't so expensive. The phone's currently $19 through MetroPCS.
     
  14. icey011

    icey011 Lurker

    BUMP! Please, I just need this phone rooted so I can tether.
     
  15. Krystal

    Krystal Lurker

    Somebody help us!!! Please! :(
     
  16. trapaholic408

    trapaholic408 Newbie

    now using lg l70 also rooted in minutes :))) sucks cause had to cough up 75$ for it ;\ but
    oh well... any one wanna buy my concord 2?
    ��
     
  17. rbheromax

    rbheromax Android Expert

    Look up towelroot. It should work for you guys as it works on EVERY device manuf < june 3 2014 (except last years motos and htcs with system partition locked through kernel)
     
  18. Krystal

    Krystal Lurker

    I just tried TowelRoot... installed fine and was able to run normally... But when i went to root, it said "this device isn't yet supported".
     
  19. jblazea50

    jblazea50 Well-Known Member

    Has anybody tried Cydia Impactor? I don't have this phone, but it has worked for almost everything so far.
    Cydia Impactor
     
  20. JesseKnows

    JesseKnows Member
    Thread Starter

  21. Levi0187

    Levi0187 Member

    I'm wondering, has anybody posted about this on any Linux forums ??? Some of those guys are pretty brilliant at finding backdoors in software and know Android better than one might think. I mean, it is Linux after all.
     
  22. vovachka

    vovachka Lurker

    any one succeed? Rooting it. Tried it with a number of tools without luck.
     
  23. cookiebrick

    cookiebrick Lurker

    Not sure if this will work, don't have the phone. I rooted an LG L34C from Straight talk using towel root I had to tap the top and change one of the numbers from a 1 to a 0 then it worked.

    Here are the instructions for LG L34C hoping they work for the concord 2 as well. Got the instructions from android central which were originally from androidarea51.

    1. First go to towelroot.com download tr.apk
    2. Install
    3. open towelroot and at the top it says welcome to towelroot, tap it 3 times.
    4. now you have a box that you can change the values of, enter the following value: 1337 0 0 0 4 0
    5. press make it rain
    6. youre rooted, but dont forget to install a superuser app before restarting phone or you may have to do this over i think.
     
  24. tresveces

    tresveces Newbie

    bump bump ... someone save us!
     
  25. Levi0187

    Levi0187 Member

    For crying out loud people, quit suggesting roots based on an LG success! This is not an LG and many LG's have been a fairly simple root on many models, so showing their success isn't making a statement to a root's ability.
     

ZTE Concord 2 Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...