1. Download our Official Android App: Forums for Android!

Root Root help needed

Discussion in 'Android Devices' started by bnkrupt, Jan 6, 2014.

  1. bnkrupt

    bnkrupt Lurker
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    8
    Joined:
    Jan 6, 2014

    Jan 6, 2014
    8
    2
    26
    Male
    Military
    Kansas
    This morning I tried to root my phone with unrevoked3. Everything was fine until the end, when it said "error: failed to get root. Is your firmware too new?" I have searched numerous threads, and the only one that may be of some help is one that said to restore phone back to factory settings. I haven't done it yet just in case there is another method. By the way I' am using a windows based computer.

    Thanks in advance, Mike.
     

    Advertisement

  2. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    Rank:
     #7
    Points:
    3,108
    Posts:
    27,243
    Joined:
    May 13, 2010

    May 13, 2010
    27,243
    17,156
    3,108
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    ok after capt method what is your hboot now?
     
  3. bnkrupt

    bnkrupt Lurker
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    8
    Joined:
    Jan 6, 2014

    Jan 6, 2014
    8
    2
    26
    Male
    Military
    Kansas
    I am not sure what my hboot is now. Nothing changed on the phone, after I ran the unrevoked3 the phone restarted that was it.
     
  4. bnkrupt

    bnkrupt Lurker
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    8
    Joined:
    Jan 6, 2014

    Jan 6, 2014
    8
    2
    26
    Male
    Military
    Kansas
    Under applications it says that fast boot is on, is that something I need to turn off before rooting the phone? Sorry for all the questions, but its like everything I search has a different answer.
     
  5. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    Rank:
     #7
    Points:
    3,108
    Posts:
    27,243
    Joined:
    May 13, 2010

    May 13, 2010
    27,243
    17,156
    3,108
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    ok you need to slow down a bit.

    captn's method is basically(if that was what you used):
    1. unlock the bootloader
    2. lower your misc. partition
    3. pick a RUU to lower your hboot according how you want to root the phone
    4. run either unrevoked or revolutionary to gain root.

    now if you were able to lower your hboot, for unrevoked to work, it needs to be hboot 2.10

    if you are planning to use revolutionary then it needs to be 2.16

    so check your hboot.....it is found in the bootloader(power off, then power+vol down)

    yeah please check that off, but that is not the issue. not sure where you are at in the guide, but you root method (unrevoked or revolutionary) will depend on what your hboot is.....that is why you are getting that message.
     
    Mikestony likes this.
  6. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    Rank:
     #7
    Points:
    3,108
    Posts:
    27,243
    Joined:
    May 13, 2010

    May 13, 2010
    27,243
    17,156
    3,108
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    wait........from my guide, what method did you use?
     
  7. bnkrupt

    bnkrupt Lurker
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    8
    Joined:
    Jan 6, 2014

    Jan 6, 2014
    8
    2
    26
    Male
    Military
    Kansas
    Thank for all your help. I am still having trouble getting into the bootloader menu. I have tried power +vol down, Vol down + power, power + vol up, vol up + power with no success. I will keep trying.
     
  8. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    Rank:
     #7
    Points:
    3,108
    Posts:
    27,243
    Joined:
    May 13, 2010

    May 13, 2010
    27,243
    17,156
    3,108
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    Make sure that fastboot is unchecked then power off.......and then power+ vol down
     
    bnkrupt likes this.
  9. bnkrupt

    bnkrupt Lurker
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    8
    Joined:
    Jan 6, 2014

    Jan 6, 2014
    8
    2
    26
    Male
    Military
    Kansas
    Ok so I finally got into the bootloader (thanks again). my current hboot is 2.18.0001 so I will need to lower this in order to run unrevoked like you said. Now to search on how to lower partition, and a ruu to lower my hboot. Thanks again.
     
  10. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    Rank:
     #7
    Points:
    3,108
    Posts:
    27,243
    Joined:
    May 13, 2010

    May 13, 2010
    27,243
    17,156
    3,108
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    Yeah captain's method is what you want......but the files have been removed.......just checked.......to be honest the HTC dev method is the easiest.
     
    bnkrupt likes this.
  11. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    Rank:
     #7
    Points:
    3,108
    Posts:
    27,243
    Joined:
    May 13, 2010

    May 13, 2010
    27,243
    17,156
    3,108
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    Once I find the files I'll edit the guide to show you how to do captain's throwbacks method......as somehow I lost them.......Lol
     
  12. bnkrupt

    bnkrupt Lurker
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    8
    Joined:
    Jan 6, 2014

    Jan 6, 2014
    8
    2
    26
    Male
    Military
    Kansas
    Ok so I have went and made an account through Htcdev.com. I watched a couple of his videos and one said something about downloading the andriod-sdk files. I downloaded it like he said unzipped the files, went into the folder double clicked on SDK Manager. He said once you double click on that another window will come up and prompt you to "Run". When I double click on the file a black window flashes and goes away. Kinda looks like the cmd prompt window. Now i have tried this on two different computers with the same results. Can you shed any light on this problem?
     
  13. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    Rank:
     #7
    Points:
    3,108
    Posts:
    27,243
    Joined:
    May 13, 2010

    May 13, 2010
    27,243
    17,156
    3,108
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    Rather then watch the video....did you read my guide? I have all the files you need in the guide.....no need to download the whole sdk toolkit......please take the time to read my guide first before doing anything else.
     
  14. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    Rank:
     #7
    Points:
    3,108
    Posts:
    27,243
    Joined:
    May 13, 2010

    May 13, 2010
    27,243
    17,156
    3,108
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    Ok so I have the necessary files......I'm not at my computer yet so give me a few hours,I should have the full steps with the files included......if you still want to get s-off.
     
    Mikestony likes this.
  15. bnkrupt

    bnkrupt Lurker
    Thread Starter
    Rank:
    None
    Points:
    26
    Posts:
    8
    Joined:
    Jan 6, 2014

    Jan 6, 2014
    8
    2
    26
    Male
    Military
    Kansas
    Sure thing, I will be waiting. Thanks again for your help. Great sticky by the way.
     
    tube517 and ocnbrze like this.
  16. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    Rank:
     #7
    Points:
    3,108
    Posts:
    27,243
    Joined:
    May 13, 2010

    May 13, 2010
    27,243
    17,156
    3,108
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    here it is:
    2. Captain Throwback's method
    ok thanx to the good Captain i have permission to write a version of his method here for AF members.....so here goes.

    first off you will need to have the bootloader unlocked, have a custom recovery, and flash the su file. all this can be done in the HTCdev method. second, you will need to disable fastboot (settings/ app/ disable fastboot) and enable usb debugging (settings/app/development)

    the captain's method is based off of toast's root exploit. with the bootloader unlocked and su file fashed you can now change the misc partition which allows you to lower your hboot so that you can use the previous root methods to finally get s-off which is like turning your securities off and is like changing administrator permission on your pc. the main rrot methods are unrevoked and revolutionary.

    here are the files you will need:
    mtd-eng.zip
    flash_image.zip
    if you want to use unrevoked:
    PC36IMG_SuperSonic_S_Sprint_WWE_3.70.651.1_Radio_2.15.00.11.19_NV_1.90_release_161482_signed
    or
    if you want to use revolutionary
    Filename: PC36IMG_SuperSonic_GB_Sprint_WWE_4.54.651.1_Radio_2.15.00.0808_NV_2.15_release_220182_signed.zip

    download the first two files and unzip them and move them to the sd card of your phone....via usb cable. do not unzip the PC36IMG file.

    now once you have done that you can now proceed below:
    1. in the android folder you used previously for the HTCdev method, open the command window and enter these commands:
    2. first we need to start adb so type:
    Code (Text):
    1. adb shell
    if you get $ in the prompt then you do not have root access. type
    Code (Text):
    1. su
    and you should get the $ changed to #.....if it does not then something previously went wrong.
    3. next, press enter after each line
    Code (Text):
    1. cat /sdcard/flash_image > /data/flash_image
    Code (Text):
    1. chmod 755 /data/flash_image
    Code (Text):
    1. /data/flash_image misc /sdcard/mtd-eng.img
    if there is no errors then you can proceed to the next step.
    4.now we need to downgrade the hboot by flashing the PC36IMG ruu:
    1. download the PC36IMG file(depending on which one you choose) and do not unzip it.
    2. rename the file so that it is only PC36IMG. make sure that you do not add any extra .zip's to the name as windows hides extensions by default.
    3. transfer the file to the root (that means not in any folder) of the sd card.
    4. power off (you most likely need to uncheck fastboot. settings/apps/uncheck fastboot.) then press and hold power+vol down.
    5. hboot should see the file and select yes to update.
    now check you hboot in the bootloader and it should change to either hboot 2.10 or 2.16 which unrevoked or revolutionary will now work.

    you can now proceed to use these guides to finally gain s-off:
    if your hboot is 2.10 then use this guide:
    http://androidforums.com/evo-4g-all-things-root/194918-rooting-dummies.html

    if your hboot is 2.16 then use this guide:
    http://androidforums.com/evo-4g-all...ooting-dummies-guide-gingerbread-edition.html
    http://androidforums.com/evo-4g-all...-rooting-gingerbread-2-3-5-dummies-guide.html
     
    tube517 and Mikestony like this.
Tags:

Share This Page

Loading...