1. Are you ready for the Galaxy S20? Here is everything we know so far!

Root HTC Desire with Froyo (2.2)

Discussion in 'Android Devices' started by mike075, Aug 11, 2010.

  1. mike075

    mike075 Lurker
    Thread Starter


    i have downloaded and upgraded my HTC Desire with the Froyo package at this site:


    Now i want to root my Desire to move apps from ROM to SD.
    I have searched a lot of threads but didn't find solutions to this problem,
    that i can trust.

    Is there any easy solution (with no danger to brick the device) to this problem because i read that only 2.1 can be rooted?

    My Bootloader version is 0.9XXXXX

    THX for tuts and helps


  2. anoniemouse

    anoniemouse Android Expert

    There is a way to root according to xda website so take a look here, see if this helps.

    [Root] SLCD HBOOT 0.92 - xda-developers
  3. mike075

    mike075 Lurker
    Thread Starter

    THX i will try this.
  4. mike075

    mike075 Lurker
    Thread Starter

  5. Sheshnag

    Sheshnag Well-Known Member

  6. dingdong3000

    dingdong3000 Newbie

    ^ is this similar to unrevoked3 but for 2.2? Looks fairly simply which is good to know - will this work on a unbranded ota froyo 2.2 desire and will it revert back to original if i unroot with same program? sorry for the q's.
  7. mike075

    mike075 Lurker
    Thread Starter

    In the list of supported devices there is standing that htc desire is not supported for universal androot but in the description there is standing the following:

    Universal Android Root or Universal Androot is a android apps that lets you to root your android phone:Nexus One(2.2), HTC Hero(2.2),HTC Desire(2.2), ...

    What is the truth of this now?

    THX for helps

  8. Sheshnag

    Sheshnag Well-Known Member

    HTC Desire 2.1 is not supported, 2.2 is. Simple! as with Nexus, it i only Froyo root.
  9. mike075

    mike075 Lurker
    Thread Starter

    Hello i have installed the Universal Androot but when i run the app after the process installing toolkit i got the message:

    Failed! No ~~~ Fu goo ~~~

    What does this means and why do i get this message?

    PLS Help
  10. phbjoh

    phbjoh Lurker

    Have the same problem on my Desire OTA upgraded to 2.2, get the below error code.

    Failed! No ~~~ Fu goo ~~~

    Blue skies
  11. teppic74

    teppic74 Android Enthusiast

    There is no known way to root Froyo at the moment. The only possibility is to downgrade to Android 2.1 and root that. If you have an SLCD screen this is complicated.
  12. alekos

    alekos Newbie

  13. teppic74

    teppic74 Android Enthusiast

  14. kosiaz

    kosiaz Lurker

    and how will i know i got SLCD screens or any other?
  15. Spncnrt86

    Spncnrt86 Lurker

    Okay, so I've been reading all the Desire threads but I'm still kinda new to this.

    I Have 2.1 and Bootloader v. 0.98 and I'm wondering if I am going to be able to Use the steps in the SLCD HBOOT or if its a whole different process completely,
    any help would be BA
  16. moe3754

    moe3754 Well-Known Member

    You can root Froyo 2.2 with this and you will have no problems at all.
  17. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    Unrevoked 3.21 can root 2.2, and is quite painless. But be wary of using the Rom Manager application if you do - I've seen a number of threads where people have had problems after doing this, some of them quite recent.

    I rooted this way and backup and flash directly using recovery, and have had no problems.
  18. Tyseyh

    Tyseyh Android Expert

    I get a "failed to get root, is your firmware too new?"

    I dunno.. is it? 2.2 Software number
  19. SUroot

    SUroot Extreme Android User

    Dunno. Did you read the rooting faq?
  20. Tyseyh

    Tyseyh Android Expert

    i did yeha, the answer on there is this.

    There are 2 reasons for this.

    1) Your firmware IS too new. Check your version. The ARA 2.32.415.x is now rootable. Ensure you are using the 3.32 version of Unrevoked if you are on an ARA build - 3.32

    For other versions, 3.21 is best - 3.21

    2) If you forced all apps to SD card, this is impairing the installation of the superuser app. Go back through the guide and substitute "pm setInstallLocation 2" foir "pm setInstallLocation 0" and try it again

    i know its not answer number 2, im not too sure on answer one though.

    Phone software information. (incase it helps )

    Android version 2.2
    baseband Version
    kernal version-
    Build Number: CL274424 Realease-keys
    Software number-
    Browser version - Webkit 3.1

    i hope that is enough info.
  21. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    Dan: ROFL - I just spotted the new avatar! :D

    Edit: Yeah, just a little off-topic
  22. SUroot

    SUroot Extreme Android User

    2.17.61 is not 2.32.415! Tried factory reset?
  23. SUroot

    SUroot Extreme Android User

    You've gotta love Karl...
  24. Tyseyh

    Tyseyh Android Expert

    Ideally I didn't want to do that unless really needed. Will it make a difference?
  25. SUroot

    SUroot Extreme Android User


    If you download an application called visionary+ (google it not market) and install it. You can temp root your device (root lost at reboot).

    This will allow you to use root backup app such as titanium backup, so you can backup everything so you can restore it later....

HTC Desire Forum

Features and specs are not yet known.

Release Date

Share This Page