1. Check out our companion app, Forums for Android! Download from Google Play

Root [Root] One Click Root for Samsung Admire (SCH-R720) :: Windows/Mac/Linux :: 9/12/2011

Discussion in 'Android Devices' started by k0nane, Sep 12, 2011.

  1. k0nane

    k0nane Well-Known Member
    Thread Starter
    163

    Apr 8, 2011
    803
    779
    163
    Male
    I do stuff, with things
    127.0.0.1
    EDIT 4/23/13: I'm pretty sure this doesn't work any more, look for other root packages in this forum.

    Don't bug me about broken links. Direct #1 will be practically infinite in its lifespan - if it disappears, this phone probably has too. I am not responsible for others' domains, including Shabbypenguin's old one, Mr. Rosenberg's, or Mediafire.



    @djrbliss, @MikesToolz, and @k0nane present...

    One Click Root for SCH-R720

    About

    Welcome, Admirers! Without the headaches of the package blocking that got in the way on the Samsung Galaxy Indulge, the crew over at the #admire channel have successfully rooted your device. :)

    Actually, @djrbliss (Dan Rosenberg, bliss in #admire) did. Almost all of the credit belongs to him - he discovered the exploit that gives us root, and wrote the Linux/Mac one-click script. Technical info on the exploit can be found here. Enjoy the fruits of his hard work!

    How to Install

    Your device must be in USB Debugging mode. To turn it on, go to Settings > Applications > Development and check the box.

    Linux/Mac: Connect your device to your PC, unpack the archive, and run run.sh. You may need to chmod 755 run.sh.

    Windows: Install the Samsung USB drivers (download), unpack the archive, and open run.bat.

    Downloads
    We do not use file hosts with waiting times or CAPTCHAs!

    Windows Download (Direct) | Mirrors :: Direct #2 - Mediafire
    Linux/Mac Download (Direct) | Mirrors :: Direct #2 - Direct #3


    Credits

    All credit for the exploit goes to @djrbliss!


    • Windows one-click originally by me (@k0nane)
    • Port to Admire by @MikesToolz
    • Hosting by @Shabbypenguin, @djrbliss, @k0nane
     

    Advertisement

    wanako1, JrossiX, bangeko and 73 others like this.
  2. k0nane

    k0nane Well-Known Member
    Thread Starter
    163

    Apr 8, 2011
    803
    779
    163
    Male
    I do stuff, with things
    127.0.0.1
    P-O-S-T :: R-E-S-E-R-V-E-D

    [​IMG]

    Original artwork by Pendulum via Gasolin3.

    ...for future use.

    Follow me on Twitter @k0nane and @publik0!
    Follow Dan Rosenberg on Twitter @djrbliss!
     
    twogbsd, djspade, djgru and 1 other person like this.
  3. izaksdad

    izaksdad Member
    16

    Feb 28, 2011
    24
    5
    16
    Full time student/dad
    East Texas
    Thanks for the speedy work there.
    Works as advertised, not a single hiccup.
    Bye Bye bloatware!
    Annoying HELLO, Hello, hello is BYE, Bye bye 4ever.
     
  4. aihliift@

    aihliift@ Well-Known Member
    16

    Feb 2, 2011
    46
    3
    16
    you guys rock !!! worked like a charm !!!!! no more metrocrap !!!
     
  5. smiley313

    smiley313 Member
    16

    Sep 13, 2011
    19
    1
    16
    Male
    Detroit, MI
    great i been waiting for this for about 3weeks now worked like a charm
     
  6. ajshaw77droid

    ajshaw77droid Member
    5

    Sep 13, 2011
    8
    0
    5
    having problems: error...device not found...please help
     
  7. BriteLeaf

    BriteLeaf Member
    6

    Sep 5, 2011
    7
    2
    6
    run.bat does not exist in the file I downloaded.

    I still get things on my phone saying I have to be rooted to open the files I was trying to open.
     
    sandpipershore likes this.
  8. BriteLeaf

    BriteLeaf Member
    6

    Sep 5, 2011
    7
    2
    6
    Ok, I went to the Windows Direct Download site, and I got a totally different file. Worked like a charm :D

    I am now among the rooted! :D:cool:
     
  9. quozzerx

    quozzerx Active Member
    15

    Feb 6, 2011
    32
    0
    15
    Thank you! So nice to have full access to the phone!
     
  10. marcos.lennis

    marcos.lennis Well-Known Member
    18

    Aug 29, 2011
    48
    10
    18
    IT Networking
    Hialeah, FL
    How do I get rid of the bloatware?

    Is anyone working on a custom Kernel to OC?
     
  11. Jaymoney

    Jaymoney Member
    16

    Sep 13, 2011
    11
    5
    16
    Sorry I am new to the whole smartphone scene. Hats off to the people who worked on this exploit!

    Im on a macintosh and the files in the archive are:

    adb.linux
    adb.osx
    admire_root.sh
    su
    superuser.apk

    Which of these do i click to make it work? I dont see a file named run.sh :(.

    Thanks!

    EDIT:

    I tried running admire_root.sh through the terminal but nothing happened. Phone is in debug mode with usb storage on.
     
    sandpipershore likes this.
  12. BriteLeaf

    BriteLeaf Member
    6

    Sep 5, 2011
    7
    2
    6
    I believe you have the Linux version, but since I know next to nothing about Macintrash.... err... I mean Macintosh, I am not certain.

    I DO know that Linux ends a lot of it's commands with a .sh though.

    I hope this helps.
     
  13. tripdoc79

    tripdoc79 Well-Known Member
    93

    May 24, 2011
    630
    223
    93
  14. Jaymoney

    Jaymoney Member
    16

    Sep 13, 2011
    11
    5
    16
    Thanks for the replies. I have the phone in USB debug mode and when i run admire_root.sh it tells me it cant find the other files which are in the same folder.

    I am sure there is something easy I am missing.
     
  15. aihliift@

    aihliift@ Well-Known Member
    16

    Feb 2, 2011
    46
    3
    16
    try extracting to a folder
     
  16. ajshaw77droid

    ajshaw77droid Member
    5

    Sep 13, 2011
    8
    0
    5
    Thanks I've been looking forward to getting rid of Metro PCS bloatware. I ran the root program, my phone rebooted and it said that I now have a rooted phone. However, when I downloaded apps that required a rooted phone (Titanium) they cannot work because they do not have access to the root files. I AM STILL STUCK WITH METRO PCS GARBAGE APPS....Please help... What did I do wrong? How can I correct this problem?
     
  17. edgchacon

    edgchacon Well-Known Member
    53

    Nov 30, 2010
    256
    59
    53
    Open terminal and type cd(press spacebar) ...dont press anything else go to next step

    now go back to Finder and go to the folder where you extracted those files
    ex. ~/Downloads/Admire

    grab the "Admire" folder and drag it to your terminal. then press Enter.


    once you are in ~/Downloads/Admire or whatever directory you placed it then type:

    ./admire_root.sh (or whatever the sh file is called)
     
    gasmasq and sandpipershore like this.
  18. ajshaw77droid

    ajshaw77droid Member
    5

    Sep 13, 2011
    8
    0
    5
    I re rooted but still no access to the root even though Juice Defender claims that my phone is rooted
    .....PLEASE HELP URGENTLY
     
  19. k0nane

    k0nane Well-Known Member
    Thread Starter
    163

    Apr 8, 2011
    803
    779
    163
    Male
    I do stuff, with things
    127.0.0.1
    Make sure Superuser is installed.
     
    geekofagirl and ajshaw77droid like this.
  20. Holockau5t

    Holockau5t New Member
    5

    Sep 14, 2011
    1
    0
    5
    that worked perfectly (after being a ****** and rooting over and over again, lol) You are effin epic for the post and I appreciate you and everyone who worked on this I'm definitely greatful!!! System tuner finally rooted and working!:D
     
  21. xFlow

    xFlow Member
    15

    Sep 9, 2011
    11
    0
    15
    Every time I try I get this, the last step is preventing me from finishing this.

    Code (Text):
    1. * daemon not running. starting it now *
    2. * daemon started successfully *
    3. error: unknown host service
    4. "[*] Triggering core dump..."
    5. [1]   Segmentation fault      app_process /dev...
    6. "[*] Rebooting phone. It may buzz a lot and loop on boot. Don't panic."
    7. remount succeeded
    8. 312 KB/s (26264 bytes in 0.082s)
    9. link failed File exists
    10. "[*] Installing Superuser.apk. If this hangs, just cancel it with Ctrl+C after a
    11.  few seconds,"
    12. "[*] and you'll be finished rooting your phone.  Reboot and enjoy."
    13. 260 KB/s (196521 bytes in 0.736s)
    14. Error: Could not access the Package Manager.  Is the system running?
    15. "[*] Persistence complete, enjoy your rooted phone!"
    16. Press any key to exit the script.
    17. Press any key to continue . . .
    18.  
     
  22. ajshaw77droid

    ajshaw77droid Member
    5

    Sep 13, 2011
    8
    0
    5
    I'm sorry but I did that. Even ensured that I downloaded the updated binary...but I still cannot remove Metro PCS stock software. What have I missed?
     
  23. ajshaw77droid

    ajshaw77droid Member
    5

    Sep 13, 2011
    8
    0
    5
    GOT IT...finally. Thanks all yall....
    :D:D
     
  24. Chiggie

    Chiggie New Member
    5

    Sep 14, 2011
    1
    0
    5
    I get an unknown host error.
    Any ideas.
    Running windows one click root
    I installed Samsung drivers.
    Downloaded and unpacked admire root
    Ran the run file.
    Then I get the error.
    Yes, the phone is in debug mode.
    Thanks for any help guys!

    Here's a copy of the log
    * daemon not running. starting it now *
    * daemon started successfully *
    error: unknown host service
    "[*] Triggering core dump..."
    [1] Segmentation fault app_process /dev...
    "[*] Rebooting phone. It may buzz a lot and loop on boot. Don't panic."
    remount succeeded
    312 KB/s (26264 bytes in 0.082s)
    link failed File exists
    "[*] Installing Superuser.apk. If this hangs, just cancel it with Ctrl+C after a
    few seconds,"
    "[*] and you'll be finished rooting your phone. Reboot and enjoy."
    931 KB/s (196521 bytes in 0.206s)
    Error: Could not access the Package Manager. Is the system running?
    "[*] Persistence complete, enjoy your rooted phone!"
    Press any key to exit the script.
    Press any key to continue . . .
     
  25. ashamancurtis

    ashamancurtis Member
    6

    Sep 14, 2011
    6
    1
    6
    Dude, works great. You might want to mention that the "superuser.apk" file needs to be installed on the target phone before running the "run.bat" file.

    Of course, maybe the rest of you knew that already. I just got this phone, and it's my first android device, so i'm trying to learn quickly here
     
    BigGoodWolf likes this.

Share This Page

Loading...