1. Download our Official Android App: Forums for Android!

Root Rooted 2.1

Discussion in 'Android Devices' started by X10iUser, Oct 31, 2010.

  1. X10iUser

    X10iUser Android Expert
    Thread Starter

    Download the SuperOneClick.

    Copy these three files from the Android SDK tools folder...

    adb

    AdbWinApi.dll

    AdbWinUsbApi.dll


    (which are zipped here - tools.zip)

    ...replace the ones in the SOCR folder.

    Run it, but when/if it starts looping do this...

    ...and you should see...

    ...install Titanium and BusyBox to confirm!

    If you continue to get looping issues, install the PDANet Client on the PC and allow it to install the drivers for your phone and try again.

    Some have said you don't need to replace the files, and that it can take up to 10 minutes. It looped for me but after doing the above, especially unticking/reticking debug mode whilst running it, and today installing the PDANet client it was almost instant.
     

    Advertisement

    rob1367, Zebadee, wynney666 and 5 others like this.
  2. CuBz

    CuBz Android Expert

    Brilliant! All the more excitement added on now :D
     
  3. FitzysX10

    FitzysX10 Member

    I am about to give it a go, wish me luck.

    Cheers mate.

    Edit: All good, thanks again.
     
  4. huntleth

    huntleth Well-Known Member

    I am still running 1.6, but will be upgrading when generic uk firmware is released. My phone is rooted now, but would it be wise to de-root it before upgrading?
     
  5. X10iUser

    X10iUser Android Expert
    Thread Starter

    Rooting has no effect whatsoever on the ability to upgrade.
     
    huntleth likes this.
  6. huntleth

    huntleth Well-Known Member

    Ah good, i'd thought as much but what with the apparent troubles people had rooting 2.1 today I didn't want to brick the phone :p
    Cheers :)
     
  7. CuBz

    CuBz Android Expert

    Mine goes no further than Installing superuser.apk... :thinking:

    EDIT: Nevermind, I unplugged USB then went into settings->applications and realised that I didn't have the box ticked allowing none market apps, ticked it, plugged USB back in and it worked :)

    EDIT 2: Although it said it had successfully rooted, and superuser is installed, no rooted apps will work :thinking:

    EDIT 3: Working now after installing Busybox :)

     
  8. X10iUser

    X10iUser Android Expert
    Thread Starter

  9. GS9000

    GS9000 Newbie

    where can i find these file mate? where is that folder?

    Copy these three files from the Android SDK tools folder...

    adb

    AdbWinApi.dll

    AdbWinUsbApi.dll


    thanks...

    ...opps, okay so i need to download the SDK file.... replaced the files on SOCR folder, ran it, tick/untick the USB debug, but i am still stucked on the loop ratc....

    pls help...
     
    TerryWSM likes this.
  10. X10iUser

    X10iUser Android Expert
    Thread Starter

    Hi.

    You need to download the SDK (see link), or attachment...
     

    Attached Files:

    GS9000 likes this.
  11. GS9000

    GS9000 Newbie

    Thanks mate, i did that, the whole 23MB file, but i will try your attachments and copy paste and see if it works...:D

    ... nope. still the same mate...

    when i untick/tick the USB, i have three options
    Connect your phone (update phone and manage account)
    Install PC Companion
    Charge the phone

    so i always select Charge the phone.. but still nothing....i also installed the PDANet already.
    how hard can it be?
     
  12. madmurdoch

    madmurdoch Member

    What is the SOCR folder please? Can't find it....

    Found it - didn't read properly and missed superonelink at the top.
     
  13. X10iUser

    X10iUser Android Expert
    Thread Starter

    Hi.

    You need to download it - SuperOneClick Root.
     
    GS9000 likes this.
  14. GS9000

    GS9000 Newbie

    Thanks mate, i'm rooted since yesterday using SuperOneClick, had to use the other version though but all went smooth without probs.

    I installed the PDANet though then ran SOC. Without it, i was going in loops for quite sometime.
     
  15. cwepruk

    cwepruk Well-Known Member

    This was a pain for me, but what you should do is connect the phone, get to your USB debugging screen on the phone (under Apps/development), toggle it on.

    Do not close that page on your phone.

    Then just open up the superuser program, click root.

    My phone just went crazy at this point (connecting, disconnecting, PC companion pops up). Exit PC companion, click on the connect to computer, then toggle USB off and back on.

    I tried this about 10 times with no luck and then once I toggled USB off/on in the span of 5 seconds, I was rooted. I am having some hang up issue with titanium. It is removing apps, but it's getting stuck - so I have to use an app killer to kill it, then re-open and go to the next app to delete.
     
  16. scorpion100

    scorpion100 Member

    I downloaded superoneclick the latest version I didnt even needed to replace the the files and it works 100% u just need to wait 10 min and it works all by itself in my case ..:D
     
  17. Craiggers

    Craiggers Newbie

    rooted matey cheers :)
     
  18. wynney666

    wynney666 Android Enthusiast

    Worked a treat, i copied files as per instructions.
    the superoneclick never actually said complete, just seemed to hang on the installing superuser.apk, but looked and it was on. the rest was simple, Now rooted and all SE apps removed.
    cheers
     
  19. uchi

    uchi Well-Known Member

    is it easier to do than it sounds? i dont wanna start playing with it and brick the phone. lol. is there a tutorial video i can folow to make it a little easier?
     
  20. kersey

    kersey Well-Known Member

    Just download z4root from Android Market and with one click you are rooted and it also has the option to unroot too.
     
  21. uchi

    uchi Well-Known Member

    excellent thanks
     
  22. uchi

    uchi Well-Known Member

    that program worked great. phone is rooted and it was painless. thanks
     
  23. kersey

    kersey Well-Known Member

    Glad to hear it mate...with the use of Titanium Backup you can either remove or freeze all the unwanted apps :D
     
  24. uchi

    uchi Well-Known Member

    i need to read up to see what i can get rid of. with my luck ill delete everything and have to start again, lol
     
  25. Merolas

    Merolas Android Enthusiast

    Let's do it the REAL easy way... download z4root from the market... and it's done... Worked perfect and now i have titanium installed and working. No more playing with debug setting
     
    clockwork58 likes this.
Loading...

Share This Page

Loading...