1. Are you ready for the Galaxy S20? Here is everything we know so far!

Rooted Desire with PVT4 - unable to create Nandroid backup or Flash

Discussion in 'Android Devices' started by andy100, Feb 10, 2011.

  1. andy100

    andy100 Newbie
    Thread Starter

    Hi,

    This is my first post although since before I got my Desire I've been using these forums and finding them a great source of help for all things Android.

    I'm sure my problem/query has been covered before but I'm at work so can't spend hours searching through the forum so if somebody could point me in the right direction it'd be much appreciated!

    Last night I finally got the courage up to root my unbranded Desire in order to create a Nandroid backup and intended to flash a new Rom, but after successfully rooting using unrevoked but when I came to do a Nandroid backup it failed with the following errors when entering CWM Recovery:

    E:Can't find MISC:
    E:Can't mount CACHE:recovery/command
    E:Can't find MISC:
    E:Can't mount CACHE:recovery/log
    E:Can't fint MISC:

    I found this when looking for an answer

    [CAUTION] New HTC Desire model spotted. PVT4 - S-OFF: works (AlphaRev 1.8) - xda-developers

    And using the test suggested with terminal emulator it looks like I've got the new PVT4.

    All this talk of AlphaRev and AmonRa is really confusing me and I'm not sure how to proceed...I downloaded the AmonRa .img file and tried rerooting using that in unrevoked but got a "Is your firmware too new?" error.

    Can anybody give me a simple step by step guide to get around this problem please?

    I installed the free version of Titanium Backup and did a full backup, then copied my whole SD card contents to my computer, so I do have a clean copy of everything.

    Then I tried flashing with Miui anyway, but got the "Error: Can't mount CACHE" message again when trying to erase all data etc from Recovery. Ran Miui from the SD in Recovery and seemed to get a completed/success message, but when I rebooted it just went back to my stock Sense UI....if nothing else, if I were to reflash the stock RUU, would I have this same problem too of the flashing not working?

    It's really frustrating me as I'm not particularly liking Android OS that much in it's stock/Sense configuration but really like the sound and format of Miui and was hoping it would salvage Android as an OS for me, but after the frustrations last night I'm really starting to hate it [​IMG]

    Cheers!
    Andy
     


  2. SUroot

    SUroot Extreme Android User

    If you have a look in the rooting FAQ (in Sig), there is a section about Pvt 4. If your erase size is 40,000, CWM will not work.

    This FAQ is also linked in the sticky at the top of this forum.
     
  3. andy100

    andy100 Newbie
    Thread Starter

    Thanks for the reply. I tried that last night but it didn't seem to work, which confused me even more. I downloaded Unrevoked yesterday so was presuming that it was the latest (correct) version, but didn't check so will make sure I've definitely got 3.21 and will use Amon-RA 2.0.1 again.

    The whole AlphaRev bit was the really confusing bit tbh. If I understand correctly, using Unrevoked with Amon-RA won't install clockworkmod, or will it? And if it's installed, how do I go about backing up?

    Sorry, I'm quite techy but not as much as to automatically understand how to run through these steps (all the references I've found online don't really give a step-by-step guide!)

    Andy
     
  4. SUroot

    SUroot Extreme Android User

    Yeah theres a lot of info in there. Takes several reads to absorb ;)
     
  5. andy100

    andy100 Newbie
    Thread Starter

    Sorry, had to edit my post after rereading the Rooting FAQ's...
     
  6. SUroot

    SUroot Extreme Android User

    Amon RA and CWM are both custom recoveries.

    When you open Unrevoked, go to File>Custom recovery and browse to your downloaded amon ra.img file. It will then use this instead of CWM.

    Although teh menus in Amon RA are different,. the same functionaility is there
     
  7. andy100

    andy100 Newbie
    Thread Starter

    Ah I see! Well hopefully I just wansn't using the right version of unrevoked and/or Amon-RA last night and it'll work this time :)

    The whole AlphaRev .iso really added to the confusion too!

    I'll try again tonight and post back my results. THanks for your help!

    Andy
     
  8. SUroot

    SUroot Extreme Android User

    Alpharev is for s-off. Thats for after if you really want it, but ignore for now ;)
     
  9. andy100

    andy100 Newbie
    Thread Starter

    Ah, that's what was confusing me because it was talked about in the XDA thread :rolleyes:

    As long as it doesn't affect my ability to do Nandroid backup's and flash ROM's I'm not worried :)
     
  10. GrenW

    GrenW Android Expert

    I'd leave S-Off and AlphaRev alone for the minute. Rooting can be 'fun' enough by itself without adding to it.

    Hopefully Dan's suggestions/FAQ will help when you try again tonight
     
  11. SUroot

    SUroot Extreme Android User

    If you really like CWM, after rooting, you could S-Off and use a modified CWM that works with 40,000 erase size (some PVT4's) But its a lot of work simply for clockwork. Well not really but one step at a time.
     
  12. andy100

    andy100 Newbie
    Thread Starter

    I'm haven't really got a preference to be honest as I haven't used it enough, so I'm not really bothered by all the hassle of doing S-Off and everything! :rolleyes:
     
  13. andy100

    andy100 Newbie
    Thread Starter

    Well I have to admit that worked a treat! The rooting, Nandroid backup and flashing of the Miui took less time all-told than it has done to fiddle about getting to know the new ROM and reinstalling my apps and data (I used Titanium for that bit).

    Cheers for all your help SUroot - very happy with the whole process and with Android/Miui now. That'll teach me for not reading the Guide well enough :rolleyes:

    Now to go back to configuring the UI to how I want it ;)

    Andy
     
  14. Rastaman-FB

    Rastaman-FB Extreme Android User

  15. Red Dread

    Red Dread Newbie

    Apologies for hijacking this thread, but I'm having exactly the same issue with my Desire as Andy100. I rooted it using unrEVOked v3.32 before I discovered it is a PVT 4 40,000.

    I've tried flashing Recovery to the Amon Ra 2.0.1 image as suggested here, but when I try to do it using unrEVOked and selecting the custom Recovery, but I get an error message saying that it 'failed to get root. Is your firmware too new?'. My Recovery is then still ClockworkMod when I reboot into it. Is this because it's already rooted when I try to flash Recovery?

    I've read and re-read all the suggestions here and in the FAQ, but can't see what Andy100 did differently to me to get his Desire to be able to backup and Flash the ROM.

    Any help would be appreciated.
     
  16. andy100

    andy100 Newbie
    Thread Starter

    I think you're using too new a version of unrevoked. Go through the Rooting FAQ's and midway down there's a link to unrevoked 3.21 for PVT4 Desire's (which is the one I successfully used to root my Desire)

    http://androidforums.com/desire-all-things-root/221212-faq-rooting-updated-24-02-11-a.html

    Andy
     
    Red Dread likes this.
  17. Red Dread

    Red Dread Newbie

    It seems you're absolutely right! Just used unrEVOked 3.21 and it worked a treat. Can't believe I missed that.

    Thanks, dude!
     
  18. andy100

    andy100 Newbie
    Thread Starter

    Glad to have helped (that's what I missed first time around too!)

    Though I've since moved over to WP7 so my memory of what I did with Android three weeks ago was a bit rusty! :)
     
  19. SUroot

    SUroot Extreme Android User

    The problem with my faq is its too much to absorb on one go. And some of it doesn't make immediate sense

    People then fool themselves into thinking they have read it and it doesn't contain the answers that it does.

    Fact is, some answers only make sense when you are in certain situations.

    I.would like to think it covers most questions but unless people keep reading it over and over, its useless.

    That's the nature of the beast I'm afraid


    If I had a penny for everytime someone asked a question starting "I read the faq, but..." and I know the answer is in the faq, id probably have £1.73
     
  20. andy100

    andy100 Newbie
    Thread Starter

    Very true SURoot, but it's an invaluable thread to have and at least you can just point people there as opposed to having to retype the same info over & over to the same questions!

    In fact, the complexity of Android (and hence the broadness of your FAQ) was part of the reason I moved away from Android :rolleyes:
     
  21. DBook

    DBook Newbie

    I was thinking about making some kind of graphic high-level flowchart to cover the main options and decisions. I'm not yet expert enough to do this - I'm getting to know rooting and unrevoked in some detail - but not debranding, flashing, RUUs, goldcards, etc.
     
  22. InfernalByte

    InfernalByte Android Expert

    The Desire costs an awful lot of mohoney and as is quite rightly pointed out there are risks involved in rooting. Add that to the pressure of not wanting to make an idiot of yourself in forums like this one and all sorts of assumptions and mistakes are made.
     
  23. talkinboss

    talkinboss Lurker

    i have the same problem as andy100 mentioned.according to the link he posted i'm about to give a try.but my desire is already rooted(it shows superuser and everything seems perfect...but problem occur when i tried to do a nandroid backup).now can i re-root my already rooted desire with AR custom recovery on unrevoked?will it create any problem?help needed.thanks
     
  24. Rastaman-FB

    Rastaman-FB Extreme Android User

    it should fix your issue
     
  25. talkinboss

    talkinboss Lurker

    thanks for the awesome help.just rooted my pvt 4 htc desire.everything was very smooth.gonna flash new rom.thanks once again.......
     

HTC Desire Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...