1. Download our Official Android App: Forums for Android!

Root Rooted G530T1 (Galaxy Grand Prime for Metro) Custom Binary Blocked By FRP Help Please!

Discussion in 'Android Devices' started by DerrickArm, Feb 2, 2016.

  1. DerrickArm

    DerrickArm Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Feb 2, 2016

    Feb 2, 2016
    7
    0
    5
    Male
    Alright so as stated in the title I rooted my G530T1 using KingRoot and once I finally powered my device off and then back on after a few days I am now receiving a message that says Custom Binary Blocked By FRP. I would like to undo this without having to restore factory settings and lose all my info I found the Odin way of doing it but tried multiple times before realizing the file I had downloaded and extracted was the wrong model.

    So if anyone can please help me out with what I need to do to fix the easiest way possible it would be greatly appreciated. I am sorry if this is posted somewhere else please believe me when I say that I am 100% for searching through google and forums and finding a way to do it myself, but I am on a laptop that is so slow it could take eons. It's really only kept around for emergencies like this one lol.T

    thanks in advance for any help! i already have odin (two different versions) and this is my first time ever venturing into rooting any kind of phone so as I am a little lost I am pretty tech savy and capable with the right guidance.
     

    Advertisement

  2. DerrickArm

    DerrickArm Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Feb 2, 2016

    Feb 2, 2016
    7
    0
    5
    Male
    I just don't know what file I'm looking for can anyone help me find it, I am assuming it is the rom for the G530T1 I had found the one for the G360 (which I believe is the Galaxy Core Prime) on this forum for the same problem but I cannot seem to find the one for the Grand Prime. I am only assuming its the rom not really sure if thats what I need to look for or not. Thanks.
     
  3. Jfalls63

    Jfalls63 Android Expert
    Rank:
     #25
    Points:
    818
    Posts:
    4,323
    Joined:
    May 15, 2015

    May 15, 2015
    4,323
    3,340
    818
    Male
    This is all I can find at Sammobile, its the T-Mobile version.

    http://www.sammobile.com/firmwares/database/SM-G530T/
    Not sure if it will work. You could try Kies3 to reflash your firmware.
    With Kies, click on tools in the top bar.
    Select Firmware Update and Initialization.
    Enter your model number and SN when prompted.
    When Kies starts downloading firmware connect phone in download mode.
     
  4. DerrickArm

    DerrickArm Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Feb 2, 2016

    Feb 2, 2016
    7
    0
    5
    Male
    Jfalls63 I'm not sure what Keis is,... the link you sent me to had instructions to install the firmware using odin...

    Instructions
    • Extract (unzip) the firmware file
    • Download Odin v3.10.7
    • Extract Odin ZIP file
    • Open Odin v3.10.7
    • Reboot Phone in Download Mode (press and hold Home + Power + Volume Down buttons)
    • Connect phone and wait until you get a blue sign in Odin
    • Add the firmware file to AP / PDA
    • Make sure re-partition is NOT ticked
    • Click the start button, sit back and wait few minutes
     
  5. Jfalls63

    Jfalls63 Android Expert
    Rank:
     #25
    Points:
    818
    Posts:
    4,323
    Joined:
    May 15, 2015

    May 15, 2015
    4,323
    3,340
    818
    Male
  6. Jfalls63

    Jfalls63 Android Expert
    Rank:
     #25
    Points:
    818
    Posts:
    4,323
    Joined:
    May 15, 2015

    May 15, 2015
    4,323
    3,340
    818
    Male
    Kies3 should automatically download the correct firmware based on your model and SN. I have been recommending it lately since it eliminates guess work. The thing to remember is to connect phone in download mode after Kies has started downloading firmware.

    http://www.samsung.com/ca/support/skp/faq/1072789
     
  7. Jfalls63

    Jfalls63 Android Expert
    Rank:
     #25
    Points:
    818
    Posts:
    4,323
    Joined:
    May 15, 2015

    May 15, 2015
    4,323
    3,340
    818
    Male
    Lordvincent 90 likes this.
  8. DerrickArm

    DerrickArm Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Feb 2, 2016

    Feb 2, 2016
    7
    0
    5
    Male
    JFalls I am just now getting time to sit down and read over this been a very busy day. I just want to say whether it fixes it or not thanks ALOT for all your time, searching, and info it is greatly appreciated.
     
  9. DerrickArm

    DerrickArm Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Feb 2, 2016

    Feb 2, 2016
    7
    0
    5
    Male
    Wow SOoooo much reading and the pages just keep coming at one point I thought it ended at 15 now we're up to 20 and Im only on 12 I have no idea what some of these programs are.... wtf is a TAR file lol reading on....
     
  10. Jfalls63

    Jfalls63 Android Expert
    Rank:
     #25
    Points:
    818
    Posts:
    4,323
    Joined:
    May 15, 2015

    May 15, 2015
    4,323
    3,340
    818
    Male
    I got up to page 35 during lunch and haven't had a chance to pick it back up yet. FRP is something new that I've only heard about in a few threads so its got me interested. More crazy stuff the carriers are adding to make it difficult to get rid of their bloat. I use to think AT&T was the only Carrier that didn't release their firmware, gotta add Metro to the list. If I find anything solid I will post. They did mention that a custom recovery for the H version worked on the T1 so that's progress.
     
    Tmcfarland1983 likes this.
  11. Jfalls63

    Jfalls63 Android Expert
    Rank:
     #25
    Points:
    818
    Posts:
    4,323
    Joined:
    May 15, 2015

    May 15, 2015
    4,323
    3,340
    818
    Male
    Went back and read over a few pages more carefully. Look at page 33, post 323. He has a way to use Kies to get rid of FRP lock and actually flashes T-Mobile firmware and still works with Metro Sim.

    I didn't ask earlier but is your phone currently usable or locked because of FRP?

    Also you should be able to turn FRP off in developer options. To get into developer options, go to settings-about phone and scroll down to your build number. Tap on build number about 8 times to unlock developer options then go back to settings and you should find it when you scroll to the bottom.
     
    #11 Jfalls63, Feb 5, 2016
    Last edited: Feb 5, 2016
  12. DerrickArm

    DerrickArm Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Feb 2, 2016

    Feb 2, 2016
    7
    0
    5
    Male
    It was blocked by FRP however I tried using the 13 step process that someone shared on around page 33-34 and while installing the TAR file via Odin it stopped and said incorrect size and I no longer see the FRP lock rather a blue screen with a triangle "!" stating "An error has occurred while updating the device software. Use the Emergency Recovery function in the Smart Switch PC software...
     
  13. Jfalls63

    Jfalls63 Android Expert
    Rank:
     #25
    Points:
    818
    Posts:
    4,323
    Joined:
    May 15, 2015

    May 15, 2015
    4,323
    3,340
    818
    Male
    Will it boot up now or all you have is recovery and download mode?
     
  14. DerrickArm

    DerrickArm Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Feb 2, 2016

    Feb 2, 2016
    7
    0
    5
    Male
    Just recovery and download.

    I tried the option they provided a link to in the end of the post. and it did not work I got this...


    <ID:0/005> Added!!
    <OSM> Enter CS for MD5..
    <OSM> Binary Check MD5.. Do not unplug the cable..
    <OSM> Please wait..
    <OSM> Checking MD5 finished Sucessfully..
    <OSM> Leave CS..
    <ID:0/005> Odin engine v(ID:3.1100)..
    <ID:0/005> File analysis..
    <ID:0/005> SetupConnection..
    <ID:0/005> Complete(Write) operation failed.
    <OSM> All threads completed. (succeed 0 / failed 1)
     
  15. Jfalls63

    Jfalls63 Android Expert
    Rank:
     #25
    Points:
    818
    Posts:
    4,323
    Joined:
    May 15, 2015

    May 15, 2015
    4,323
    3,340
    818
    Male
  16. creativ3live

    creativ3live Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Mar 16, 2016

    Mar 16, 2016
    2
    0
    5
    Male
    G530T1UVU1AOH9 some one posted this saying that this is the firmware for metro core prime
     
  17. vic30536

    vic30536 Lurker
    Rank:
    None
    Points:
    15
    Posts:
    1
    Joined:
    Mar 25, 2016

    Mar 25, 2016
    1
    0
    15
    Male
    So im in the same bind. My Samsung Galaxy Grand Prime Model: SM-G530T1 is
    Custom Binary block by FRP
    I downloaded the kies and entered the model number but when i entered the sn number it says it is wrong to try again. Can someone please help!!
     
  18. Jfalls63

    Jfalls63 Android Expert
    Rank:
     #25
    Points:
    818
    Posts:
    4,323
    Joined:
    May 15, 2015

    May 15, 2015
    4,323
    3,340
    818
    Male

Share This Page

Loading...