1. Are you ready for the Galaxy S20? Here is everything we know so far!

Rooting 2.3.3

Discussion in 'Android Devices' started by MyEvilBanana, Dec 4, 2013.

  1. MyEvilBanana

    MyEvilBanana Newbie
    Thread Starter

    Hi All, I need some help rooting my Captivate. My phone ,SGH-I897, came with gingerbread.ucke3 2.3.3 preloaded on it and I can't find anything specificly for rooting it. Was going to try methods for 2.3.5 but keep running into walls... After a long trial tring to get Kies to reconize my phone I talked to Samsung and they said my phone is not supported by Kies, I've down loaded drivers for my computer so it'll know I plugged it in but my pc still doesn't see it is so even tho I've downloaded Odin it doesn't see it either. Read on here certain phones you can just put a zip file in the correct folder and reboot and that's about all you need to do. Would that work for me? If someone can give me some direction it be great. I really want all this AT&T junk off my phone and fixing this gps problem for good would be nice. I don't know if I'll get into it enough to start flashing roms or not but I'd like to have the opition... Spent alot of free time the last couple weeks reading old posts and sorting though dead links tring to figure out how to do it the right way for my phone cus I have no interest in bricking my phone... Well thanks in advance
     


  2. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    If you want to update the Captivate you have to use Kies Mini. Full kies is not compatible. You can get a copy of kies mini here.

    Then you should be able to root using the instructions in the rooting thread (I see you posted there, too.)

    Now, after you do all that, you are still using and old phone with an old OS. I know you said you weren't interested in flashing a custom rom, but it could get your Captivate feeling new again and it's not that hard. It would also preclude you from having to do the kies mini thing.

    What I would do (and I did) was to flash the korn kernel for 2.3.5 just to get CWM recovery on your phone and then flash CM10.2 and gapps right away. CM10 will install its own kernel so korn isn't relevant.

    If you're game, I can walk you through it.

    Basically the steps would be:

    1. Backup your files OFF the phone. Anything you want to keep. There are apps to backup the phones databases for email and text messages so you don't lose anything.

    2. Download all the files you need. Odin, korn, CM10 and gapps. Install odin on your PC and copy CM10 and gapss to your phone. DO NOT unzip them.

    3. Flash CWM recovery.

    4. Boot into recover and install CM10 and gapps.

    5. Reboot the phone and set it up now running Jelly Bean.
     
  3. MyEvilBanana

    MyEvilBanana Newbie
    Thread Starter

    I'd be tickled to get as far as rooting... and if I make it that far it be great to have you walk me through the next steps... But here's where I'm stuck

    I've installed and re-installed drivers and/or Kies Mini better then a dozzen times now making sure each time get uninstall/delete anything from Samsung on my pc between tries and re-booting before and after loading again , had a nice chat with a tech at samsung and he walked me though the steps for Kies Mini and drivers install & then when that didn't work I was told Kies Mini wasn't compatible and to just use USB mass storage to transfer files instead. My last attempt I finally had some luck and drivers were loaded when I plugged in my phone,now my pc will see it's a samsung captivate plugged in but only in usb debugging mode. In download mode it knows there's something there but doesn't know what to do with it or what it is. Odin won't see it in usb debugging or download mode. Heimdall will see it in usb debugging mode but I can't do anything with past load their driver and it wont see it in download mode either.
    I've gotten drivers from about 6 different links including one from the samsung tech. This last one that sorta worked was an older link and not from the samsung site (SGH-i987_Captivate_USB_Drivers_5_02_0_2)
    Any ideas? :thinking:
     
  4. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    Two quick questions ... you mention Heimdal, so are you using a Mac? If so, are you trying to run Odin on a Mac running Windows? And, have you tried a different cable and/or USB port on your computer? Samsung phones are very fussy with the cable connection.
     
  5. MyEvilBanana

    MyEvilBanana Newbie
    Thread Starter

    Running windows xp 32bit, the hiemdall came another site as part of a zip that was in an idiots guide to rooting the captivate, strangely it didn't mention windows or mac now that think about it. will try the cable swap this evening. One I've been using came with it and is suppost to be a data cable but looks nothing like my last Samsung phones (none smart phone) past connecting ends.. and I'll try another port. Could it be because the pc is so out dated it has mostly 1.0 usb ports? i think it had one 2.0 I'll try to figure out which one it is
     
  6. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    I would bet dollars to donuts (what a stupid expression ;) ) that you're having issues due to XP drivers and an old PC. Can you get access to a Windows 7 machine?
     
    MyEvilBanana likes this.
  7. MyEvilBanana

    MyEvilBanana Newbie
    Thread Starter

    Ya my pc's about to the end of its road, its 8yrs old & when Microsoft stops with updates for XP next year I'm sure I'll have more issues so I'll be looking for a new one soon... I think my stepdaughter's lap top is running windows 7 I'll give that a try tonight too
     
  8. MyEvilBanana

    MyEvilBanana Newbie
    Thread Starter

    good news and bad...good news it was the windows xp giving me hell, bad news ran odin and flashed both tar files as instructed all seemed fine turn on my wifi so I could go to the market and get the recomended apps and up dates and it went into a start up loop... tried popping the battery out and re-starting it, re-starting through the recovery menu, and re-flashing the KK4_stock_kernal ... still doing it. running some searches to see what else I might try but really hoping for some help getting this thing back to working. The ATT screen comes up and goes to the samsung logo about have way through that the start up sound finally kicks in, after it gets to the home screen I have till its done scanning everything before it starts all over again. I was able to get in and turn off the wifi again but that didnt help just keeps turning back on

    edit: though I turned the wifi back off when it re-starts the wifi is turned back on again automaticly
     
  9. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    Flash CM10 or the rom of your choice, it will replace the insecure kernel you used to root and fix the wifi issue.
     
  10. MyEvilBanana

    MyEvilBanana Newbie
    Thread Starter

    Been racking my brain this morning tring to think of anything I might have done to mess it up before I flash another rom... And after re-reading the directions yet again I realized I didnt upgrade to 2.3.5 so I still have 2.3.3 Should I still flash the cm10 rom before I do anything else?
     
  11. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    I would. Then whatever version of stock you had won't matter.
     
  12. MyEvilBanana

    MyEvilBanana Newbie
    Thread Starter

    Hope I'm not getting annoying, I'm Very Thankful for the help, after making one slip up I'm more leery of what I'm doing. I downloaded cm10.2 and gapps as .zip files. Now since I didn't upgrade and there by don't have cwm recovery on my phone... Do I flash cm10.2 as a .zip file with odin the same way I did the .tar files? And then gapps the same way as well? And if I need cwm recovery how do I get it? Been doing searches and haven't had luck finding anyway to get it other then up dating to 2.3.5 am I missing something?
     
  13. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    No. zip files should be flashed through CWM (or TWRP) but since I am more familiar with CWM I will give you those instructions.

    First, get all the files downloaded.

    You will need an insecure kernel with CWM. I'd try this one >> [KERNEL] SpeedMod Captivate [K13E HPCall VoodooSnd7 SharpnessFix STABLE] - xda-developers. Again, there are multiple versions because the assumption is you want it to be compatible with the installed OS, but since we are going to flash CM10 right away, it won't matter. The kernel will be replaced with CM10. Download the latest .tar file (speedmod-kernel-i897-k13e-500hz.tar), not a zip file.

    You will need the CM10<whatever>.zip and gapps<whatever>.zip Make sure gapps is for the version of android you are installing. For example if CM10.1 is Android 4.1, make sure you get the gapps for 4.1 and not 2.4 or 4.3.

    Copy them to the root of your phone. I assume you can still get your phone to boot and connect to your PC? When you plug it in, and enable storage mode, whatever drive letter is assigned will be the root of your phone. If you can't, then put them on an SD card and put the card in the phone. If you have any important other files on the SD card, back them up. Flashing shouldn't touch the external card, but you never know.

    So ... before you flash copy those two zip files to your phone (CM10 and gapps).

    Make sure the phone has at least an 80% charge and the drivers are installed on the PC you re using. Since you already used Odin, I'll assume they worked.

    Now we are ready.

    Step one. Flashing the new kernel with CWM.

    1. Put the phone in download mode. I've always found the easiest way is to pull the battery for a few seconds, then replace it. Hold the vol. up and vol. down buttons and plug in the USB cable. Do not touch the power button. You should see the yellow triangle and the downloading message.

    2. Fire up Odin on the PC. Your phone will show up as a number in a yellow box. In PDA, check the box and select the speedmod-kernel-x-y.tar file. Leave the other settings as default: PHONE, CSC, PIT should be blank and Re-partition should be un-checked.

    3. Click start. Let it complete. It may try to reboot the phone upon completion and fail. No big deal as long as Odin says it completed.

    Step Two. Flashing CM10.

    1. Shut the phone off and unplug it. If it failed a reboot and is stuck, just pull the battery.

    2. Boot into CWM recovery. Press and hold the vol. up and vol. down buttons and press and hold the power button until the screen flashes. Release the power button while continuing to hold the volume buttons. it will boot into recovery.

    [​IMG]

    3. Clean out the old system. First perform a factory data reset. You use the volume keys to highlight the options and the power button to select. There will be several confirmation screens. once completed it will drop you back to the CWM screen. Now select wipe cache partition. Confirm, confirm. Finally select advanced and wipe the Dalvik cache. When that is done select the ****go back **** option to get to the main CWM screen.

    4. Now we put in CM10. Select install zip from sdcard. It should take you to the root of the internal data partition so if you copied your files there you will see them. You'll have to scroll with the volume keys as it lists all the folders as well. Try pressing up first to see if it takes you to the bottom of the list. Select the CM10<whatever>.zip file and install ... there will be several confirmations again. It will take a while, be patient. When it's done, flash gapps the exact same way.

    5. Reboot. With both CM10 and gapps it should say "completed" when it's done so if you say those you are golden. Just remember, that this is fresh, brand new, never been touched OS so it's initial boot will take a good 10 or 15 minutes to reassemble everything. That's why it was important to make sure the battery had a good charge. If the battery fails during a flash you can brick it.

    Once you do it once, it's pretty easy. Don't get discouraged if it doesn't go exactly right the first time. Good luck and let me know if you run into anything. :)
     
  14. MyEvilBanana

    MyEvilBanana Newbie
    Thread Starter

    almost there I think... it was being difficult so I just put the zips on the external sd card, flashed the kernal, got into cwm wiped everything I was suppost to, went well... but I cant find the zip files... I select external_sd it flashes lines of white type for a tenth of a sec. and then back to the menu screen I was on, went though all the folders that were visible and couldnt find it... ideas?
     
  15. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    Was there anything else on the SD card? If you have a spare you might want to give that a try. Make sure it is formatted as fat32. If those don't work then we can load the files using adb.
     
  16. MyEvilBanana

    MyEvilBanana Newbie
    Thread Starter

    Formatted card with FAT32 only thing I put on it were the zips... in CWM selected install zip from sdcard then external_sd again screen flashed same deal back to the menu screen I was on, at the bottom I noticed it said "no files" think it said that last night too... Would it be ok to hook it back up to the pc and try to put the zips on the root directory again? Think I know what I was doing wrong there, I was trying to get the phone in usb storage (and it wouldn't let me have the opition) in stead of going into "my computer" folder and looking for a drive directory. Can I do this still or has the option for that past? Or would you rather I do the abd method you mentioned?
     
  17. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    IF the phone will boot to Android at this point, then copying directly would be the easiest. If not we'll need to push them to your phone using adb.

    One quick thought about CWM. If you boot to recovery, you have a mounts and storage option. You may have to mount the external SD card before it will see it.
     
  18. MyEvilBanana

    MyEvilBanana Newbie
    Thread Starter

    I saw that option but wasnt sure what it ment exactly when I went into that menu so I backed out of it.... Went -mounts and storage
    Then -mount usb storage
    "USB Mass Storage device
    Leaving this menu unmount your SD card from your PC"
    options
    -unmount
    **go back**
     
  19. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    Here's what you do (just tried it so I know it works). Unplug your phone and shut it off. Boot into CWM recovery. Once you see the CWM menu, plug in the USB cable. Now select mounts and storage>mount USB storage. after a few second you should see the phone appear as a drive letter. This will be the /sdcard partition. Copy your files there. It will look something like the attached image.

    Once the files are copied, on the phone select ++++go back +++++ twice to get to the main menu. The phone will automatically unmount.

    Now, choose install zip from sd card and you should see the files listed at the bottom. If you see them, then just follow the steps to flash CM10 and gapps as before.
     

    Attached Files:

  20. MyEvilBanana

    MyEvilBanana Newbie
    Thread Starter

    The zips are I on the sd card and can see them... This is what I got when I ran
    Finding update package....
    opening update package...
    installing update package...
    assert failed: getprop("ro.product.device")=="captivate"ll... bunch more lines similar to this, then...

    E:Error in /mnt/sdcard/cm-10.2.0-captivatemtd.zip
    (status 7)
    installation aborted

    I ran it twice and got the same thing both times
     
  21. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    I haven't flashed 10.2 yet. I've still got 10.1.3 on mine.

    There are three possibilities. 1.) the package is incompatible with your device. This is the standard SGH-i897 AT&T Captivate, right? 2.) The file you have downloaded is corrupt. Try downloading it again and replace the file currently there. 3.) your external SD card or sim are somehow interfering. remove them.
     
  22. MyEvilBanana

    MyEvilBanana Newbie
    Thread Starter

    Here's the details I may have left out...
    -Samsung Galaxy S Captivate i897 for AT&T, says Android 2.2 platform on the one side of the box and the back says Android 2.1 (typo?), in the "About" on the phone it said gingerbread.ucke3 2.3.3 (straight out the box)
    -I took out sim card before I started our journey
    -I removed SD card before our last try, wanted to eliminate it as a possibility
    -downloaded CM 10.2 from CyanogenMod Downloads
    -downloaded gapps from Goo.im Downloads - Browsing gapps
    -had downloaded them on my Windows XP machine then transfered them to the Windows 7 laptop I borrowed, that might be where something went wrong, will download straight from on-line to Windows 7 this time

    I'm going delete cm10.2 and gapps via the computer, then re-download it via the computer and drag & drop straight in the root directory as before, if it still doesn't work I'll re-do the process with cm10.1.3 and the right version of gapps for it. Before I try to install to make sure I haven't junked up anything along the way I'll use CWM to perform a factory data reset, wipe cache partition, and wipe the Dalvik cache... Unless you think all the wiping is over kill?
    Sound like a plan? Wish me Luck :) I'll give it a run a little later tonight when I have time to commit totally to it, I'll check back to make sure there isn't anything else you think I should change before I start
     
  23. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    Everything sounds kosher, so I'm not sure why 10.2 is failing. I'm going to download it and give it a go, to make sure it is in fact a stable release.

    At this point, I doubt wiping the caches would do much to help, but it would hurt either. Probably not a bad idea just in case there is anything odd hanging around. I'll let you know how I make out with 10.2.

    EDIT: I got the same error with CM10.2. Try 10.1.3
     
  24. MyEvilBanana

    MyEvilBanana Newbie
    Thread Starter

    Ok loaded in and installed... installed very quickly... rebooted... now on a recovery screen that looks different eye and top hatin the middle says:
    cwm-based recovery v6.0.3.6
    then a menu... then...
    cwm-based recovery v6.0.3.6
    warning: no file_contexts
     
  25. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    Just to be absolutely clear ... you flashed CM10.1.3 and when you rebooted it booted directly into recovery? It did not boot into Android 4.2?

    CWM 6.0.3.6 is simply a newer version of CWM recovery. I didn't remember CM10 updating that as well, but apparently it does. Nothing to worry about.

    Since you are on a newer version of recovery now, try the process again ... factory reset, wipe caches, install zip from sdcard ... both cm10 and gapps and then reboot. It should boot into CM10. It might take a while the first time, but you will see the cyanogen animation.
     

Samsung Captivate Forum

The Samsung Captivate release date was July 2010. Features and Specs include a 4.0" inch screen, 5MP camera, 512GB RAM, Hummingbird processor, and 1500mAh battery.

July 2010
Release Date
0
Reviews
Loading...

Share This Page

Loading...