1. Are you ready for the Galaxy S20? Here is everything we know so far!

Rooting a Motorola Charm from Telus Mobility

Discussion in 'Android Devices' started by surgeon1919, Aug 18, 2010.

  1. surgeon1919

    surgeon1919 Newbie
    Thread Starter

    Hi everyone,

    I'm new to the forum and Android but not to Motorola although it's been sometime since I've used one.

    I just bought a Charm from Telus and I would like to unbrand the OS.

    I know it's only the 2nd day that's it's been out but how would or could I go about this?

    I've done some reading on the Milestone board and I've used RSD lite before.

    Any help would be greatly appreciated.

  2. LifeInAnalog

    LifeInAnalog Well-Known Member

    ...I just did a quick search through google and there doesn't seem to be a whole lot of info on customizing the Charm is there?

    It is very early, so maybe some modder/developer will give it a go at some point. Currently, I THINK you're out of luck. But keep looking, keep searching.
  3. GlitchZero

    GlitchZero Well-Known Member

    This is the MILESTONE root forum. But good luck dude. Might be hard this early on.
  4. surgeon1919

    surgeon1919 Newbie
    Thread Starter

    Thanks for the try LifeInAnalog.

    Glitch Zero, I'm very aware this is the Milestone forum but there is no Charm forum otherwise I would have posted my message over there.

    My sincerest apologies for disturbing your day!!!!
  5. ashketchum

    ashketchum Member

    Try the Easy Root Compatibility Test app from the Market. If it says your phone is compatible, then you can use Easy Root to root your phone.
  6. surgeon1919

    surgeon1919 Newbie
    Thread Starter

    Okay I'll check it out ashketchum. Thanks for the info.
  7. ashketchum

    ashketchum Member

    You can also try Universal Androot. Its available here. I believe it uses the same exploit as Easy Root, to root your phone and its free. :)
  8. Brendanmurphy

    Brendanmurphy Android Enthusiast

  9. ashketchum

    ashketchum Member

  10. surgeon1919

    surgeon1919 Newbie
    Thread Starter

    I really don't want anything to do with telus! I really just want this phone to be plain old stock.

    So far I haven't had much time to look up any of the links.

    Thanks again for the info. Much appreciated!
  11. Brendanmurphy

    Brendanmurphy Android Enthusiast

    But the phone is stock telus made no modifications i really don't understand what you are trying to do? Telus installed no boot logo, no apps, no logos NOTHING. The phone is as stock as you can get.
  12. TelusMilestone

    TelusMilestone Android Enthusiast

    lol some peoples kids
  13. surgeon1919

    surgeon1919 Newbie
    Thread Starter

    You guys are obviously right! I didn't buy the phone for myself and I've barely had time to play with it. There's virtually no telus dna in this phone!!

    I still want to root and try and get the best battery life possible. My girlfriend has noticed the battery dies pretty quickly and she doesn't use it as a data phone. (no data plan, occasional wifi).
  14. surgeon1919

    surgeon1919 Newbie
    Thread Starter

    I wasn't able to find the easy root compatibility tool in the app market.

    I've downloaded RSD lite and it pretty much finds my phone.

    I've also downloaded the universal root but I don't know what to do with it and rsd lite doesn't see it.

    I also downloaded the vulnerable sbf file but I can't use it because my bootloader is higher than what is recommended to use it with.

    That page with the Chinese characters isn't much help...

    What else am I missing?!
  15. ashketchum

    ashketchum Member

    You don't need RSD Lite. Universal Androot that you downloaded should be an apk file. You need to copy it to your sd card and then install it using Astro File Manager (available in Market) or if your phone has Quick Office like the Milestone, you can also use that to install the apk file. Once you install it, you should see Universal Androot icon in your app drawer. Launch Universal Androot and use the "Root" button to root your phone.
  16. Brendanmurphy

    Brendanmurphy Android Enthusiast

    Phone defiantly has battery life issues its a bug in the firmware i have already notified Motorola and they have passed it onto the Engineering department. If you take a look at the battery usage Cell standby takes up 50% of the battery. Cell Standby is time without signal but even if you have signal it reports as no signal
  17. surgeon1919

    surgeon1919 Newbie
    Thread Starter

    Ok this makes more sense! And to make sure what exactly can I expect once I use this root? Is 1.6.1 all I need or will 1.6.2 be better? I really can't find a straight answer to both these questions. Sorry, I've tried to be as ressourceful as possible.

    I was wondering if there could be something wrong. Is it just me or do apps just start themselves. I've used the built-in battery manager/task killer and I'm surprised to see the app I closed is running again later. I even leave it on EDGE since she doesn't have a data plan.

    I use a BB Bold 9700, I run whatever, whenever and my battery will last me a solid day with streaming even longer when I don't stream.

    I know I'm comparing apples to oranges but it's still not normal how fast the battery drains on the Charm.
  18. ashketchum

    ashketchum Member

    You should go ahead and use the 1.6.2. It contains newer version of the Superuser app. You will have to reboot your phone once, after pressing the "Root" button. After rebooting you will see the Superuser app in your app drawer. When you use an application that requires root, the Superuser app will prompt you to Allow or Deny permission. You will find screenshots of the Superuser app on this page.

    Also, you can uninstall Universal Androot after you are done rooting your phone.
    surgeon1919 likes this.
  19. scotchjeff

    scotchjeff Lurker

    If I did root my charm, would I lose MS Exchange support?
  20. TelusMilestone

    TelusMilestone Android Enthusiast

    I highly doubt it with out knowing for sure, but even if it did you could always add it back! Once the phone is rooted you can boldly go where it couldn't go before ;)
  21. surgeon1919

    surgeon1919 Newbie
    Thread Starter

    I still haven't done anything to the phone except unlock it.

    We're having the same issue with the SMS timestamp. Any sms message my gf receives shows a -4hr time difference.

    It's being used on Rogers.

    I was just thinking that I should have just bought the flip out to avoid the sms timestamp issue.
    It also got me thinking, is there anyway I could somehow flash the flipout OS onto the charm? It's essentially the same phone but in a different shape. Maybe by having Rogers' native settings there will be less glitches...
  22. JackTheMan18

    JackTheMan18 Member

    If I may ask, how did you get the Motorola Charm unlocked?
    Which unlocker did you use?
    I tried several, and no one could give me a code that worked!
  23. surgeon1919

    surgeon1919 Newbie
    Thread Starter

    I really cannot say how I did it!
  24. surgeon1919

    surgeon1919 Newbie
    Thread Starter

    I also forgot to mention on top of the time stamp problem, my gf is having another problem that is extremely typical with Telus. When a long message is sent, the recipient will received it 5-6 times and maybe the 2nd part of the msg will be attatched but usually it isn't.

    Even though the phone is being used with Rogers she has this telus problem. She's never had it happen on her unbranded/unlocked krzr even when she used a t-mobile v600 after losing her Rogers V600.

    Could we flash the charm with the flipout OS?

Motorola Milestone Forum

Features and specs are not yet known.

Release Date

Share This Page