1. Download our Official Android App: Forums for Android!

Root Rooting an Xperia X10 from Rogers? Here is something good to know!

Discussion in 'Android Devices' started by dgiaffe, Oct 13, 2010.

  1. dgiaffe

    dgiaffe Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    41
    Joined:
    Jul 13, 2010

    Jul 13, 2010
    41
    2
    16
    Hey all, I just rooted my phone and tought everything was fine, because I was able to browse on the Internet OTA. However, after some time I noticed my widgets were not updating, I couldn't connect to the Android Market, I wasn't able to get on Maps neither in Facebook. I tried redowngrading, tried to do a restore of the Build I had (couldn't find one though), tried to do the root procedure again, it still wasn't working. I finally found this. This made the trick after a bunch of research. The procedure on this same website seems pretty clear. Not sure if those could or should be added to the sticky... I think I would of followed that procedure instead since there was no indication on how to find the DeviceID on xda's and I had to do a research myself. Plus, it tells about the APN settings lost with Rogers. Yours to decide if that should be sticked or not ;) Totally loving Android :D
     

    Advertisement

    santu9191 likes this.
  2. sparkdroid

    sparkdroid Member
    Rank:
    None
    Points:
    16
    Posts:
    63
    Joined:
    Aug 4, 2010

    Aug 4, 2010
    63
    6
    16
    After you rooted your phone, did you install a custom ROM? Or did you just root it?

    The reason I ask is that I have an x10a on Rogers that I rooted with the "one click root" method and had no issues at all.

    Just curious.
     

Share This Page

Loading...