Root Rooting broke Google Voice?


I noticed ever since rooting my phone a few weeks ago that I was no longer getting voicemails. It took me a while to notice, because I usually always answer my phone anyway, so I rarely get voicemails to begin with. Nobody that regularly calls me bothered to mention there was a problem with my voicemail, which also contributed to me not knowing there was an issue for a while.

Perhaps it's just a coincidence, but I don't know why it would've stopped working for any reason other than being related to flashing the new firmware.

Currently my Voice number is forwarded to my cell phone, and I use Google Voice for voicemail. After the phone finishes ringing, I get a message saying "the number you have tried to reach is not in service", or something along those lines.

I've uninstalled and reinstalled the Google Voice app. I've tried deactivating and reactivating my cell phone from the list of forwarded numbers in GV's settings online. Neither worked.

The sign I originally missed that seems to indicate the problem is when setting up the Google Voice app for the first time, it tries to set up the voicemail and goes to a "Unfortunately your network carrier is currently not supported..." screen.

It worked fine from November until the firmware switch a few weeks ago, so unless Sprint coincidentally changed something recently, I don't think the carrier is the issue.

Any help?


Android Enthusiast
I cannot assist you in resolving your issues; I can only tell you that I'm fully rooted, new ROM and new theme and have no problems with my Google Voice. Still receive everything fine.