1. Are you ready for the Galaxy S20? Here is everything we know so far!

RPC:S-7 AEC-0 Error

Discussion in 'Android Help' started by Adam Kaas, Mar 6, 2016.

  1. Adam Kaas

    Adam Kaas Lurker
    Thread Starter

    Hello,

    I've seen many threads of people not being able to download things from the Play Store with the error referenced in the title. My problem is I can download anything I want from the play store, but I can't do in-app purchases without receiving the above error. I'm using a DROID MAXX on Wi-Fi only (Not currently connected to a carrier). Any suggestions? I've tried removing my account and re-adding it. I just recently performed a factory reset as well. I've cleared all of the data and cache data for Google Play Service and the framework. I'm out of ideas.
     


  2. scary alien

    scary alien not really so scary
    Moderator

    Welcome to our AndroidForums, @Adam Kaas.

    I thought this sounded familiar and found a thread from last Fall:


    with the end-result being to:

    -Go to Settings->Applications->Manage Applications->All
    -Select "Clear Data" for Google Play Services and Google Service Framework
    -Reboot the device​

    (edit: it does seem like you've already tried this, though :( )

    Not 100% sure that will work, but thought I'd suggest it...

    Cheers!
     
    tube517 likes this.
  3. tube517

    tube517 Android Expert

    Double check that time and date is correct.

    Following these steps will sync your device with our servers.

    1. Open your device's main Settings app.
    2. Touch Date and time.
    3. If you see "Automatic date & time" and "Automatic time zone," uncheck them.
    4. Manually change the date and time so that they are wrong.
      • Note: don't worry - we'll change them back to the right date and time in a minute.
    5. Tap the Home Screen button.
    6. Go back to your Date and time settings (repeat steps 1 & 2).
    7. Manually change the date and time, so that they are correct.
    8. Re-check the boxes for "Automatic date & time" and "Automatic time zone."
     
    scary alien likes this.
  4. Adam Kaas

    Adam Kaas Lurker
    Thread Starter

    @scary alien @tube517 Thank you for your contributions. Unfortunately neither method works. Again, I can download things from the play store, but I can't make in-app purchases.
     
    tube517 and scary alien like this.
Loading...

Share This Page

Loading...