1. Are you ready for the Galaxy S20? Here is everything we know so far!

RSDLite on Windows 7x64 Problems and Solutions

Discussion in 'Android Devices' started by GregTard, Oct 29, 2010.

  1. GregTard

    GregTard Well-Known Member
    Thread Starter

    Make sure you are using the correct sbf file for your device. There are many different sbf files for the DroidX going around and if you use the wrong sbf file, your phone could be bricked permanently. I am not aware of the status of other device sbf files so please do the research to find out if your device has a similar situation. As more devices include a locked bootloader, this will become more widespread. The following sbf files exist for the different DroidX versions.

    • 2.1 or leaked 2.2 (Motorola version 2.3.15) - If you are running 2.1 or one of the leaked versions of 2.2 (Motorola version 2.3.15 or any lower than .15), you did not upgrade your bootloader or kernel, you can use the 2.1 sbf (The_Gift). The bootloader version that the 2.1 sbf can be used for is 30.01. If you use the 2.2 official (Motorola version 2.3.15) sbf, you will be upgraded to the new kernel but not the bootloader and will not be able to get back to the 2.1 versions.
    • 2.2 OTA (Motorola version 2.3.15) - If you are running 2.2 OTA (Motorola version 2.3.15), you have upgraded your bootloader and kernel. The bootloader version is 30.03 and you can not use the 2.1 sbf. It will brick your device.
    • 2.2 OTA (Motorola version 2.3.15) - There is also a system only 2.2 (Motorola version 2.3.15) sbf. This does not change your bootloader or kernel but I am unsure of it's results if used on a 2.1 device. I would not risk it.
    • 2.2.1 (Motorola version 2.3.320) - There is also a new leak for 2.3.320 which includes a new update to the kernel and bootloader. It will upgrade your bootloader to 30.04 and you can't revert back to 2.3.15 after using. Their is a system only sbf for this leak that should only be used with the 30.04 bootloader. Consult this thread for more info.
    • 2.2.1 (Motorola version 2.3.320) - There is now a full sbf that should only be used with the 30.04 bootloader. Consult this thread for more info.
    • 2.2.1 (Motorola version 2.3.340) - There is now a full sbf that should only be used with the 30.04 bootloader. Consult this thread for more info.

    To access your bootloader on the DroidX, press the volume down + camera + power at the same time and hold. You should see a flash and then you can release. Then the bootloader will be displayed.

    Remeber Rootzwiki is the Bomb ;) when it comes to sbf help.

    All of the below information was gathered while troubleshooting issues with my DroidX and my computer running Windows 7 x64. Some have contacted me saying this has helped them with other devices and OS versions so it may help you even if you are not running Windows 7 x64 or using a DroidX.

    RSDLite on Windows 7 x64 is extremely uncooperative. Many have had problems and eventually use XP, another computer, or Linux to SBF so I thought I would post all of the fixes to try in one place. Hopefully the mods will see fit to put this in a sticky.


    I have grouped this into the most common symptom/solution relationship I have seen from the 100+ posts I have read on this. If you have other solutions, symptoms, or relationships that I missed, let me know and I will be glad to add them. These are only the ones that I have seen personally and seen the most of in the forums.

    If your device is not present in RSDLite:
    • Make sure you are using the latest version of RSDLite (4.9 at this time) with a minimum of 4.7 with patch.
    • Make sure you have the latest drivers for your system (x64 or x86).
    • Run RSDLite as an administrator. Set this on the executable in the RSDLite directory (C:\Program Files (x86)\Motorola\RSDLite\SDL.exe).

    If your "Start" button in RSDLite is disabled:
    • Use a short name for the sbf file. I named by "X" which comes in handy later.
    • Try placing the sbf file in different locations. The root of C:\ seems to have the best success while others have had luck with their My Documents folder.
    • Run RSDLite as an administrator. Set this on the executable in the RSDLite directory (C:\Program Files (x86)\Motorola\RSDLite\SDL.exe).

    Flash process fails generating the following type of errors
    Code (Text):
    1. 15:39:54, November 18, 2010
    2. Line: 475
    3. ERROR: Not enough image files created
    4. File: D:\GitProjects\hdt_windows_flash\flash\code\flashd ll\pst_fp_flashfilemi.cpp
    5. Device ID: 0
    Go into the directory you installed RSD Lite (for Win7 x64 the default is C:\Program Files (x86)\Motorola\RSD Lite\) and look for a file that starts with "FlashErrorLog" (if multiple exist, use the last modified). If you see the above mentioned error, the only fix I have seen is to do the following:
    • Uninstall RSDLite and all Motorola drivers
    • Re-download all files (RSDLite, Motorola drivers, and sbf
    • Install the latest version of RSDLite (currently 4.8)
    • Install the latest drivers for your system (x64 or x86).
    • Run RSDLite as an administrator. Set this on the executable in the RSDLite directory (C:\Program Files (x86)\Motorola\RSDLite\SDL.exe for Win7 x64).
    • Use a short name for the sbf file. I named by "X" which comes in handy later.
    • Try placing the sbf file in different locations. The root of C:\ seems to have the best success while others have had luck with their My Documents folder.

    Flash process fails immediately with error "Failed Flashing process. (0x7100)":
    RSDLite has a bug that will cause the flash process to fail. I found the answer on these forums after weeks of searching so I will quote the OP and link to the original post. Please thank the OP if this helps you.
    View original post here.

    To determine if this bug is your problem, go into the directory you installed RSD Lite (for Win7 x64 the default is C:\Program Files (x86)\Motorola\RSD Lite\) and look for a file that starts with "FlashErrorLog" (if multiple exist, use the last modified). Open it, and if you see something like this:
    Code (Text):
    1. Line: 865
    2. ERROR: \\?\c:\SPRecovery_ESE81.sbfwtƒyo

    1. Download the Forums for Android™ app!


  2. sund0wn

    sund0wn Android Expert

    you put a lot of work into that. certainly deserves a "thanks"

    hopefully this saves someone a headache. i know what a heartstopper it is to have a bricked phone, and have RSD problems. i found this out on the day of the original 2.2 leak.
  3. Steven58


    Great job! This belongs in the Root section as no one here, who doesn't root (main forum) knows what RSDlite even means! ;) Moving it. Thanking you.

  4. ECFfighter7232

    ECFfighter7232 Android Expert

    Aweswome! thank you! I'm gonna try these out as soon as I get back to my laptop at home. I have not been able to get RSD to work on my Win 7 machine at all. Fortunatly I've had my work computer on xp which has worked for me.
    I run into the "start button greyed out" catagory. device always shows up, but the sbf file never does.
  5. colchiro

    colchiro Extreme Android User

    Win7 x64 here and RSD worked fine the first time. My experience was the latest Motorola drivers, currently 4.7.1, were required after I updated to froyo. If you have trouble recognizing or connecting to your phone via usb, run the Motorola Driver Installer and update your drivers. (Start... programs... Motorola) Make sure you right-click on the little blue M in your tray (by the clock) and turn off the spam web page (when phone connects, launch... nothing).

    BTW, the fix for many things not working with Vista or Windows 7 is to right-click on the icon and choose "run as administrator", including command prompts used for things like adb shell. It's the equivalent to "root" on your phone.
  6. sund0wn

    sund0wn Android Expert

    i think i am one of the very first people to have this happen with the 2.1 sbf. i couldnt find info about this ANYWHERE. i accidentally renamed it dx.sbf, and it worked like a charm.

    definitely follow the outline. it is sure to fix that problem. shorten the name of the sbf. and like the OP said, if that doesnt work, try moving the file around. try the desktop, then the root of the C: drive, then try the my documents folder, and if none of those work, just keep at it. but my bet is that renaming to dx.sbf (or x.sbf as the OP said) should fix the issue.
  7. hyperlite

    hyperlite Well-Known Member

    Thank you for this!
  8. PerCompLLC

    PerCompLLC Android Enthusiast

    Sticky Maybe??

    Edit: Worked like a charm!!!
  9. eulerphi8

    eulerphi8 Well-Known Member

    Finally got it work on my Win 7 machine. Thank you very much! Like you said I had to change the length of the filename until I got the right length.
  10. mjd515

    mjd515 Well-Known Member

    i followed all of your recommendations and never had a problem so thank you for helping me avoid a problem! :)
  11. mcsix93

    mcsix93 Lurker

    I keep getting an error that it failed and am trying to follow the directions above but I do not seem to be getting an a FlashErrorLog. At least I cannot find it. Now when connecting my phone it is not showing up at all as a device in RSD. Any thoughts?
  12. hyperlite

    hyperlite Well-Known Member

    I started working through this last night, just to make sure i could get right to flashing my phone if i needed to. Most of the guides say to have your phone in debug, but my phone will only stay in debug if connected for charge only. In this mode, RSD does not see it. I had to connect in PC Mode...the driver install fails, but RSD sees it. Mind you, i didn't actually try and flash, it may fail immediately for all i know.

    Try a search of your PC for flasherrorlog maybe?
  13. GregTard

    GregTard Well-Known Member
    Thread Starter

    Does your phone say that it is still connected on the screen and is it showing up in Device Manager on your machine (right click "Computer", select "Manage", select "Device Manager" on the left side)?
    Your phone should say

    Battery OK
    OK to program
    Transfer Mode:

    Are you connecting through a USB hub?

    Have you disconnected and reconnected your phone?

    Have you rebooted your phone in the bootloader again?

    Is your computer 32 or 64 bit?

    Where did RSDLite get installed?
  14. mcsix93

    mcsix93 Lurker

    I am not at home to give all answers at the moment. Work computer is locked down and I cannot install RSD on this machine. When I press J and D plus the power on button the phone comes on and goes into a blue screen with a black motorola logo. At the bottom left the phone says bootloader USB Init. This is on a Backflip Sorry not a droid. I was pointed to here from another thread/forum. I have been looking all over trying to figure this out. When I posted this I did not even notice it was a droid forum. Sorry.
    Computer is Windows 7 64bit. RSDLite is installed in Program Files (x86)/Motorola/RSDLite i think. I will keep searching.
  15. Trooper

    Trooper Android Expert

    Im trying to SBF. Running it on Windows 7 32 Bit. When trying to flash I am getting this error.

    15:39:54, November 18, 2010
    Line: 475
    ERROR: Not enough image files created
    File: D:\GitProjects\hdt_windows_flash\flash\code\flashdll\pst_fp_flashfilemi.cpp
    Device ID: 0

    15:39:55, November 18, 2010
    Line: 544
    ERROR: Error processing flash file.
    File: D:\GitProjects\hdt_windows_flash\flash\code\flashdll\FlashHdlr.cpp
    Device ID: 0

    Forgot to mention this is from the FlashErrorLog. Since it kept referencing D, I decided to try running it from a flash drive. No errors yet but it still says in process. Gosh, I wonder if I just totally hosed my phone by trying this. :(

    EDIT: Praying this is going to work here. I just accidentally unplugged my phone. Looks like this is going to be a nail biter here.
  16. Airmaxx23

    Airmaxx23 Android Expert

    Did you try doing a factory reset prior to flashing? Also, try flashing using a different USB connection type (PC mode, media sync or USB mass storage).
    Trooper likes this.
  17. Trooper

    Trooper Android Expert

    I did do a factory reset. Right now its been about 20 minutes or so, its says its executing, and its at 32%. Im just concerned since I accidentally kicked the plug out of the pc right before it started that my phone is hosed. :(

    The green LED also went out after I basically kicked the plug out. I plugged it back in as quick as I could, but the LED did not come back on. The program is doing something, but have no way of telling until its done.

    I just hope I did not hose my phone. Thank you very much for your reply.
  18. Airmaxx23

    Airmaxx23 Android Expert

    Chances are you'll need to do it again.
  19. Justintoxicated

    Justintoxicated Android Enthusiast

    Wow I found the exact opposite to be true. I gave up trying to get drivers to work right with Win XP_x86 after wasting about 4-5 hours and trying all kinds of crazy fixes, but everything worked first try with win7x64, installed and SBFed on the first attempt, phone was detected etc.

    My Phone still is not recognized in XP.
  20. Trooper

    Trooper Android Expert

    Correct. I gave up for today. When I have time, I will try to sbf.
  21. GregTard

    GregTard Well-Known Member
    Thread Starter

    Sorry, I have been tied up with a huge yard sale all weekend. Trying to make some more $$$ for the Christmas season. Trying ot see how much money I can make selling my computer stuff that my wife doesn't now about so I might actually be able to surprise her this year.
    Some of the items in the OP pertain specifically to the DX like the RSDLite version since 4.7 was the first release to include DX drivers I believe, but the Backflip I am not sure when it was supported initially. Some of the issues are RSDLite and or Windows 7 problems and should be applicable no matter what phone. If your phone is not showing up in RSDLite the first thing is to verify the drivers are still present and make sure they are the lates versions using the Motorola driver utility. Also verify that the USB port is not the problem and the cable by trying different ones.

    Where was RSDLite installed to? The only suggestion I have is to uninstall drivers and RSDLite, re-download, and start over. I found a few posts mentioning those errors and that is what they did. The problem occurs across multiple devices so isn't DX specific, but I will add this situation to the OP with a suggestion to uninstall drivers and RSDLite, redownload all needed files, and try again. If you get it to work, let m eknow what you did so I can add it to the OP. Hopefully it will help someone else down the line.

    I have lost connection before while in the sbf process. It errored at the end and I was able to start it again and succesfully sbf. You should be fine.

    I have read so many posts with problems but have no idea how many people had no problems. This is the first I have seen of a problem on XP that wasn't due to no drivers, incorrect version, or some other mistake. WinXP is so open compared to Win7, I can't think of any reason it wouldn't work unlike Win7 where I could think of many things to break the process when comparing default OS setup. I wonder if the USB bus might be the problem. I assume you don't care since it owrks fine on WIn7, but I am just curious.

    On another note:
    I hate car commercials this time a year. Hopefully someday I will make so much money that I can buy my wife a car for Christmas and it be a surprise. Right now I can't even spend $50 without her knowing. I need one of those secret off-shore accounts to funnel money into .... and some money to funnel into it. :)
  22. Justintoxicated

    Justintoxicated Android Enthusiast

    Seems to be a driver issue I'm having in XP, but even with the correct drivers RSD Lite never identifies the phone. So I don't know. I did have UAC disabled in win7x64 (User account control).
  23. bouchigo

    bouchigo Android Expert

    My HDD crashed a couple of days ago, I had to re-install Win 7 64-bit on a new HDD.

    Now I am having a problem installing the MTP USB Driver (all other drivers install fine), anyone else having issues with this???
  24. Steven58


    Yes, indeed. My apologies. I didn't see the request until today. In the future, if you folks can PM me or GMB or any of the other staff who frequents this section, we can do it for you sooner. Thanks! :)
  25. G.Armour

    G.Armour You know you want to.

    Links to the sbf's or did I miss them?

Motorola Droid X Forum

The Motorola Droid X release date was July 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, TI OMAP3630 processor, and 1540mAh battery.

July 2010
Release Date
Similar Threads - RSDLite Windows 7x64
  1. Milo Williamson
  2. Fire Marshal Bill
  3. cycv5
  4. Boowho
  5. R2D6
  6. Milo Williamson
  7. ghostanime2001
  8. RU2022
  9. oldun
  10. willsp28

Share This Page