1. Download our Official Android App: Forums for Android!

Apps Running Android app from an Android Device

Discussion in 'Android Development' started by prajakta, Sep 22, 2011.

  1. prajakta

    prajakta Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Sep 22, 2011

    Sep 22, 2011
    1
    0
    5
    Hello All,

    I am currently building an Android app using Eclipse and phonegap.I am successfully able to run the app on an Emulator. I want to test it on a device but however Eclipse just doesn't recognise my android device. I have made sure that i have downloaded all the required usb drivers and also on my device i have set USB debugging to true. I have searched a lot over the web but cant really find the answer to this problem.

    Can anyone help me with the same?

    Cheers,
    Prajakta
     

    Advertisement

  2. JiMMaR

    JiMMaR Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    363
    Joined:
    Jun 12, 2010

    Jun 12, 2010
    363
    57
    53
    plug in your phone , make sure eclipse is running
    go to the folder where you installed the sdk
    go to platform-tools folder
    hold shift and right click on any empty space, then chose "open command window here"
    type this "adb remount" it should give you remount successfully

    if that didn't work , your computer didn't recognize your phone
    it'd be more helpful if you mentioned which device you have and which OS you are using
    [I assumed you are using windows, it also differs if you are using 64bit or 32bit versions]
     
  3. Laxidasical

    Laxidasical Newbie
    Rank:
    None
    Points:
    16
    Posts:
    25
    Joined:
    Aug 25, 2011

    Aug 25, 2011
    25
    3
    16
    Chicago
    This happens to me every blue moon. While your device is plugged in and Eclipse is open, turn off USB Debugging, wait a few seconds, then turn it back on. Eclipse should recognize the device again...
     
  4. gekaap

    gekaap Lurker
    Rank:
    None
    Points:
    25
    Posts:
    6
    Joined:
    Jun 13, 2012

    Jun 13, 2012
    6
    0
    25
    Hi, I know this is an old thread, but I'm having pretty much the same problem and didn't see a need to create a new thread.

    I've been having a horrible time trying to simply get started in learning how to develop my own apps. I began by downloading the eclipse ADT bundle here. Initially I failed to follow the setup instructions properly, and ultimately could not run the "My First App" app on my device or an emulator when I tried. I then started over and went back and fixed my errors and problems with the setup, but I still cannot run the app. I am using Windows 7 64 bit, and my device is an HTC Evo 3D 4G from Virgin Mobile with Android 4.0.3.

    Attempting to run the app resulted in this feedback from the Eclipse console:

    I took this to imply that maybe eclipse was looking for an android 4.2 device (which didn't make a great deal of sense because I thought that the target was only supposed to be the highest supported version). So I deleted the project and recreated, changing the target to 4.0.3 to match my device. The same issue occurred.

    I then attempted the advice of the two above posts, starting with the "adb remount" suggestion. This was the feeback I was given:

    I then attempted to disable and enable debugging mode. App still would not run. Reattempted the adb remount, and was given "device not found" again.

    One note: This is a new phone, and my old phone was an LG Optimus runing Froyo. I notice on my new device plugging in the USB cable results in a prompt to choose a connection type (charge only vs disk drive). I'm not accustomed to this option as my Optimus did not distinguish between the two. (I don't know if this is prompt is an HTC thing or an ICS thing.) My assumption was that I needed to select the "disk drive" option, however I've repeated my attempts with "charge only" selected, and have not had any success with that either.

    One final note, I've also tried to create virtual devices to see if I can at least get the app to run, and that has been useless. Either eclipse freezes when I create the virtual device, or when I try to turn the boot the virtual device, it never boots (I let it sit for an hour, and the boot process was stuck on the android screen still). I don't know if there's anything in that that offers relevant information at the moment.

    Thanks in advance for any help.
     
  5. shredcode

    shredcode Member
    Rank:
    None
    Points:
    16
    Posts:
    30
    Joined:
    Mar 31, 2013

    Mar 31, 2013
    30
    3
    16
    For your HTC Evo3d issue...That sounds like you do not have the proper HTC driver installed. I would go to HTC's support site and download the HTC Sync software. Install that software halfway...The first half of the installation is the USB driver (which is what you need to get it to work), once the driver is installed you can cancel the installation since you have what you need to get it to recognize the device.

    I have an Evo3d from Sprint that i've used as a dev device, and the above is how I was able to get it to work.
     
  6. zionlimb

    zionlimb Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jun 22, 2013

    Jun 22, 2013
    1
    0
    5
    I had the same problem using a Galaxy S3 with Android 4.1.2 and solved it. Hereby the solution.

    First install the SDK Platform and ARM EABI of your Android version:
    1- Run Windows -> Android SDK Manager.
    2- On the Android SDK Manager check mark "SDK Platform" and "ARM EABI..." of Android 4.1.2 (API 16) which was not installed. In your case, you should choose the aforementioned two options but for your Android version.
    3- Click the "Install Packages" button.
    4- Wait for the installation to finish.

    Next, create the project again selecting your android version as target platform.

    Then, on your phone, enable developer options AND "USB debugging"

    Now try to run your first application again.

    Hope this helps!

    Regards,
     

Share This Page

Loading...