S Beam error message on new Samsung Galaxy S5

Hey all,
I'm new to this site. I recently defected from Apple and bought a midnight colored galaxy S5 about two weeks ago. I love the phone. A few days ago, a friend and I were trying out the NFC S beam capability by touching s5's and swapping pics that way. It worked perfectly. Today, my friend tried to send me a video that he had recorded on his galaxy s5 the same way, and I kept receiving an error message that read "S beam not working on device". I've gone to application manager, looked up beaming services, and cleared the cache (as was suggested on one you tube video), performed a restart, turned on and off the NFC icon, checked to make sure the S beam was on (it was), and have not found a successful way to transfer pics and videos via NFC-S Beam. IT WORKED TWO DAYS AGO, WHY ISN'T IT WORKING NOW? I haven't made any changes to the settings (that I know about). Please help!
Hello Sharmander, and welcome to the forums!

First, I need to ask if your phone is rooted. Whether it is or not will affect how we help you.

Also, what carrier are you using? While it's a minor detail, it can also change how we help you.

Finally, have you installed any apps over those past two days?