1. Download our Official Android App: Forums for Android!

Root S-Off htc inspire 4g, rooted and unlocked

Discussion in 'Android Devices' started by tmcphersonjr61, Jul 21, 2013.

  1. tmcphersonjr61

    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Jul 21, 2013

    Jul 21, 2013
    13
    6
    16
    Male
    Licensed Practical Nurse
    Hagerstown, Maryland
    I am a noob here and have been working on pc's for many years. However I am not a "command line" guru. I am trying to install jellytime from the xda site on my sons HTC Inspire 4g AT&T. After a week of reading many posts and trying multiple apps, I have managed to get the phone unlocked using htcdev unlock tool and to get it rooted using HTC Quick Root. I have been trying to install the ROM without success, I think because phone is still s-on, using Ext4 Recovery. Have read many posts and tried to follow instructions from Scotty85 without any luck. It is very frustrating. I truly don't care about leaving AT&T and I only want to update my son's phone to jellybean for him to play with until he gets my Galaxy S2 Skyrocket in a few months. Any help would be most greatfully appreciated. Bear in mind, I am a nurse and will not be able to look for answers or e-mails frequently due to my job. I will respond to help as soon as I can. Thanks again.

    ACE PVT SHIP S-ON RL
    HBOOT-2.00.0030
    MICROP-0438
    RADIO-26.17.14.11_M
    eMMC-boot
    Feb 20, 2012 16:03:18
    Running GB 2.3.5
     

    Advertisement

    scotty85 likes this.
  2. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member
    Rank:
    None
    Points:
    3,118
    Posts:
    32,107
    Joined:
    Jan 3, 2011

    Jan 3, 2011
    32,107
    24,090
    3,118
    Scotland
    Welcome to AF! :)

    How far along are you with the install? Whereabouts in the process is it failing?
     
    scotty85 likes this.
  3. tmcphersonjr61

    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Jul 21, 2013

    Jul 21, 2013
    13
    6
    16
    Male
    Licensed Practical Nurse
    Hagerstown, Maryland
    It keeps failing when I get to fastboot boot <recovery name>.img. Maybe I missed something and have the wrong recovery image? Thanks for the reply.
     
  4. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member
    Rank:
    None
    Points:
    3,118
    Posts:
    32,107
    Joined:
    Jan 3, 2011

    Jan 3, 2011
    32,107
    24,090
    3,118
    Scotland
    Are you actually typing <recovery name>.img or replacing <recovery name> with the name of the recovery image? You should be using the name of the image file.
     
    scotty85 likes this.
  5. tmcphersonjr61

    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Jul 21, 2013

    Jul 21, 2013
    13
    6
    16
    Male
    Licensed Practical Nurse
    Hagerstown, Maryland
    Sorry for the confusion. Yes I did type the actual recovery file name. I tried the ace_recovery_ext. I also d/l and tried the one for ra-vigor. Both times the command prompt field said it was unable to load program.
     
  6. tmcphersonjr61

    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Jul 21, 2013

    Jul 21, 2013
    13
    6
    16
    Male
    Licensed Practical Nurse
    Hagerstown, Maryland
    I am at work and replying from memory. I was following a thread from Scotty 85 on how to replace recovery image on a phone with s-on. Current installed sw is version 3.20.502.52_us.
     
  7. scotty85

    scotty85 Extreme Android User
    Rank:
    None
    Points:
    1,413
    Posts:
    11,131
    Joined:
    Jul 25, 2010

    Jul 25, 2010
    11,131
    7,411
    1,413
    i assume your following this guide: http://androidforums.com/desire-hd-...-how-unlock-install-recovery-root-htcdev.html

    did the md5sum of your image match the one listed in the guide? (042e9fa838521592ec9224bfb27df52a)

    how exactly is it failing? there are many ways that the recovery can fail to boot,or flash,so well need a little more to go on,rather than just spouting off more questions that may just confuse you further.

    first thing that comes to mind from the info you provided,is your bootloader unlocked? you didnt mention that in your hboot info. overtop of the other info you provided,you should see a big,pink banner displaying the state of the bootloader: locked or unlocked

    2.00.0030 should be a compatible hboot,and have that banner. in order for the recovery to boot,or permantly flash,you will need to be unlocked

    next time you try the process,copy and paste the session from your cmd window. this will help up figure out exactly what/where its going wrong :)

    to copy the cmd window: right click.click mark. highlight everything in white. hit enter or right click again. paste into a reply here on the forum :)
     
    El Presidente likes this.
  8. tmcphersonjr61

    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Jul 21, 2013

    Jul 21, 2013
    13
    6
    16
    Male
    Licensed Practical Nurse
    Hagerstown, Maryland
    Scotty85, yes, i was following that thread. The md5 checksum did match. If you look I stated in my first post that phone was unlocked using htcdev unlock. I probably should have specified that the boot loader is unlocked and I have managed to root the phone. I am still unable to turn the s-off. I lost the post where you mentioned a "wire method" or something similar from joupunut? I think that was the name. I can't copy the command window unless I go thru all the steps again. Can do that tomorrow evening after work. Would you like me to do that again? I do appreciate any help. The phone is working fine. My son just wants to have android jellybean until he gets his upgrade for Christmas. Thanks again for your assistance.
     
  9. tmcphersonjr61

    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Jul 21, 2013

    Jul 21, 2013
    13
    6
    16
    Male
    Licensed Practical Nurse
    Hagerstown, Maryland
    Microsoft Windows [Version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation. All rights reserved.

    C:\Windows\system32>cd c:\miniadb_inspire

    c:\miniadb_inspire>adb devices
    List of devices attached
    HT1ALT211659 device


    c:\miniadb_inspire>md5sums ace_recovery_ext_4

    MD5sums 1.2 freeware for Win9x/ME/NT/2000/XP+
    Copyright (C) 2001-2005 Jem Berkes - PC-Tools.Net: Tools and utilities for Windows, Unix/Linux, DOS
    Type md5sums -h for help

    [Path] / filename MD5 sum
    -------------------------------------------------------------------------------
    [c:\miniadb_inspire\]
    ace_recovery_ext_4 042e9fa838521592ec9224bfb27df52a

    c:\miniadb_inspire>adb reboot bootloader

    c:\miniadb_inspire>fastboot devices
    HT1ALT211659 fastboot

    c:\miniadb_inspire>fastboot flash recovery ace_recovery_ext_4.img
    error: cannot load 'ace_recovery_ext_4.img'


    c:\miniadb_inspire>fastboot flash recovery <ace_recovery_ext_4>.img
    error: neither -p product specified nor ANDROID_PRODUCT_OUT set

    c:\miniadb_inspire>fastboot flash recovery <ace_recovery_ext_4.img>
    The syntax of the command is incorrect.

    c:\miniadb_inspire>


    This was done under command prompt <run as administrator>. Any help appreciated. I did rename the miniadb folder for me and I copied and pasted the image file into the folder separate from the d/l since it didn't work in the other folder.

    Thanks. Tom

    Inspire shows
    ***UNLOCKED***
    ACE PVT SHIP S-ON RL
    HBOOT-2.00.0030
    MICROP-0438
    RADIO-26.17.14.11_M

    FASTBOOT USB

    <VOL UP> to previous item
    <VOL DOWN> to next item
    <POWER> to select item

    BOOTLOADER <highlighted>
    REBOOT
    REBOOT BOOTLOADER
    POWER DOWN

    As I said, device has been unocked using htcdev process and rooted using htc quick root 1.1.13
     
    scotty85 likes this.
  10. scotty85

    scotty85 Extreme Android User
    Rank:
    None
    Points:
    1,413
    Posts:
    11,131
    Joined:
    Jul 25, 2010

    Jul 25, 2010
    11,131
    7,411
    1,413
    offhand,are you sure your recovery is an image file,and not something else?

    your first command is missing the file ext:
    it should be md5sums ace_recovery_ext_4.img

    as you can see below,the same didnt work for me,i needed to include the .img file extension to get it to work properly:

    Code (Text):
    1. Microsoft Windows [Version 6.1.7601]
    2. Copyright (c) 2009 Microsoft Corporation.  All rights reserved.
    3.  
    4. C:\Users\Scott>[COLOR="Red"]cd c:\miniadb_inspire[/COLOR]
    5.  
    6. c:\miniadb_inspire>[COLOR="red"]md5sums ace_recovery_ext_4[/COLOR]
    7.  
    8. MD5sums 1.2 freeware for Win9x/ME/NT/2000/XP+
    9. Copyright (C) 2001-2005 Jem Berkes - http://www.pc-tools.net/
    10. Type md5sums -h for help
    11.  
    12. [Path] / filename                              MD5 sum
    13. -------------------------------------------------------------------------------
    14. Error: Unable to read file/directory ace_recovery_ext_4
    15.  
    16. c:\miniadb_inspire>[COLOR="red"]md5sums ace_recovery_ext_4.img[/COLOR]
    17.  
    18. MD5sums 1.2 freeware for Win9x/ME/NT/2000/XP+
    19. Copyright (C) 2001-2005 Jem Berkes - http://www.pc-tools.net/
    20. Type md5sums -h for help
    21.  
    22. [Path] / filename                              MD5 sum
    23. -------------------------------------------------------------------------------
    24. [c:\miniadb_inspire\]
    25. ace_recovery_ext_4.img                         042e9fa838521592ec9224bfb27df52a
    26.  
    27. c:\miniadb_inspire>
    28.  
    double check and make sure your recovery is a .img file,and not some other type.

    you might also go thru this small checklist,and make sure nothing is messing with your connectivity:
     
  11. tmcphersonjr61

    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Jul 21, 2013

    Jul 21, 2013
    13
    6
    16
    Male
    Licensed Practical Nurse
    Hagerstown, Maryland
    I looked in properties to see if it is a .img file and did not see that. Not sure, could I have inadvertently done something wrong. I unzipped with WinRAR. Do I need to use a different program. Will try all you have sent me tomorrow after work. Thanks again for your quick and thorough replies.
     
  12. scotty85

    scotty85 Extreme Android User
    Rank:
    None
    Points:
    1,413
    Posts:
    11,131
    Joined:
    Jul 25, 2010

    Jul 25, 2010
    11,131
    7,411
    1,413
    you are quite welcome :)

    onthe unzipping,im not 100% sure on that one. i would think winrar would be fine,but ive not personally used it. i use 7 zip,or you should be able to just unzip natively without an other program,if youre using windows 7.

    starting to sound like the file type is the cause of your prollems... when i check properties,it looks like the attached:
     

    Attached Files:

  13. tmcphersonjr61

    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Jul 21, 2013

    Jul 21, 2013
    13
    6
    16
    Male
    Licensed Practical Nurse
    Hagerstown, Maryland
    I do use Windows 7. Will re download and unzip and retry. Will post
    results tomorrow evening.
     
    scotty85 likes this.
  14. tmcphersonjr61

    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Jul 21, 2013

    Jul 21, 2013
    13
    6
    16
    Male
    Licensed Practical Nurse
    Hagerstown, Maryland
    It worked this time. Currently installing jellytime using 4ext. The problem was the file was not an .img file. When I changed the name as you suggested, it changed the file type on my PC. I am running a Windows 7 PC. Live and learn. If I have any further issues after I install jellytime (jellybean) and google apps and inspire mods, will post here. Thanks all for your help and a special thanks to Scotty85 Android Guru!!!!!
     
    scotty85 likes this.
  15. tmcphersonjr61

    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Jul 21, 2013

    Jul 21, 2013
    13
    6
    16
    Male
    Licensed Practical Nurse
    Hagerstown, Maryland
    Update, Have tried to install jellytime 4 times using 4ext after finally flashing the recovery img. Now the phone stays stuck on the HTC logo and goes no further. have waited 15 minutes to be sure not just having long first boot. Any suggestions? I did complete format all partitions except sd card before install from sd card. I even tried just the Jellytime without google apps and inspire mods. No Luck.
     
    scotty85 likes this.
  16. scotty85

    scotty85 Extreme Android User
    Rank:
    None
    Points:
    1,413
    Posts:
    11,131
    Joined:
    Jul 25, 2010

    Jul 25, 2010
    11,131
    7,411
    1,413
    the problem is that recovery cannot install the boot image while you are s on.its an htcdev quirk.

    there are a couple things you can try:
    1)for other devices, ext 4 has an option called "smart flash" wich has a way of installing the boot image manually. im not sure if it works on inspire/dhd or not. check ext 4 for a setting to enable smartflash,and reflash the rom.

    2)if you want to stay s on,and smart flash doesnt work, then install the boot image manually. this guide is for the rezound,but the basic concept is the same. just make sure to use an ACE specific recovery: http://androidforums.com/rezound-all-things-root/499172-how-manually-flash-roms.html#post3933400

    3)s off. then all youll need to do is flash the rom. no need for special recovery settings or manually installing boot images. use this guide: http://androidforums.com/desire-hd-...-s-off-simunlock-supercid-inspire-4g-dhd.html
     
  17. tmcphersonjr61

    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Jul 21, 2013

    Jul 21, 2013
    13
    6
    16
    Male
    Licensed Practical Nurse
    Hagerstown, Maryland
    Oh happy day. That worked. Using manual install for boot.img and jellytime now installed. Now trying to make sure google apps and inspire mods are installed. Thanks to everyone for all your excellent help. Android Forums rocks and can help even an old geezer like me install custom roms.
     
    scotty85 likes this.
  18. scotty85

    scotty85 Extreme Android User
    Rank:
    None
    Points:
    1,413
    Posts:
    11,131
    Joined:
    Jul 25, 2010

    Jul 25, 2010
    11,131
    7,411
    1,413
    awsome! glad you are sorted :)
     
  19. tmcphersonjr61

    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    13
    Joined:
    Jul 21, 2013

    Jul 21, 2013
    13
    6
    16
    Male
    Licensed Practical Nurse
    Hagerstown, Maryland
    Most things seem to be working now. Not sure if the inspire mods that set GPS are in or not. Have tried to install from zip using 4ext but it reboots back into jellytime when I try to install. Is there a way to install theses some other way. I know someone here will know because you guys rock!!!! Will be in bed shortly since I am up at 4:30 every morning for work. LPN's don't make the big bucks like RN's do. Will look for answers and try to apply tomorrow. Thanks again in advance for any and all help.
     
  20. earlovann

    earlovann Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jun 9, 2014

    Jun 9, 2014
    1
    0
    5
    I cant even get my MSCommand to read the md5sum of the image. can I get some help on this too?
     
  21. scotty85

    scotty85 Extreme Android User
    Rank:
    None
    Points:
    1,413
    Posts:
    11,131
    Joined:
    Jul 25, 2010

    Jul 25, 2010
    11,131
    7,411
    1,413
    Sure,but I'm not sure exactly what help you need. Need more info on what guide you're using,what prollem you're having,etc.

    If you're having issue with adb or fastboot commands,copy and paste your entire cmd window :)
     
  22. tokes

    tokes Newbie
    Rank:
    None
    Points:
    16
    Posts:
    19
    Joined:
    Jun 5, 2012

    Jun 5, 2012
    19
    1
    16
    Okay, all goes well until I get here. What's the cause and how can I fix it?

    C:\acetools>adb shell /tmp/gfree -f
    --secu_flag off set
    --cid set. CID will be changed to: 11111111
    --sim_unlock. SIMLOCK will be removed
    Section header entry size: 40
    Number of section headers: 44
    Total section header table size: 1760
    Section header file offset: 0x00015398 (86936)
    Section index for section name string table: 41
    String table offset: 0x000151df (86495)
    Searching for .modinfo section...
    - Section[16]: .modinfo
    -- offset: 0x000011cc (4556)
    -- size: 0x000000c4 (196)
    Kernel release: 2.6.35.10
    New .modinfo section size: 196
    Attempting to power cycle eMMC... Failed.
    Module returned an unknown code (No such file or directory).
     
  23. scotty85

    scotty85 Extreme Android User
    Rank:
    None
    Points:
    1,413
    Posts:
    11,131
    Joined:
    Jul 25, 2010

    Jul 25, 2010
    11,131
    7,411
    1,413
    Looks like you are not on an exploitable radio.

    Without more info on what you're doing and seeing your entire cmd window,it's almost impossible to say for sure the cause.
     

Share This Page

Loading...