1. Are you ready for the Galaxy S20? Here is everything we know so far!

S-OFF, root, & Fix Everything All-in-One!

Discussion in 'Android Devices' started by remanifest, Mar 4, 2013.

  1. OakIris

    OakIris Member

    Thank you for your response, Brian. I don't have anything especially private on my phone so I am not too concerned about someone stealing my phone and data; I will leave USB debugging on. Sounds as if leaving the bootloader as is won't do any harm, either. I seem to have plenty of room left on my SD card, etc, so don't need to delete anything at this time; I was just curious as to what could be deleted for future reference. Back ups are always a good idea!

    Holly
     


    Brian706 likes this.

    1. Download the Forums for Android™ app!


      Download

       
  2. adamhos1234

    adamhos1234 Android Expert


    Here is a list of safe to remove apps
    http://www.vmroms.com/index.php?topic=213.0
     
    OakIris and Brian706 like this.
  3. OakIris

    OakIris Member

    Thank you very much, Adam!

    Holly
     
    adamhos1234 likes this.
  4. misterdrum

    misterdrum Lurker

    Just had to register to say thanks! Guide/script worked like a dream :D
     
  5. philetus

    philetus Newbie

    I have my Evo V unlocked and rooted.I have Superuser.
    In the S-OFF, root, & Fix Everything All-in-One!, do I still do everything?

    I only flashed the Superuser patch. I didn't flash a rom.
     
  6. spen1995

    spen1995 Well-Known Member

    I got a beef with whoever wrote this and didn't put at the very top in bold red letters that it formats your memory stick, I had photos on there all never get back cause you didn't do your research:mad::mad::mad::mad:
     
  7. Brian706

    Brian706 I like turtles!
    Moderator


    I'm sorry that you lost your photos. :(

    Have you tried an sd recovery software? There are many, here is one example from a quick Google Search: Data Recovery Software, Solutions, Tutorials, Forum - ZAR Data Recovery

    I know you're upset but it's ultimately our own responsibility to do our own research when rooting.

    The OP does suggest reading the official instructions from the developers of the s-off exploit:
    which does mention there is a risk of wiping the sd card.
    I personally didn't lose any data while performing the wire trick and I don't think the OP did either. It has only been the unlucky minority that has mentioned wiping their card and in one extreme case, the card wouldn't function at all anymore.


    I really hope you can get your photos back!! Good luck.
     
    scotty85, adamhos1234 and Kritter888 like this.
  8. joethecopper

    joethecopper Newbie

    OK, I'm stuck. I used the script in the s-off folder and it completed successfully. I then selected bootloader and recovery. The phone rebooted and got stuck in a boot loop. I tried the step in preliminary steps but now it wont do anything. the red light flashes like once every minute. Did I brick it?

    Update:

    Ok, after I pulled the battery, then reinstalled it and hooked up the usb, it wouldn't do anything. I pulled the sc card and got it to boot but its back in the boot loop.

    OK. With the sd card in the phone, it won't do anything. With the sd card out, I can get it to power up, but it gets stuck in the boot loop. Any ideas?

    Sorry for the noobishness of this.
     
  9. OverByter

    OverByter Resident Slide Rule Guru

    Can you get into recovery?
    OB
     
  10. CodemasterRob

    CodemasterRob Lurker

    Hey. This guide is exactly what I need, but I've run into a problem. When I run the RUU.exe, it gets to the point of flashing the ROM and then it tells me the "USB Connection encountered an error". I look at my phone, and it shows:

    RUU

    Hboot version is old

    Update Failed!

    I'm on Hboot 1.58 and I have no ROM installed, At the top of the screen, after doing fastboot oem lock, it says "RELOCKED" "Security Warning". I don't know if this has anything to do with it, or if it's just the RUU you've posted. I'm downloading another RUU to use and I'll see if that works.

    Update: It stops as soon as it starts saying "Updating hboot". It gives me "ERROR [155]". Any idea what I should do? I've relocked the bootloader, flashed SetMainVersLow in TWRP, and then I ran this.
     
  11. OverByter

    OverByter Resident Slide Rule Guru

    You will need to downgrade your hboot before running the RUU, even with s-off I've occasionally run into the same problem, the RUU has only been released with the 1.57 hboot and sometimes fails when trying to overwrite the 1.58 version.
    OB
     
  12. Brian706

    Brian706 I like turtles!
    Moderator

    If you are S-Off already, just run the RUU while the phone is in fastboot USB mode. Should solve those weird errors.

    Of not S-off, you simply can't run the RUU.
     
  13. CodemasterRob

    CodemasterRob Lurker

    Alright... I thought you had to have S-OFF to downgrade Hboot?
    I can't get S-OFF without the stock ROM according to this, and no other ROM will boot. That makes it seem like this is a lost case. I do however have the wire and Jbear ready to go on a moment's notice. I don't know why I didn't do that first.
     
  14. more2read

    more2read Well-Known Member

    I need a little help......
    Way back, I did the Fix Everything successfully - phone worked well.

    I recently got an OTA update, and it failed to update - message in TWRP about being aborted. So I manually installed from TWRP.
    Phone is still saying it wants to update.

    Info from phone....
    Software Number 1.14.652.0 710RD
    BaseBand 0.97.10.0808
    Build Number 1.14.652.0 CL372137 release-keys

    Is there some special procedure to follow to allow OTA updates?
     
  15. adamhos1234

    adamhos1234 Android Expert


    You need to be completely stock for ota.
    So basically you would need to ruu than accept all ota updates then if you wanted to gain root again or flash a rom, you would need to reflash your recovery and ROM of choice.

    Since youre s off you don't need to relock and unlock again. Just run the ruu as a pg86img.zip. everything will return to stock and you will keep your soff status
     
  16. adamhos1234

    adamhos1234 Android Expert


    Try flashing harmonia.
    It'll work for soff
     
  17. more2read

    more2read Well-Known Member

    I'm a little lost .... Is "ruu" an App I need to install through TWRP?
     
  18. adamhos1234

    adamhos1234 Android Expert

    Don't forget to backup your data, this will wipe your phone

    Actually the ruu is a .exe that you would normally run through windows.

    But since you're s off you can flash it as a pg86img.zip

    To do that you can first download the file from here
    http://androidforums.com/cdma-evo-3d-all-things-root/769527-rom-update-utility-ruu-all-downloads.html

    Put that file on the root of your SD card
    Make sure it is named pg86img.zip

    Boot into bootloader
    Accept the update and your phone should do the rest

    When its done, you should have the stock ROM and the stock recovery and you can now completely update your phone.

    Don't forget to either rename or remove that pg86img.zip after your first reboot

    When you're done updating (which I think there are 2 or 3 system updates) you can flash a custom recovery again and reroot.
     
  19. CodemasterRob

    CodemasterRob Lurker

    Can someone confirm this works on hboot 1.58 on a stock odex ROM?
     
  20. Brian706

    Brian706 I like turtles!
    Moderator

    It's been done many times good sir.
     
  21. dburna74

    dburna74 Lurker

    Thanks for the info Brian,

    If i run into any issues getting S-OFF and downgrading ill def let you know.
     
  22. malckdaddy

    malckdaddy Lurker

    Thank you for this guide. It is perfect. I wish I could find a way to redirect all internet traffic for other Evo 3D s-off, root, etc guides straight to this thread. I have a feeling it would save a whole lot of people a whole lot of troubles. Once again, thank ye, sir. :)
     
    mjhealy1978 likes this.
  23. KinoTheMystic

    KinoTheMystic Lurker

    how do i know if i have a recovery on my phone? I know it is rooted. This phone was given to me by my dad and i am on a stock ROM.
     
  24. Brian706

    Brian706 I like turtles!
    Moderator

    Simply put the phone into recovery mode. Power the phone down. Pull the battery and replace it.then hold the volume down button. Press the power button but continue holding the volume down button.

    Once the bootlolader screen appears, press the volume down button repeatedly until you highlight the recovery option. Once highlighted, press the power button to select it.

    If you have the stock recovery, you will see a triangle with an exclaimation point and/or an android with a door open showing the insides. Been a long time since I've seen it.


    If you have a custom recovery it will say (hopefully) 4ext recovery or twrp recovery. Possibly clockworkmod recovery. There will be many options to select, whereas there will be nothing to select in the stock recovery.
     
  25. KinoTheMystic

    KinoTheMystic Lurker

    thanks! It is indeed twrp, yet an older version.
     
Loading...

Share This Page

Loading...