1. Check out our companion app, Forums for Android! Download from Google Play

General S2 bug

Discussion in 'Android Devices' started by Dtmversion1, Mar 7, 2012.

  1. Dtmversion1

    Dtmversion1 New Member
    Thread Starter
    5

    Mar 7, 2012
    4
    0
    5
    Im having a few buggy issues with my s2 (NONE ROOTED) when the phone is not plugged into to anything quite often it beeps to say the MTP is initialized and says usb connected

    Also if i turn phone off and on again it thinks the battery IS flat and wont start up unitl its plugged into the charger then it kicks back into life again even if battery is 50% 100% etc

    Has anybody come across this before and/or is there a fix for this?

    thanks guys!
     

    Advertisement

  2. Russell Ng

    Russell Ng Well-Known Member
    143

    Sep 29, 2011
    1,384
    166
    143
    Male
    Engineer
    Kuala Lumpur
    Sounds like a problem with your USB port. Try cleaning it with a toothbrush gently.

    Cheers
     
  3. Dtmversion1

    Dtmversion1 New Member
    Thread Starter
    5

    Mar 7, 2012
    4
    0
    5
    Ill give it a go, thanks for advice :)
     
  4. Sword Fish

    Sword Fish Well-Known Member
    43

    Oct 19, 2011
    329
    40
    43
    Pilot
    Calgary, AB
  5. Dtmversion1

    Dtmversion1 New Member
    Thread Starter
    5

    Mar 7, 2012
    4
    0
    5
    Still no joy, rang orange who did the whole 'take sim card and battery out then put back in' thing and still doing it. also blew the usb port with an air hose to clean out the mini usb port and stopped charging via usb computer to see if that helped but still going nuts thinking its plugged in.
     
  6. Russell Ng

    Russell Ng Well-Known Member
    143

    Sep 29, 2011
    1,384
    166
    143
    Male
    Engineer
    Kuala Lumpur
    Have you tried a factory reset? Try that first, and if doesn't work....
    Then send it back to the store. Some have mentioned that changing the USB solve it for them, but if you can't do it on your own, get the retailer/service guy to do it.

    Its probably a defective USB port.

    Cheers
     
  7. Dtmversion1

    Dtmversion1 New Member
    Thread Starter
    5

    Mar 7, 2012
    4
    0
    5
    After reading the xda thread i bent the usb port down inside the phone with a thin screw driver a little bit incase it was bent and touch wood everything seems ok so far and battery has stopped draining for the moment. if it happens again ill get it changed under warranty.
     

Share This Page

Loading...