1. Download our Official Android App: Forums for Android!

Tips S3, Jelly Bean, Bluetooth, and Google Now

Discussion in 'Android Devices' started by Pappy35, Dec 9, 2012.

  1. Pappy35

    Pappy35 Well-Known Member
    Thread Starter
    Rank:
     #407
    Points:
    58
    Posts:
    229
    Joined:
    Sep 27, 2012

    Sep 27, 2012
    229
    15
    58
    Male
    Aerospace Engineer
    Memphis, TN
    I noticed a problem using Google Now (GN) after the Jelly Bean update last week: GN's voice recognition wouldn't initialize.

    At the time it was driving me nuts cause it seemed to work sometimes and other times not. It made no difference whether the head unit was set to BT input, radio, or completely off. The phone only exhibited this when it was paired and BT calls worked perfectly every time.

    I spent a little time, while parked mind you, to work it out. It's clearly a bug in Samsung's implementation as I paired my Nexus 7 and it worked perfectly every time.

    If you're having this issue, the workaround seems to be:

    Launch GN
    Press the mic button.
    Hit the Back softkey.
    Then hit the mic again.

    Works every time now.
     

    Advertisement

  2. Pappy35

    Pappy35 Well-Known Member
    Thread Starter
    Rank:
     #407
    Points:
    58
    Posts:
    229
    Joined:
    Sep 27, 2012

    Sep 27, 2012
    229
    15
    58
    Male
    Aerospace Engineer
    Memphis, TN
    I further found that voice typing from the keyboard Mic icon doesn't work at all when paired and there's no work around that I can find. Anyone know if there's a way to grap the Android applications that handle Voice-to-Text (VtT) and install them over those supplied by Samsung? My phone is rooted.

    VtT not working via BT is a real deal-breaker for me on a phone that I'm otherwise very happy with.
     
  3. davidmanvell

    davidmanvell Android Enthusiast
    Rank:
    None
    Points:
    78
    Posts:
    677
    Joined:
    Jul 12, 2012

    Jul 12, 2012
    677
    71
    78
    Male
    Power Quality Specialist for a medical imaging com
    Virginia Beach, VA USA
    Is it trying to use the microphone in your stereo rather than the one in your phone?
     
  4. Pappy35

    Pappy35 Well-Known Member
    Thread Starter
    Rank:
     #407
    Points:
    58
    Posts:
    229
    Joined:
    Sep 27, 2012

    Sep 27, 2012
    229
    15
    58
    Male
    Aerospace Engineer
    Memphis, TN
    I have no idea though I'm guessing it's using the phone mic. When I do my workaround with the radio playing the graphic shows that it's picking-up the music.

    Just paired it to my laptop and this problem doesn't show up. Perhaps there's a difference when pairing to an audio device?
     
  5. Pappy35

    Pappy35 Well-Known Member
    Thread Starter
    Rank:
     #407
    Points:
    58
    Posts:
    229
    Joined:
    Sep 27, 2012

    Sep 27, 2012
    229
    15
    58
    Male
    Aerospace Engineer
    Memphis, TN
    Well, I narrowed it down to this which seems to be the root of the problem:

    BT has two settings: 1) Call Audio, and 2) Media Audio.

    The VtT option is not available when Media Audio is selected. Apparently this defeats the Voice to Text initialization. Seems completely silly to me that they would disable that function when paired as a media device (or with both selected). My Nexus 7 doesn't have a phone but it has the Call Audio option too and works with both checked.

    Anyone have any idea how this might be unbroken (I won't say fixed cause it should work regardless).
     
  6. mistawalker

    mistawalker Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jun 26, 2012

    Jun 26, 2012
    2
    0
    5
    I have a solution that we designed to fix this. Email me at [redacted] and I'll explain to you what to install to fix this. please share with anyone else with this problem.
     
  7. El Presidente

    El Presidente Beware The Milky Pirate!
    Moderator
    Rank:
     #5
    Points:
    3,118
    Posts:
    31,502
    Joined:
    Jan 3, 2011

    Jan 3, 2011
    31,502
    22,914
    3,118
    Scotland
    Hi mistawalker, I removed your email address for security reasons. If you have a solution, can you post it here? I'm sure people who are experiencing the issue would be grateful.
     
    D-U-R-X likes this.

Share This Page

Loading...