1. Download our Official Android App: Forums for Android!

Support S5 will only connect via USB to PC and power cable

Discussion in 'Android Help' started by Elapid, May 5, 2016.

  1. Elapid

    Elapid Lurker
    Thread Starter
    May 5, 2016

    May 5, 2016
    I got a Stealth Cam G42NG trail camera as a gift this past Christmas for wildlife watching. The thing is built like a tank, and it's very reliable. Having to remove its SD card and put it into a laptop every time I want to check it, though, is a real pain. I purchased a micro-to-mini M/M USB cable so I could just connect my Galaxy S5 directly to the trail cam. For a few months, this worked really well. The camera is designed with a USB mode, which would kick on as soon as I plugged the phone into it. The phone would scan the camera, and treat it like an external storage device. I could grab photos and videos, and plunk them right into my phone's microSD card via that cable, no problem.

    After a period of flawless functionality, some... difficulties... started. I would connect the two devices, and the trail camera would light up, "USB mode." On the phone's end, though, nothing would happen. After several seconds of no response from the phone, the trail camera would sort of 'give up', and switch itself off, again. At first, disconnecting and reconnecting the USB cable a time or two would work, though the connection would, on occasion, be lost mid file transfer if the cable was moved in any way. It's finally gotten to the point where a connection can't be established at all. My phone acts like nothing has been plugged into it, and the camera forlornly glows, "USB mode," for about 20 seconds before giving up and going dark, again. I tried using a different cable adapter: Nothing. I brought the camera home, wondering if all its time outside in the weather had somehow damaged its USB port. It connected to my PC just fine, though. Likewise, the S5 connects to my PC just fine, and recognizes immediately when it's been plugged into its wall charger for the night.

    Has anyone had a similar problem, and is there a way to fix it?


Share This Page