1. Download our Official Android App: Forums for Android!

General S7 Edge: Play Store won't update over Wifi

Discussion in 'Android Devices' started by bhl62, Mar 10, 2016.

  1. bhl62

    bhl62 Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    28
    Posts:
    83
    Joined:
    Nov 19, 2010

    Nov 19, 2010
    83
    15
    28
    OK, I thought I was nuts when I activated my S7 Edge yesterday and couldn't update anything on the Play store over Wifi, till I saw another report on the VZW forums (https://community.verizonwireless.com/thread/905974). I posted this update there as well but decided to start a discussion here where we have more experts.

    Here are all the symptoms I've seen:
    - Play store will not update or install anything while on Wifi. I have a TPLink AC3200 router and the Play store won't update on either 2.4GHz or 5GHz bands (WPA2/PSK). All other android devices (including two Galaxy S5's) continue to work fine. LAN access is fine including streaming live HD TV
    - All play store updates work over 4G
    - Oddly, if I connect to an open xfinitywifi network and login with my Comcast credentials, everything works fine. Ditto at the open network at my office.
    - Tried setting the guest network on my router to Open, turning off SPI firewall and DDoS protection, didn't help
    - The VZ Cloud app reports that it cannot detect an internet connection while on Wifi (works on the open Wifi networks)
    - I first thought this had to do with attempting to transfer data from my old S5 so also did a factory reset. Didn't help.
    - All other apps, browsers, etc access the internet fine.

    Anybody got any thoughts on where to look or if VZW has a config issue on the play service?

    EDIT: there are no problems installing apps from Amazon or Samsung, just the play store.
     

    Advertisement

  2. Todd Kageals

    Todd Kageals Newbie
    Rank:
    None
    Points:
    26
    Posts:
    13
    Joined:
    Mar 10, 2016

    Mar 10, 2016
    13
    4
    26
    Male
    I have the same issue. I tried multiple factory resets and even completely deleting my Google account and starting over with a new account (major pain) and I still could not get the play store to work on wifi at home. Works over 4g but not wifi. All other apps seem to work over wifi (actually, the youtube app would not work either). Wifi speed test worked and was super fast on the phone but no luck with the play store. Sure wish I had not reset my phone now!
     
  3. svim

    svim Android Expert
    Rank:
     #42
    Points:
    608
    Posts:
    3,989
    Joined:
    Dec 19, 2013

    Dec 19, 2013
    3,989
    3,021
    608
    Illinois
    Try this as a test. Instead of using the Google Play app use your phone's web browser to access:
    https://play.google.com/store
    If the browser window does fill up properly with typical Play Store stuff, than never mind.
    But if the site doesn't show up properly maybe there's some weird conflict going on between Verizon's default DNS and some background configuration related to something on S7 phones. In another thread yankies90 suggested changing the DNS as a solution -- if you install a DNS changing app like 'DNS Changer' it has a large number of alternative public DNS addresses you can select so your phone won't be using Verizon's default DNS.
    DNS Changer
    https://play.google.com/store/apps/details?id=net.emrekoc.dnschanger

    Related thread topic:
    http://androidforums.com/threads/play-store-wont-work-on-wifi.1008555/#post-7243757

    Changing DNS can have benefits:
    http://www.howtogeek.com/167239/7-reasons-to-use-a-third-party-dns-service/
     
    KOLIO likes this.
  4. wxman2003

    wxman2003 Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    411
    Joined:
    Apr 2, 2010

    Apr 2, 2010
    411
    43
    43
    Found this on Verizon forums. Does this work? The person who posted it, said it worked.

    Settings -> Application manager -> Google Play Store -> Permissions -> turn all on -> Force Stop.
     
  5. bhl62

    bhl62 Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    28
    Posts:
    83
    Joined:
    Nov 19, 2010

    Nov 19, 2010
    83
    15
    28
    Here are a couple of my posts from the VZW forum:

    Yesterday:
    This is hilarious! Just for giggles I connected my phone to my VPN while at home everything started working. Disconnect, it stops. I also notice that the icons in the main play store page load very slowly when the problem is seen, and fast when it works.

    So, does this mean my network is too fast and it works only when slowed down (802.11ac router, 160+/12 Mbps Internet connection)? Sheesh!

    Today:
    I tried enabling permissions (essentially turning on Contacts and Locations which are off by default) but that did not help on two phones. I used the VPN workaround to update both phones.

    Incidentally, I also found that Google Maps wasn't downloading any maps either without the VPN and some others have reported issues with YouTube, so we are probably looking at a shared network service that all the Google Apps (and VZ Cloud) use. Another forum poster reported that changing the DNS also helps which could explain why my VPN workaround works.

    Looking at the empirical data, DNS certainly looks like a probability. Using my VPN probably bypasses the internal DNS and uses the DNS from the router/Comcast. Looked at DNSet and noticed that it also works by setting up a VPN, so that strengthens that observation.

    EDIT: This however doesn't answer the question of why it works on public wifi networks, so is there a combination of DNS + WPA supplicant settings at play?
     
  6. KWCumbie

    KWCumbie Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Mar 11, 2016

    Mar 11, 2016
    1
    0
    5
    Male
    DNS tool did not work. Upgraded router firmware, new iPv6 options appeared, phone took off. Not advanced enough to know more about why.
     
  7. Todd Kageals

    Todd Kageals Newbie
    Rank:
    None
    Points:
    26
    Posts:
    13
    Joined:
    Mar 10, 2016

    Mar 10, 2016
    13
    4
    26
    Male
    I had the same issues and observation....although I have no idea what a VPN even is.....I solved my issue by turning on "guest network" on my router. If I connect the phone to the guest network, play store, youtube, etc. all work very quickly. If I connect it to my "secured" network on my router, none of it works or at least it works so slowly as to not work at all!
     
  8. bhl62

    bhl62 Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    28
    Posts:
    83
    Joined:
    Nov 19, 2010

    Nov 19, 2010
    83
    15
    28

Samsung Galaxy S7 Edge

The Samsung Galaxy S7 Edge launched in 2016 and was one of two of Samsung's flagship devices. The S7 Edge features a 5.5-inch display with a resolution of 2560 x 1440, 4GB of RAM, 323GB of storage, and 12MP main camera sensor.

Share This Page

Loading...