1. Download our Official Android App: Forums for Android!

Samsung Galaxy GT-I5800

Discussion in 'Introductions' started by sparkler10, Jun 9, 2011.

  1. sparkler10

    sparkler10 Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    1
    Joined:
    Jun 9, 2011

    Jun 9, 2011
    1
    0
    25
    Hi, I've had this phone for a few months now with no problems. All of a sudden, every other day or so it has started to play up. The screen flashes on and off (slowly) and then the phone just switches itself off. To get it working again, I have to remove the battery and then it can be switched on again, only for the problem to repeat. As I say, it is only every other day or so that it does this. Has anyone else had experience of this or do you know if it is likely to be a hardware fault or a software fault? Thanks
     

    Advertisement

  2. El Presidente

    El Presidente Beware The Milky Pirate!
    Moderator
    Rank:
     #4
    Points:
    3,118
    Posts:
    32,120
    Joined:
    Jan 3, 2011

    Jan 3, 2011
    32,120
    24,094
    3,118
    Scotland
    Hello, welcome to the forums.

    I can't say for sure, but it sounds like a hardware problem. The guys in the Galaxy Apollo forum might be able to help.
     
  3. scary alien

    scary alien not really so scary
    Moderator
    Rank:
     #8
    Points:
    2,138
    Posts:
    22,297
    Joined:
    Mar 5, 2010

    Mar 5, 2010
    22,297
    23,684
    2,138
    Male
    space alien ;)
    Indy
    Welcome to AndroidForums, sparkler10!

    Sorry to hear about your phone problems...it does sound like a hardware problem to me (maybe a loose battery?--just a wild guess there...but does the battery fit snug in its compartments?).

    Hopefully someone in the sub-forum that El Presidente provided a link to has heard of this or can suggest an solution.

    Good luck!
     

Share This Page

Loading...