1. Check out our companion app, Forums for Android! Download from Google Play

Samsung Galaxy S Plus can't automatically connect to wifi?

Discussion in 'Android Apps & Games' started by peter12345, Apr 30, 2012.

  1. peter12345

    peter12345 Member
    Thread Starter
    25

    Apr 19, 2012
    8
    0
    25
    Hi i have a new samsung galaxy s plus and i can connect to wifi without problems but when i leave my home-wifi and go to another place (my work) then it can't automatically connec't to the new wifi eventhough i have wifi sleep policies set to "never". To turn wifi on I have to manually turn wifi off and on or manually start an application such as "wifi manager" which i downloaded from google play to solve the problem but it doesn't work all the time.

    Why doesn't the phone work right. Should I deliver the phone back to the seller and complain about it?

    Or do some of you know another app which can automatically search for wifi and connect?. WiFi Manager by "Kostya Vasilyev" only works sometime but usually it doesn't work :(.
     

    Advertisement

  2. Crashdamage

    Crashdamage Well-Known Member
    643

    Feb 25, 2011
    4,451
    2,745
    643
    Mostly retired
    Kansas City, Mo.
    Likely there is nothing wrong with the phone. Try putting the phone back to it's original configuration. Uninstall WiFi Manager and disable or uninstall any other 3rd-party WiFi apps or widgets. If it still won't connect properly post back here.
     
  3. chanchan05

    chanchan05 The Doctor
    1,108

    Jun 30, 2011
    14,748
    4,510
    1,108
    Male
    On a Galaxy S and Galaxy SL, it automatically connects to WiFi as long as the WiFi has been "remembered" by the phone. Even if the phone comes in range of WiFi hotspots, if these aren't remembered, then the phone won't connect automatically.
     
  4. Unforgiven

    Unforgiven -.. --- - / -.. .- ... ....
    Moderator
    4,238

    Jun 23, 2010
    33,219
    32,562
    4,238
    Male
    Douglas, MA
    Is your phone a Samsung Galaxy Ace Plus?
     
  5. peter12345

    peter12345 Member
    Thread Starter
    25

    Apr 19, 2012
    8
    0
    25
    Hi the phone is about 1 month old and it didn't work from the start. Then i installed wifi manager but the problem consisted. Btw i have seen many other threads about this problem without any solution soo perhaps it's just the way it is hmm. But as you suggest i will try desinstall and see how it works. The phone is a Samsung I9001 Galaxy S Plus phone.
     
  6. peter12345

    peter12345 Member
    Thread Starter
    25

    Apr 19, 2012
    8
    0
    25
  7. Stevex998

    Stevex998 Member
    35

    I have a SGS+. Once you have carried out the initial registration of phone to the modem you want to connect up to, the phone should connect automatically from then on. I have done this with my home modem in the UK and the one I use when working abroad.
    Most of the time though I use my Widgetsoid WiFi widget to deselect wifi when I go out so as to save battery juice; when I get back within my modem range I turn wifi back on via the widget, connects every time.
     
  8. afish79

    afish79 New Member
    5

    May 2, 2012
    1
    0
    5
    my phone is a Samsung Galaxy Ace Plus and i can not connect with wifi.

    all time it make turning on and turning off.

    any help ?
     
  9. Dieselbud

    Dieselbud Well-Known Member
    43

    Mar 1, 2011
    195
    33
    43
    Female
    Alberta, Canada
    Mine started doing this too. I have had this phone for over a year and never had to manage my wifi. As soon as I got within range of my home wifi it connected. Now I have to manually connect by turning it off and then on again.

    If I forget to do this, it eats up my 3g data plan. And I cannot find anything in my settings to make it connect automatically unless I am missing something.

    It has been happening for about a week and I am not sure what I did in that time to have changed it. I do not have any wifi management apps as far as I know. Not that I downloaded on purpose.

    I am running gingerbread for about a month and this has only been happening for about a week.
     
  10. windstrings

    windstrings Well-Known Member
    38

    Nov 14, 2009
    209
    10
    38
    It appears to be a software quirk. Something about wifi need to be on but "not connected".. so if your within a remembered signal, tell it to "forget" for now.
    Once you get it working you no longer have an issue and can use it like normal.
    Seems the software "or firmware" needs jarring.

    Rather than double post, I addressed a fix I figured out here...

    http://androidforums.com/nexus-s-su...ot-working-but-usb-tethering.html#post4791694

    Post #3
     
  11. samarthpatel91

    samarthpatel91 New Member
    5

    Oct 4, 2012
    1
    0
    5
    i khow this problem. Thats the bug in the new firmware. But there is a solution. In your wifi router there is lan setting option where ull find Lease Time. Set it to two weeks. Lease was set to "forever" actually, I changed it to one day, rebooted both and now it seems to work fine, I've tried downloading bigger files and playing some games online, it didn't drop at all! I twill not disconnect again.

    Thanks for your answers, hopefully it'll stay like this.
     

Share This Page

Loading...