Help (samsung galaxy s plus) cwm-based recovery v5.5.0.4 appears on each boot



I was trying to upgrade my samsung galaxy s plus (GT-19001) device to Android 4.0.4.

i just installed CWM-based recovery v5.5.0.4 on my device by rebooting and selecting (install zip from sd card).

------using mentioned combination of keys -------

Then i placed the files in my phone's internal SD Card.

files are mentioned below:


then install 1 by choosing from internal SD card and then 2nd file.

my device prompted completion success messages but it took very short time.


now what happened after doing this. my device is displaying same booting screen of CWM-based recovery v5.5.0.4 on each re-boot.

i treid many times by unplug the battrey but unfortunately unsuccessfull.

After that i did Wipe data/factory reset and wipe cache partition.


I tried it through window's based utility Odin v4.43 but it could detect my device usb driver even after success of USB driver installation.

it didn't display Added in message box.

now what should i do ?

i already installed samsung Kies but still undetected.

I tried some old version of Odin 3v1.8 , it detected the port and displayed Added but failed to write ROM on my device.


My desktop machine's OS : windows 8 64 bit enterprise edition.

I am unable to install new of revert back my OS.
I need your guidence to resolve the issue. Thanks in advance.
Please ask for further details if required.