1. Download our Official Android App: Forums for Android!

Support Samsung Galaxy S2 - Default Dialer is dialing a +91 prefix for all numbers!

Discussion in 'Android Devices' started by rohandroid, Jul 21, 2011.

  1. rohandroid

    rohandroid Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Jul 21, 2011

    Jul 21, 2011
    3
    0
    5
    Hello,

    On my Samsung Galaxy S2 (Android 2.3.3),my default dialer is putting a country code prefix +91 whenever I dial any number. The problem is when I dial 1800 **** **** numbers, it does not connect. The call ends abruptly.

    Tried to check every setting available but couldn't find one which removes the country code prefix while dialing.
    Similarly, also tried a couple apps but it didn't work.
    Guess this is a problem with Samsung TouchWiz?? Can anybody please help??

    Thanks!!
     

    Advertisement

  2. Ryistech

    Ryistech Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    103
    Joined:
    Jul 19, 2011

    Jul 19, 2011
    103
    1
    36
    I guess I would do a restore if nothing else is working.
     
  3. rohandroid

    rohandroid Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Jul 21, 2011

    Jul 21, 2011
    3
    0
    5
    Thanks Ryistech!:)....Yes, I have kept that option as a last resort:)...It's really bugging me. I love my Galaxy S2 and Android..just this one part I want sorted out. Cheers for replying.
     
  4. gwlaw99

    gwlaw99 Android Expert
    Rank:
    None
    Points:
    128
    Posts:
    1,030
    Joined:
    Nov 1, 2009

    Nov 1, 2009
    1,030
    53
    128
    You could try downloading an alternative dialer from the market.
     
  5. Slug

    Slug Check six!
    Moderator
    Rank:
    None
    Points:
    2,043
    Posts:
    20,549
    Joined:
    Aug 1, 2009

    Aug 1, 2009
    20,549
    17,001
    2,043
    Male
    Mobile phone retail
    Inverness, UK
    Have you asked in the Galaxy S2 forum? I haven't seen any similar reports but that doesn't exclude others having the same issue and finding a solution.
     
  6. rohandroid

    rohandroid Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Jul 21, 2011

    Jul 21, 2011
    3
    0
    5
    Hi Slug and gwlaw99,

    I did try a couple alternative dialers, Smart Caller and Smart Caller Lite. But didn't work. Galaxy S2 kept dialing the numbers with +91 Country Code Prefix.

    Then I thought that some app might have mucked up some setting or something. So I uninstalled Skype and Viber. That did it! The country code prefix was gone while dialing! However Galaxy S2 still couldn't dial the 1800 number from India. It works on all other handsets just not this one.:(

    Also, I cannot directly dial the Landline number that I get a call from, coz there is that prefix and area code in the Call Logs and I have to edit the number every time I call :(

    Yes, I should have asked in Android Galaxy S2 forums. My Bad. Can I move the thread there now?
    Thanks for your help!
     

Share This Page

Loading...