1. Download our Official Android App: Forums for Android!

Support Samsung Galaxy S2 not connecting via USB to Windows PC or Windows laptop

Discussion in 'Android Devices' started by CarlosRexx, Jan 5, 2013.

  1. CarlosRexx

    CarlosRexx Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    9
    Joined:
    Dec 22, 2012

    Dec 22, 2012
    9
    0
    25
    Male
    Bar manager
    London, England
    Not quite sure why? I have the correct drivers and the computer will charge the phone but Kies wont recognise is. :|
     

    Advertisement

  2. SCPadgeebar

    SCPadgeebar Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    363
    Joined:
    Sep 6, 2012

    Sep 6, 2012
    363
    74
    53
    Male
    If you want to access internal storage, go to Settings > More Settings > USB Utilities > Connect Storage to PC and then plug your USB Cable.
     
  3. Ijaz Ahmed

    Ijaz Ahmed Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    259
    Joined:
    Dec 1, 2010

    Dec 1, 2010
    259
    38
    43
    This happens 50% of the time with me as well, I am on Windows 7.

    Leave your phone connected to PC

    Goto Device Manager and look for yellow marks in the "Universal Serial Bus Controllers"

    Right click on the yellow items and select "Un-install". In my case, I get two items with yellow mark.

    After un-installaing, click the button "Scan for hardware changes". Windows will find you phone again and install drivers.

    It should be working and no yellow marks should be in the Device Manager.
     
  4. SCPadgeebar

    SCPadgeebar Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    363
    Joined:
    Sep 6, 2012

    Sep 6, 2012
    363
    74
    53
    Male
  5. Ijaz Ahmed

    Ijaz Ahmed Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    259
    Joined:
    Dec 1, 2010

    Dec 1, 2010
    259
    38
    43
    ^ Is it 32-Bit or 64-bit driver ?
     
  6. SCPadgeebar

    SCPadgeebar Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    363
    Joined:
    Sep 6, 2012

    Sep 6, 2012
    363
    74
    53
    Male
    Worked on both(My 32-bit Windows 7 Home Premium and 2 64-bit Windows 7 Ultimate).
     
  7. CarlosRexx

    CarlosRexx Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    9
    Joined:
    Dec 22, 2012

    Dec 22, 2012
    9
    0
    25
    Male
    Bar manager
    London, England
    ive sorted it now, had to reinstall windows so it's fixed everything.
     
  8. Throwaway041

    Throwaway041 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    May 10, 2013

    May 10, 2013
    1
    0
    5
    I just made an account to say thank you SCPadgeebar. I've installed a dozen different usb drivers and reformatted my computer and everything. This finally fixed my issue with my Samsung Galaxy SII.
     
  9. astav88

    astav88 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jun 3, 2013

    Jun 3, 2013
    1
    0
    5
    nothing works not even the driver mentioned above, it says successfully installed and needs a restart, but when i restart i have the same problem.
     
  10. MihaiG

    MihaiG Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Sep 22, 2012

    Sep 22, 2012
    2
    0
    5
    Male
    Certified IT Consultant
    Vancouver, Canada
    I encountered initially, lots of problems trying to connect S2 to PC using Kies. Although Kies was installed and had drivers for S2, when plugging the phone in the USB port, Windows would start installing drivers.
    Also, after Windows drivers were installed, I was asked everytime I plugged the phone to select the Winows application to work with the device. At the same time Kies was trying to connect to the device as well.
    If you select a Windows app to work with the device, Kies will not connect anymore.
    To correct the connection problem, select the option "Take no action" and mark the check-box "Always execute this action".
    On Win 7, the pop-up menu does not have the option for "Take no action", so you have to click on hyperlink for additional options and you will see a list of all devices including GT-I9100. There is a droplist for the action to take for each device. Select in the droplist for GT-I9100 the option "Take no action".
    Since I did this, my S2 has been connecting without problems to Kies.
    I was able to backup my phone and upgrade the firmaware to JellyBean (4.1.2).
     
  11. Nipin

    Nipin Lurker
    Rank:
    None
    Points:
    6
    Posts:
    4
    Joined:
    Feb 3, 2015

    Feb 3, 2015
    4
    2
    6
    Hey Guys. I got a Samsung S2 with O/S Gingerbread in it...I wanted to install CyanogenMod....BUT, When ever I try to connect it to my PC[XP] or Laptop[Win7] all I get is a msg " USB Device Not Recoginzed"....what I have already tried :
    1. Uninstalling and Re-Installing the driver
    2. Downloaded Samsung USB driver
    3. Changed USB Cables [3 cable in total....NOTE: I can connect my Motorola Xoom Tablet with these cable and it works with the Xoom]
    4. Installed the latest version of Samsung Kies3 hoping that will install some driver. BUT, :(
    5. Yes I have ENABLED the USB Debugging option on the phone also.

    Can someone please tell me what went wrong??

    Thank you in advance.
     
  12. lunatic59

    lunatic59 Moderati ergo sum
    Moderator
    Rank:
     #3
    Points:
    4,138
    Posts:
    33,098
    Joined:
    Jun 12, 2010

    Jun 12, 2010
    33,098
    27,850
    4,138
    Male
    IT
    Pennsylvania
    Just to be clear, your phone is the i9100?

    When you plug it into either computer does it fail to install the driver (configuration error) or does it simply not recognize that anything has been plugged in (hardware problem)? If the former, have you enabled USB debugging? If the latter, you might have a faulty USB port on your phone.
     
    ironass likes this.
  13. ironass

    ironass Android Expert
    Rank:
     #19
    Points:
    1,343
    Posts:
    11,395
    Joined:
    Aug 17, 2010

    Aug 17, 2010
    11,395
    5,594
    1,343
    Male
    Keeping one step ahead of the Tax man
    Cotswolds, England
  14. lunatic59

    lunatic59 Moderati ergo sum
    Moderator
    Rank:
     #3
    Points:
    4,138
    Posts:
    33,098
    Joined:
    Jun 12, 2010

    Jun 12, 2010
    33,098
    27,850
    4,138
    Male
    IT
    Pennsylvania
    Thanks IA ;) I just wanted to make sure it wasn't a US branded model and was truly the international variant.

    @Nipin , at this point you probably have a couple of conflicting drivers installed. I'd recommend deleting ALL android drivers (and rebooting your PC/Laptop) before installing Kies.
     
    ironass likes this.
  15. ironass

    ironass Android Expert
    Rank:
     #19
    Points:
    1,343
    Posts:
    11,395
    Joined:
    Aug 17, 2010

    Aug 17, 2010
    11,395
    5,594
    1,343
    Male
    Keeping one step ahead of the Tax man
    Cotswolds, England
    Good point lunatic59. I've been caught out on that, many times! :rolleyes:
     
    lunatic59 likes this.
  16. lunatic59

    lunatic59 Moderati ergo sum
    Moderator
    Rank:
     #3
    Points:
    4,138
    Posts:
    33,098
    Joined:
    Jun 12, 2010

    Jun 12, 2010
    33,098
    27,850
    4,138
    Male
    IT
    Pennsylvania
    Yeah, because the AT&T variant won't work with Kies ... you have to use Kies mini :goofydroid: (can that still be found?)
     
    ironass likes this.
  17. Nipin

    Nipin Lurker
    Rank:
    None
    Points:
    6
    Posts:
    4
    Joined:
    Feb 3, 2015

    Feb 3, 2015
    4
    2
    6
    sry forgot to mention the model its DGH-T989 [T-Mobile]

    As per your 2 options its the former the pc detects the device its connected.....and give the message " USB Device Not Recoginzed".

    And yes the setting "USB Debugging" has been enabled.

    I am going to delete kies3 and install the 2...and let you know
     
  18. ironass

    ironass Android Expert
    Rank:
     #19
    Points:
    1,343
    Posts:
    11,395
    Joined:
    Aug 17, 2010

    Aug 17, 2010
    11,395
    5,594
    1,343
    Male
    Keeping one step ahead of the Tax man
    Cotswolds, England
    Good job you checked lunatic59!

    It's neither the International or the AT&T variant but the Galaxy SII, "Hercules", model for T-Mobile, U.S.A.

    My post #13 should still apply for advanced problem solving on connection to Kies.
     
    lunatic59 likes this.
  19. lunatic59

    lunatic59 Moderati ergo sum
    Moderator
    Rank:
     #3
    Points:
    4,138
    Posts:
    33,098
    Joined:
    Jun 12, 2010

    Jun 12, 2010
    33,098
    27,850
    4,138
    Male
    IT
    Pennsylvania
    I kind of suspected. ;) Been around this block more than once. :D @Nipin Do you mean SGH-T989D? (Canadian?) or simply SGH-T989? Either way @ironass post should help you get closer. I think the difference might be that the Canadian variant would enable international 3G frequencies (which would be a good thing, because the US version probably won't get you more than 2G speeds anywhere else.)
     
    ironass likes this.
  20. Nipin

    Nipin Lurker
    Rank:
    None
    Points:
    6
    Posts:
    4
    Joined:
    Feb 3, 2015

    Feb 3, 2015
    4
    2
    6
    Just SGH-T989

    Will try out ironass #13 steps...will keep you posted
     
    lunatic59 and ironass like this.
  21. Nipin

    Nipin Lurker
    Rank:
    None
    Points:
    6
    Posts:
    4
    Joined:
    Feb 3, 2015

    Feb 3, 2015
    4
    2
    6
    Well I reinstalled the keis and the phone & pc connected. So, I thought to update the OS. Well Kies dwl stuff and rebooted my phone and then the !@#$%^&* back to square one...same old msg....feel like using a sledge hammer on it.....
     
    #21 Nipin, Feb 4, 2015
    Last edited: Feb 6, 2015
  22. ameen rasheed

    ameen rasheed Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Feb 11, 2015

    Feb 11, 2015
    1
    0
    5
    Male
    I have the SGH-T989 ( which keeps and keeps rebooting) and i have kies and all the drivers. it just doesnt connect to any pc i put it on tho. any help would be appreciated :)
     
  23. lunatic59

    lunatic59 Moderati ergo sum
    Moderator
    Rank:
     #3
    Points:
    4,138
    Posts:
    33,098
    Joined:
    Jun 12, 2010

    Jun 12, 2010
    33,098
    27,850
    4,138
    Male
    IT
    Pennsylvania
    What you've got is called a bootloop. It's indicative of a damaged operating system. If a factory reset doesn't fix it you may have to reflash the firmware.
     
    ironass likes this.

Share This Page

Loading...