1. Are you ready for the Galaxy S20? Here is everything we know so far!

Samsung Galaxy S2 Unable to Connect to Samsung Kies App

Discussion in 'Android Devices' started by zenlok, Apr 12, 2012.

  1. zenlok

    zenlok Lurker
    Thread Starter

    Hi All,


    I have recently got a new Galaxy S2 on Vodafone UK and when I try and connect it to the Kies application, I keep getting the error message;


    Reconnect the devise in Samsung Kies (PC Studio) Mode.
    Current connection mode is not supported by Kies.


    I have tried using the debug mode and does not resolve the issue.


    Anyone else having this issue?

    Cheers,

    Dave.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Reave

    Reave Lurker

    I had this problem. earlier for a little while.

    (i don't have my computer with me atm, so it might not be exact)

    I unplugged the the phone from the computer, then ran the troubleshooting page that should show up when you click "search for device" on the left hand side of the window without having a phone plugged in. it went whatever it does, and automatically reinstated some drivers. after that, it worked perfectly fine for me.

    Hope that helps.
     
  3. zenlok

    zenlok Lurker
    Thread Starter

    Hi Reave,

    Thank you for the update :)

    I have tried your suggestion and I am still having the same issue :-(

    Cheers,

    Dave
     
  4. fahdeen

    fahdeen Newbie

    Hi guys been here for sometime...
    i have the same problem after i updated my kies to the latest version 2.3.0.12035_16_4. Now the MTP driver just does not install even after following the following instructions from the link [Solution / Tutorial for Galaxy S i9000] MTP Application crashing
    and also other instructions from around the net!
    1) tried deleting samsung entirely from my drive including drivers and rebooted and then reinstalled. no hope!
    2) tried deleting all files with 16 characters from phone memory and sd card. still no hope!
    3) installed all drivers successfully via usb debugging mode and then after that i disabled usb debugging and connected it says MTP driver successfully installed but i have to restart my pc. when i restart it says MTP drivers installing and then it fails!!!!!! kies keeps saying connecting..........

    Same results at home (vista) and work (win 7 pro)!!!
    whats happening?????
    I'm in Qatar my phone details are as follows
    Model: GT-I9100
    PDA: I9100JPKJ2
    Phone: I9100XXKI4
    CSC: I9100OJPKJ1
    Android Version: 2.3.5
    Kernel Version: 2.6.35.7-I9100JPKJ2-CL655700 root@DELL143 #2

    Any ideas if i have ICS update? This is my first android phone bought it last july. I'm a bit nervous about updating via odin!
    any help anyone???
     
  5. LukeX

    LukeX Newbie

    Hi there
     
  6. lb009

    lb009 Lurker

    I too couldn't connect to kies with USB. I had to take out my sd card and it connected straight away.

    hope that helps.

    I can connect to kies via wifi to back up my pics from sd card and for all firmware/ software upgrades take the sd card out upgrade then put sd card back in.
     
  7. woodylee1900

    woodylee1900 Lurker

    Guys!! I have had a same problem. It could be USB driver crashes. I've always had my external hard drive connected via another usb cable. when you try to connect your galaxy device, try remove your external hard usb cable if connected, then try connecting galaxy via usb cable again. it worked for me. good luck.
     
  8. krystian15

    krystian15 Lurker

    having the exact same issue with my phone, ill connect it and it will say "reconnect device in samasung kies (Pc Studio) mode. current mode not supported by kies. check usb settings (setting>applications>development>usb debugging (x))" i do exactly what it tells me and the same freaking message pops up!!!WTH!!! plz for the mercy of the gods can someone help me with this before i go insane!!!!!!!
     
  9. wileest

    wileest Lurker

    Hi guys and gals out there with problems getting your S2 or S3 connected to Kies. Don't worry its easy. When the pop-up appears telling you that your have to connected in PC Studion mode and current mode not supported, check USB connection & debugging etc. just drag down your android notification bar and it should show your usb connection as a "camera" - you may have somehow set it as a camera unknowingly. Below it says "Touch for other usb options". Do that and it should bring you to a USB Connection page with options to connect as Media Device (MTP) or Camera (PTP). Just tick the MTP option. Thats it. Thats all. I hope it solves your problem.
     
  10. subyroo

    subyroo Lurker

    I just downloaded and installed Kies_2.3.2.12064_10_1 and every time I connect my Galaxy S to the PC via Kies the PC (Win7 SP1) installs a driver for the device and then it can't connect to Kies. I run the Kies Troubleshoot Connection Error program and it re-installs a driver then we get back on the merry go-round with installing drivers.

    This is absolutely crazy. :mad: :mad:

    I get the feeling there is a clash with Win7 64bit drivers and the Kies_2.3.2.12064_10_1 driver.

    Can anybody shed some light on a way to get off this merry go-round. :banghead:
     
  11. vivadz

    vivadz Lurker

    Hi,

    After hitting my self for days trying to fix this issue and after reading some posts suggesting to clean some keys in the registry I did the following.

    1- Uninstalled Kies
    2- Reboot
    3- Download, install and run CCleaner. Make sure you backup your registry!!!
    4- Click the Analyze button, then the Run Cleaner button at the bottom of of the CCleaner.
    5- On the left menu Click the Registry menu
    6- Click Scan for Issues. After backing up your registry, click to fix the issues.
    7- Reboot and repeat from 3 to 6 to make sure all the samsung related keys are gone.

    Voila. That fixed it.
     

Samsung Galaxy S2 Forum

The Samsung Galaxy S2 release date was April 2011. Features and Specs include a 4.3" inch screen, 8MP camera, 1GB RAM, Exynos 4210 Dual processor, and 1650mAh battery.

April 2011
Release Date
0
Reviews
Loading...
Similar Threads - Samsung Galaxy Unable
  1. kwb4
    Replies:
    5
    Views:
    567
  2. LordMax2
    Replies:
    1
    Views:
    679
  3. 4joeyirosh1
    Replies:
    17
    Views:
    2,782
  4. family coach
    Replies:
    14
    Views:
    1,445
  5. Devils_Advokat
    Replies:
    33
    Views:
    1,939
  6. syc0path
    Replies:
    3
    Views:
    1,124
  7. Crash1
    Replies:
    3
    Views:
    2,020
  8. kylabeardad
    Replies:
    6
    Views:
    1,685
  9. jhall68w
    Replies:
    6
    Views:
    1,689
  10. MarcoGalaxyA10
    Replies:
    1
    Views:
    2,358

Share This Page

Loading...