1. Download our Official Android App: Forums for Android!
  2. We apologize for the disruption in email services! They are sending out now, but there is a backlog, so it may take a little time to catch up.

General Samsung Galaxy S2 Wireless turns off when phone not in use!! Help!

Discussion in 'Android Devices' started by Kataklysmyk, Mar 1, 2012.

  1. Kataklysmyk

    Kataklysmyk Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    4
    Joined:
    Mar 1, 2012

    Mar 1, 2012
    4
    0
    25
    Hi everyone, I was just wondering if anyone could help me.

    I have recently bought a Samsung Galaxy S2 but recently the wireless has been playing up. I use Whatsapp quite frequently however I have noticed if I don't touch my phone I don't recieve any messages from Whatsapp, which relys on wireless if it is activated. When I pick up my phone and start interacting with it, I get an influx of whatsapp messages.
    It seems that the wireless may have some sort of sleep mode and turns itself off after a while. Is there a way in which to change this or am I talking utter rubbish?
    If anyone could help me that would be fantastic! :) Thank you!
     

    Advertisement

  2. Hawker

    Hawker Android Expert
    Rank:
     #63
    Points:
    433
    Posts:
    4,095
    Joined:
    Aug 2, 2011

    Aug 2, 2011
    4,095
    1,911
    433
    Male
    UK
    You can set the wireless sleep mode policy:
    menu>settings>wireless+network>wifi settings>menu>advanced>wifi sleep policy
    this can be set to never, never when plugged in or when screen turns off.

    You may want to set it to never.

    Having said this, when an app requires data and its wifi connection is available it should automatically re-invoke even when its "sleeping"

    I'm not familiar with this Whatsapp app, so maybe there is something else you can set in its own settings.
     
  3. Slug

    Slug Check six!
    Moderator
    Rank:
    None
    Points:
    2,043
    Posts:
    20,552
    Joined:
    Aug 1, 2009

    Aug 1, 2009
    20,552
    16,992
    2,043
    Male
    Mobile phone retail
    Inverness, UK
    Check Settings/Wireless & network/Wi-fi settings/Menu/Advanced/Wi-fi sleep policy. It's probably set to "When screen turns off".
     
  4. mohdka

    mohdka Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Sep 23, 2012

    Sep 23, 2012
    1
    0
    5
    same experience to me tooo... after many days search and efforts, finally find out why this is happening to me... i had installed battery saving apps and this app was controlling wifi. simply removed battery saving application, since then wifi is working good without any hindrance. Pls try this way too....
     

Share This Page

Loading...