1. Are you ready for the Galaxy S20? Here is everything we know so far!

Support Samsung Galaxy S3 DHCP Option 50 issue

Discussion in 'Android Devices' started by aa77, Aug 1, 2013.

  1. aa77

    aa77 Lurker
    Thread Starter

    Hi,
    We're having an issue with Samsung Galaxy S3 (4.1.1.) where we're connecting to specific SSID, this SSID is passed to access gateway, access gateway acts as DHCP server.

    The S3 can connect and sends DHCP request on first association with empty request and receives and uses IP allocated from access gateway, establishes session at access gateway, passes data, everything works fine.

    The issue we're having is that we'll disconnect S3 from Wi-Fi and then reconnect but S3 sends DHCP request with option 50 (requested IP address) with same address previously requested.

    This is generally not an issue but our access gateway will not allow session for user if user sends DHCP requested with option 50 set.

    There doesn't appear to be a way to have S3 not send DHCP request with option 50 set after first association.

    Examining verbose logcat output always shows request going with option 50.

    We've tried doing 'forget network', tried rebooting phone, tried resetting to factory default but same results. When we select network on the SSID, it's set for DHCP, not 'static'.

    Once we associate with SSID and receive IP address, outside of factory defaulting the S3, it will always send request for same IP address. Setting low lease time at access gateway's DHCP pool wouldn't do much help as that would just leave users not able to connect within lease time.

    We rooted one of the S3s and found we could avoid this by going in and deleting the dhcp*lease files in the adb shell in the "dhcp" directory (as a guess):

    We tried calling S3 and got no help from them after spending one hour with support trying to explain what DHCP is, so no resolution.

    We searched this S3 forum and found nothing, so now asking for your feedback.

    Is there way to avoid this?

    I think all signs are pointing to 'no'.

    While it's fine that we can avoid this by using rooted phone, we can't have this as solution for hundreds of thousands of users (hopefully millions).
     

    Advertisement

  2. XplosiV

    XplosiV Master X is Watching You

    First thought is to assign a reserved IP on the access point of possible, then DHCP will assign the same IP regardless.

    Might be worth looking into the access points lease time setting, and maybe make sure the IP pool has spare IP's so DHCP can assign freely without waiting for a lease time out.
     
    funkylogik likes this.
  3. funkylogik

    funkylogik share the love peeps ;)

    Sorry... hijacking just to say hi to XplosiV. Not seen u in ages bro :beer:
     
  4. aa77

    aa77 Lurker
    Thread Starter

    Thanks but issue is how to get S3 to stop sending option 50 (requested IP address) once it tried to reconnect to Wi-Fi.

    It gets IP address when first connecting to Wi-Fi.

    After it disables Wi-Fi or if powered down, once Wi-Fi is enabled again, then it sends DHCP request without requested IP address (option 50).

    We're trying to get S3 to not request a specific (or any) IP address each time it connects to Wi-Fi.
     
Loading...
Similar Threads - Samsung Galaxy DHCP
  1. notableuser
    Replies:
    1
    Views:
    132
  2. Cyberdev
    Replies:
    8
    Views:
    439
  3. Android News
    Replies:
    0
    Views:
    112
  4. Android News
    Replies:
    0
    Views:
    77
  5. Android News
    Replies:
    0
    Views:
    45
  6. Android News
    Replies:
    0
    Views:
    67
  7. Android News
    Replies:
    0
    Views:
    62
  8. Android News
    Replies:
    0
    Views:
    54
  9. Android News
    Replies:
    0
    Views:
    48
  10. Android News
    Replies:
    0
    Views:
    28

Share This Page

Loading...