1. Are you ready for the Galaxy S20? Here is everything we know so far!

Samsung Galaxy S3 USB "Unknown Device"

Discussion in 'Android Devices' started by Zeggy, Jun 17, 2012.

  1. Zeggy

    Zeggy Lurker
    Thread Starter

    Hi everyone,

    I a new to android phones and the Samsung Galaxy S3 is my first real smart phone, but i am usually tech savy.

    I first tried my USB cable with the S3 in my laptop on Friday and when i placed the connection into the port the computer installed the driver requrired and I could access all the SD folders ect.

    Today I have tried to connect and I receive the following message "Unknown Device" in Device Manager.

    I have read a lot of threads about its a driver issue and searched for the S3 driver but cant find anything, nothing came in the box.


    1. Download the Forums for Android™ app!


  2. SUroot

    SUroot Extreme Android User

    Kies should work. Tried another USB port?

    You could try reinstalling. Go to device manager (right click my computer, manage, device manager) whilst plugged in and you should see an android device with a yellow exclaimation mark. Delete, unplug, replug
  3. Zeggy

    Zeggy Lurker
    Thread Starter

    Thanks for the reply.

    I had a try, I uninstalled the USB that was "unknown device", unplagged the USB connection and reconnected, then windows responded in about 30 seconds message with "unable to install driver software"

    I also had a try via Kies using the "trouble shooting" button and the reinstall attempt failed also.

    Is there a direct location for this driver software, cant find it anywhere on samsung website, or maybe i am installing it wrong?
  4. Crafty

    Crafty Android Enthusiast

    does kies via wifi work ?

    Somewhere on the phone there is a setting to make it appear ass an MTP device or not. I can't find it right now, but maybe if you changed that by mistake somehow the computer doesn't recognise the phone.
  5. Zeggy

    Zeggy Lurker
    Thread Starter

    When i connect the USB to the computer, and on the S3 notice section i select the USB icon - "Connected as media device", it states

    Media device (MTP) selected (green tick)

    The phone is charging and is apparently recognising its connected, cant say the same for the computer.

    Error in device manager

    "Windows has stopped this device because it has reported problems. (Code 43)"
  6. SUroot

    SUroot Extreme Android User

    Have you rebooted the pc? Try toggling USB debugging in development settings
  7. d76james

    d76james Lurker


    Just had the same problem but MIGHT have found a solution?
    I'm a new Android user (just switched off my Blackberry) and working through the new phone. Had managed to install and use KIES on Win 7 PC until today when I had the same problem. Tried everything and as a last resort have uninstalled KIES (+ Drivers) and currently downloading all 88Mb again!

    While waiting, just seen (hopefully) the solution on another forum - switch the phone off and back on!! Ever so simple but will find out if it cures my problem once I have managed to re-install KIES!

    Just completed reload (and phone reload) and all is working fine! Can't be sure but most likely fix will just need to disconnect phone, switch off and back on and connection to Kies will work again hopefully.
    Good luck.
  8. mrbutters

    mrbutters Well-Known Member

    Zoandroid likes this.
  9. sherlock5545

    sherlock5545 Android Expert

  10. tgma

    tgma Lurker

    I'm having a similar problem on a Mac - the S3 is telling me that it has a USB PC connection, and it's connected as a Media device, but it doesn't appear on my Mac desktop, and programs like DoubleTwist and EasyPhoneSync don't work.

    EasyPhoneSync does at least "see" the phone, but then says it doesn't have a proper USB connection.
  11. reborns14

    reborns14 Newbie

    i was able to get my phone to work with the USB drivers from samsung
    uninstalling Kies
    and by turning on Debugging on the Phone
    • Open Settings
    • Select "Developer options" in the System section
    • Check the box for "USB Debugging"
    • Press "OK" to confirm.
    and using the Camera (PTP) selection on the phone lets me connect, and go into the phone and sdcard now.
  12. reborns14

    reborns14 Newbie

    looks like i spoke too soon. stupid MTP keeps trying to connect to something, im guessing the software that i uninstalled.

    wont let me transfer files. keep getting an error. hating samsung right now.
  13. Henchman

    Henchman Lurker

    Hey all,

    Thanks for above, all you need to do is shutdown and then switch back on, or restart, but I did the latter. No need to re-install kies.


  14. Ballymoss

    Ballymoss Android Expert

    I think it is a Driver issue. I tried to install Kies with my S2 but it never worked so I uninstalled it. Ever the optimist I tried installing it for my S3 but W7 says "Derivers Not Installed". I may have another go tomorrow.
  15. dougdragon

    dougdragon Lurker

    I ran into this issue as well. When I connected my phone to my (Win7Prof64) computer, the OS recognized and downloaded the drivers and my phone's directory came right up. When I tried the same the next day - I received the "unknown device" message. After about an hour of troubleshooting I learned something interesting - I was using a different USB cable than the one I received from my phone. I connected the USB cable I got with the phone and everything automagically worked again. The USB cable must use another wire that "regular" USB cables don't? Here's a chat with Samsung support regarding the cable:

    Gavin: Yes, the USB cable supplied with the device is Samsung recommend and is the Original. So, we request you to use the USB which is supplied with the device.
    Doug: will i damage the device at all if i use a different cable to simply charge the device?
    Gavin: No, it will not damage the device while charging.
    Gavin: But, it can face some issues in connecting in mass storage mode.

    Hope this helps!
    Zoandroid likes this.
  16. Anthony2816

    Anthony2816 Well-Known Member

    I spent an hour on the phone with a Verizon tech guy last night, who (1) claimed I was the first person to bring up this issue, and (2) spent the hour trying different things, but finally gave up and admitted you can't access the S3's SDcard like you would a flash drive. He suggested it might be due to an attempt by Samsung to get around the problem that when the SDcard is treated like a flash drive, it isn't available to the phone or its apps, making them nonfunctional.
  17. Zoandroid

    Zoandroid Android Expert

    Well, after reading this, installing the Samsung GS3 USB driver to my Windows 7 Home Premium PC, and using the OEM cable to connect my new GS3 to the PC, I am happy to report that I DID access and copy 70MB of files from the "internal" SD card, and the entire 3.77GB of files I had loaded earlier onto the 64GB SD card I am using in the phone, over to my PC without incident! In fact, I even got the "USB Safely remove" icon to appear in the Win7 System Tray, which is something that does not happen when I connect my tablet running ICS to the same PC. So what that rep told you does work! Even though there is no actual notification choice under USB connections that says USB Mass Storage, it still let me copy the non-photo, non-media files using MTP. I don't know why, but I won't complain! :D

    That post helped me solve the USB connection issue to my S3. Thanks!
  18. Zoandroid

    Zoandroid Android Expert

    As I understand it, the only time the GS3 won't access the installed SD Card is if you unmount the card. Although the above would also be the case under a true USB Mass Storage connection environment, I did not have that issue. I wanted to make sure what Win7 was seeing regarding the size of the file set I was copying also matched what the Phone was seeing. So while I was copying the files I used Root Explorer (even though it isn't rooted....yet) to check the properties of the mnt/SD Card and mnt/SD Card-EXT content in the phone to see its file size. The phone had no problem accessing the card during the copy. Rather unusual that it can do that.
  19. sheheryar73

    sheheryar73 Lurker

    i found same problem then i restart my cell phone after that its showing me samsung galaxy reorganization in windows
  20. Rastaman-FB

    Rastaman-FB Extreme Android User

    if you read his post though he already mentioned it used to work until the usb shorted and caused his device to turn off and restart. it has damaged the usb block of his external hard drive

    imo this is a hardware error and should be replaced
  21. Ballymoss

    Ballymoss Android Expert

    Re my issue with Samsung Kies on my S2 I discovered recently that it was because the S2 (which I bought "used" on Ebay) had been 'flashed' with the IMEI number of a Nokia 6310 and thus SK doesn't recognise it as a Samsung device.
  22. I had the problem on a Galaxy S. It has now started on the new S3.

    We spend too much time reinstalling and testing software before we examine the connector on the phone. It is usually full of small fragments like hair and dust, and even corrotion stains from moist.

    Those fragments and stains may be electrically leading, and thereby damaging to the information signals.

    This could be a reason why charging succeeds, although signalling (like recognizing the device) continually fail.

    The problem is not covered by the guarantee. You have to try to carefully rinse the contact yourself with a toothbrush, tooth picks or some other soft tool, perhaps with a little red spirit if there is a corrotion problem. Carefully consider a vacuum cleaner to remove loose fragments, too.

    It helps a lot if you have some very strong optical instrument to inspect the contact with while working on it.

    After an hours careful work on the connector the S3 phone is again recognized by Windows, just like my older Galaxy S, which was also repaired by the same cleaning process.

    I guess other phones than Samsung suffers from the same problem as well. Anyway I find this to be a serious consumer case. Information and containment on the USB connector vulnerability should have been a lot better!
  23. Zoandroid

    Zoandroid Android Expert

    I've found that periodic cleaning with compressed air, and the application of Caig De-Oxit on headphone plugs and jacks can effectively cut down on headphone jack issues. Also, using port covers such as those sold on the modDIY website, or using a case with built in port covers, such as the Otterbox Commuter, go a long way to keep the ports free of dust and dirt. Especially when the device is carried in a jeans pocket.
  24. pedrito0906

    pedrito0906 Lurker

    That really helped me a lot!!!! that was my issue, I was using different USB cable, I tried everything, Im glad I read this post XD TY!!
  25. badboy007

    badboy007 Lurker

    "For advanced users only"

    Had this problem 2 weeks ago. Tried every reinstall (kies, drivers, .net framework, etc..) and restart procedures without any result. The problem was that the MTP service app of my S3 was not working correctly (something had to stop it or i did it by error since i rooted the phone).
    So i had this problem solved after struggling for like 1 week by simply un- and then re-installing the MTP apk and restarting the device ( you need to be rooted to un/reinstall a system apk).

    Hope this helps

Samsung Galaxy S3 Forum

The Samsung Galaxy S3 release date was May 2012. Features and Specs include a 4.8" inch screen, 8MP camera, 1GB RAM, Exynos 4412 Quad processor, and 2100mAh battery.

May 2012
Release Date
Similar Threads - Samsung Galaxy USB
  1. Epic555
  2. jo69
  3. spre248
  4. jo69
  5. Milo Williamson
  6. Marvin P Droid
  7. Dave Satterlee
  8. NightAngel79
  9. Rob

Share This Page