1. Are you ready for the Galaxy S20? Here is everything we know so far!

Samsung Galaxy S4 not recognised by my computer

Discussion in 'Android Devices' started by aramis8, Dec 26, 2013.

  1. aramis8

    aramis8 Lurker
    Thread Starter

    Hello everyone,

    I'd be really grateful if anybody can help me out with a problem I have...

    My computer just doesn't recognise my Galaxy s4 when I connect it via USB. Now the computer recognises every other phone I've connected to it, I've tested about 7 different phones.

    There is nothing wrong with the phone or USB cable, I had this verified by Samsung, and furthermore, the phone connects to every other computer I've connected it to. I've tested it on about 5 different machines.

    So I know there's nothing wrong with the phone, and there can't be anything with the computer or it's USB ports since other phones connect to it.

    This has been doing my head in for the past 3 weeks, so I'd be eternally grateful if anybody can shed any light on it.

    I've downloaded Kies and all the Samsung USB drivers, I even reinstalled a clean copy of Windows and even factory reset the phone, but all to no avail.

    I have an AS-Rock Motherboard, could that be the problem? but if that was the case, why do all other phones connect.

    Thank you.

    1. Download the Forums for Android™ app!


  2. Welcome to Android Forums. This thread was moved from Android Lounge to the forum dedicated to discussing your phone.

    ... Thom
  3. aramis8

    aramis8 Lurker
    Thread Starter

    Thanks, sorry I'm new so didn't know where to post it. sorry.
  4. Zangetxu

    Zangetxu Newbie

    never encountered such problem, i am sure there must be some option within settings > security. check the details.
  5. aramis8

    aramis8 Lurker
    Thread Starter

    Well the phone connects to other computers, so I don't think it's an option setting.

    I forgot to mention, it's only Galaxy S4's that don't connect to my computer, as I've tried 2 others with the exact same result.

    My computer recognises all other phones, so why doesn't it specifically recognise the S4.

    This is doing my head in lol
  6. leshicks

    leshicks Lurker

    I had the same issue on 2 computers until I used the USB cable that came with the phone.
  7. aramis8

    aramis8 Lurker
    Thread Starter

    Hello, yes I used the cable that came with the phone. Lol this is a weird one...
  8. teriffe

    teriffe Lurker

    Hi I'm having the same problem and I'm new here so I don't know where to find the answer to the above! Any help is appreciated!
  9. aramis8

    aramis8 Lurker
    Thread Starter

    Hello mate, I know for a fact it can't be the phone...

    Do your computer happen to have an ASRock motherboard by any chance?
  10. aramis8

    aramis8 Lurker
    Thread Starter

    Hello everyone,

    I finally managed to resolve the issue yesterday.

    So I wrote my motherboard (ASrock) company an email explaining the problem.

    They told me to try one of two things:

    1. In BIOS please set:

    BIOS > Advanced > USB Configuration > Legacy USB Support > BIOS Setup Only.


    2. try moving jumper PS2_USB_PWR1 from pins 2&3 to pins 1&2. With this jumper setting you cannot wake up the system from standby using mouse or keyboard, but maybe it will solve the USB related problem. Shut down power to the system before moving the jumper.

    Try the option number 1 first, if that doesn't work, try option 2.

    It worked for me. Hope it does for you too.
  11. meejay

    meejay Lurker

    Hello everyone,

    I have been using my S4 with my computers for months. I have been using original charger and OEM chargers as well at home and car. I have only used original charge cable at work and used the original charge cable to interchange data between both PC and notebooks.

    Last week a strange thing happened that the battery didn't charged with my OEM car charger when its below 15% battery and there was a notification on the screen something like "charging dock plugged" with a different sound than standart charging sound. Tried several times and the phone started rebooting in one of them the language changed from Turkish to Portuguese. Then I have changed the batteries of my wifes S4 with mine and charging problem is resolved. But, later I have realised that my computers does not recognise my S4.

    I have tried 4 different computers but it was all the same with each.

    Could anybody help me out with this?

Samsung Galaxy S4 Forum

The Samsung Galaxy S4 release date was April 2013. Features and Specs include a 5.0" inch screen, 13MP camera, 2GB RAM, Exynos 5410 Octa processor, and 2600mAh battery.

April 2013
Release Date

Share This Page