1. Are you ready for the Galaxy S20? Here is everything we know so far!

Samsung Galaxy S6 How do I stop my text messages from displaying a preview in the notification bar?

Discussion in 'Android Devices' started by Android user since 2012, Apr 11, 2015.

  1. jamespcook

    jamespcook Lurker

    Problem is message details ie name's and content in notification bar on lock screen, my solution will work pop ups can also be disabled but that doesn't affect lock screen nor is it mentioned in initial question or concluding question.
    So settings, sounds notifications, notifications on lock screen, select hide contents. I now get notification in lock screen and status bar saying 1 new message, no name no content. To disable pop ups is a different setting bug easy enough to do as everyone has pointed out but sounds like you already did that. Let me know how this works for you.
     


    #26 jamespcook, Apr 18, 2015
    Last edited: Apr 18, 2015

    1. Download the Forums for Android™ app!


      Download

       
  2. This is called heads up notification and this is Lollipop feature and cannot be turned off unless ur phone is rooted.
     
  3. Straydog

    Straydog Well-Known Member

    OK, many thanks for the explanation, understood. It is not a bug, but a new invention from Google or Samsung to impose silly ideas on people and we can't have a say (or a choice). Newer does not always mean better.
     
  4. chinx5053

    chinx5053 Lurker

    So I too have been struggling with this. I went to settings, applications, and turned off notifications for those apps. It's A bit inconvenient cause you have to check in but hey worth it
     
    #29 chinx5053, Apr 21, 2015
    Last edited: Apr 21, 2015
  5. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    Just use a different message app. Many third party apps let you choose whether the message text appears in the notification, or even whether you get a popup.

    Standard procedure with Android: if the built-in app doesn't so what you want, find an alternative that does.
     
    Snakeyeskm likes this.
  6. Straydog

    Straydog Well-Known Member

  7. d20hak

    d20hak Lurker

    Go in to sound and notifications and then highlight do not show notifications and it stops the big pop up but still let's the little icons appear on the top status bar with set notification sound.
    It works on mine.
     
    Hadron likes this.
  8. Enahmir

    Enahmir Android Enthusiast

    Go to SMS choose more choose settings choose notifications and turn it off.
    No more notifications in the bar.
     
  9. sawyergeo

    sawyergeo Lurker


    I was having the same problem. In order for this to not happen, you must have your phone in a particular lock mode, meaning your screen lock type cannot be "swipe". If it is in a lock mode, once you choose one of the modes, a screen will pop up asking you how do you want to see your notifications on the lock screen and there you can choose hide content. The message will still, however, show it's full content while you are in your phone. I am attaching the samsung manual if you need further help. That's how I found it. Hope this helps!
     

    Attached Files:

  10. snakedoc11

    snakedoc11 Lurker

    Hi I had the same problem BUT FOUND THE ANSWER at long last. No more pop ups are people able to see the message on the top of the screen.

    go to Settings>Applications>Application manager>Downloaded>Then app you want>Then un-tick the box "show notifications"
    THIS WILL WORK and will still show you that you have a message with out any name or message popping up.

    ive put this on another part of the forum but thought best to show it here too.
     
  11. *kallen

    *kallen Newbie

    Thank you! But this unfortunately didn't notify that I even had a message, I have randomly unlock my phone and check manually. I've basically gotten used to it by now, but I'd love to turn it off. QUOTE="snakedoc11, post: 6987760, member: 1849476"]Hi I had the same problem BUT FOUND THE ANSWER at long last. No more pop ups are people able to see the message on the top of the screen.

    go to Settings>Applications>Application manager>Downloaded>Then app you want>Then un-tick the box "show notifications"
    THIS WILL WORK and will still show you that you have a message with out any name or message popping up.

    ive put this on another part of the forum but thought best to show it here too.[/QUOTE]
     
  12. Fevagirl

    Fevagirl Lurker

    I had no problem getting rid of this. Go to messages>more>settings>enhanced messaging>click on the number registered>deregister. Done. Noooo need to admit defeat and up root or go third party.
     
  13. zb79

    zb79 Lurker

    I agonized with i think what is the problem you are dealing with
    in messages > (3 dots in the corner) > settings > Notifications (yes - i get that it says on) > pop-up display
    un check that and you should still get text message notifications and not the on screen pop ups your trying to get around - hope this helps :)
     
  14. fmatt

    fmatt Lurker

    Ok so go to your settings>sounds and notifications>app notifications>find messages > hide content on lock screen.
     
  15. subway05

    subway05 Lurker

    I am using the S6 with Verizon messaging pre-installed... Advanced settings from the left scroll und uncheck notifications... messages about messages? Really?
     
  16. Dangstar

    Dangstar Lurker

    Ive figured it out i believe. if you go to settings>Lock screen and security>Screen lock type> pick pattern>draw your pattern> then it gives you some options. one of them is hide content. You get popups on who texted you but it doesnt show the message itself. it only shows the name of the person who texted you. hope this helps.
     
  17. Honesty

    Honesty Lurker

    I use the app NEXT SMS Vs the original messaging and withe this app I was able to do what your asking for. If you choose to download it to solve your problem goto SETTINGS>NOTIFICATIONs> click off! That will stop messages from popping up on your phone, and set it to where it can only be viewed if you click on the app itself.

    & it also comes with a feature called PRIVATE BOX which sounds like it would come in handy since you use your phone for work. With private box you can have all your messages from family and friends goto your private box and the messages ull only show by you typing in a code to unlock the messages.


    OR! If you want your messages to pop up but just show NEW MESSAGE Vs what the text says go to SETTINGS> NOTIFICATION SETTINGS> PRIVATE MODE "ON". and that ull still show you have a message but won't show what it's about........


    And if you downloaded the app and try this it'll work for the original messaging & the app #PROBLEM SOLVED!
     
  18. Michelesnow

    Michelesnow Lurker

    If your screen is locked and you see the pop up just go to settings sound and notification...

    Open that up and change notifications on lock screen to private
     
  19. dleming

    dleming Lurker

  20. MissMonster

    MissMonster Lurker

    Oh man, I had to make an entire account just to leave this comment. I was driving myself crazy trying to figure it out and I found it you guys! Taa daa lol

    Apps> settings> sounds and notifications> app notifications> messages> select message settings (cog icon to the right)> turn "preview message" on/off

    Boom! Good luck
     
  21. Deleted User

    Deleted User Guest

    Wish we could do this for what's app...
     

Samsung Galaxy S6 Forum

The Samsung Galaxy S6 release date was April 2015. Features and Specs include a 5.1" inch screen, 16MP camera, 3GB RAM, Exynos 7420 Octa processor, and 2550mAh battery.

April 2015
Release Date
0
Reviews
Loading...
Similar Threads - Samsung Galaxy stop
  1. Marvin P Droid
    Replies:
    19
    Views:
    479
  2. kumaranil13k
    Replies:
    9
    Views:
    736
  3. gabrieltito234
    Replies:
    14
    Views:
    603
  4. mysorian
    Replies:
    3
    Views:
    379
  5. ChaunceyK
    Replies:
    0
    Views:
    383
  6. sudz28
    Replies:
    7
    Views:
    479
  7. Hornetzero
    Replies:
    5
    Views:
    589
  8. oneytlam
    Replies:
    2
    Views:
    599
  9. Lane Lester
    Replies:
    2
    Views:
    575
  10. UUXIII
    Replies:
    8
    Views:
    611

Share This Page

Loading...