1. Download our Official Android App: Forums for Android!

Support Samsung Grand Prime won't accept file transfers from PC (USB connection)

Discussion in 'Android Help' started by Android Question, Jun 27, 2016.

  1. Android Question

    Thread Starter

    I bought a Samsung Galaxy Grand Prime earlier this year. It has Android version 5.0.2 on it. I installed a 64gb SD card for extra memory.

    Phone worked great and I was able to transfer (upload) files from my PC to it via USB connection, no problem - at least for the 1st month I had it. Recently, it will not accept any uploads (not to the phone or the mounted SD card). The progress bar just hangs at either 25% completion or 100% completion indefinitely and it won't ever complete the transfer. The only way I can transfer files to this phone is via email or Bluetooth connection.

    So what happened? The first month I had it was able to transfer files to it, no problem.

    I have always been able to download files from it to my PC (via USB cable), and still can despite the fact I can no longer upload files to it.

    I tried Samsung Kies3 software and it is able to do a backup but it can't upload files to the phone either.


Share This Page