1. Check out our companion app, Forums for Android! Download from Google Play

Tips Samsung I5700 (Galaxy SPICA) Android 2.1 Flashing Guide - ENGLISH

Discussion in 'Android Devices' started by greaky, Feb 24, 2010.

  1. greaky

    greaky Member
    Thread Starter
    16

    Dec 30, 2009
    13
    3
    16
    Systems Manager
    Pune

    Advertisement

    Sparx, Orfeas91 and FuriousAngel like this.
  2. Gurdeep.Singh.Mander

    Gurdeep.Singh.Mander Well-Known Member
    16

    Feb 8, 2010
    82
    4
    16
    Software Engineer
    Chandigarh, INDIA
    going to flash... will post u on how like it.
    well, thanks for the guide + essentials :)
     
  3. Orfeas91

    Orfeas91 Active Member
    15

    Feb 5, 2010
    26
    0
    15
    Flashing at this moment but it's been on 1st step "setup connection" for 25 minutes...:S
    what should I do?
    Edit: 34 minutes ... :/
     
  4. Gurdeep.Singh.Mander

    Gurdeep.Singh.Mander Well-Known Member
    16

    Feb 8, 2010
    82
    4
    16
    Software Engineer
    Chandigarh, INDIA
    Same here! I just escaped from bricking my brand-new phone :eek: Thank God.
    Will better wait for the official upgrade instead...
     
  5. Orfeas91

    Orfeas91 Active Member
    15

    Feb 5, 2010
    26
    0
    15
    Same here. Fortunately didn't brick as well. Good ol' 1.5 again :p Would like 2.1 though ;)
     
  6. nx1977

    nx1977 Well-Known Member
    163

    Feb 8, 2010
    2,421
    174
    163
    UK
    Make sure you close Samsungs NPS (dont forget the connection monitor in the sys tray!) and that you've installed the i5700 drivers that came on the CD in the box.

    Odin will then see the phone just fine.
     
  7. Orfeas91

    Orfeas91 Active Member
    15

    Feb 5, 2010
    26
    0
    15
    Odin sees the phone,but it is not going further the first step. Doing exactly as the guide says.
     
  8. nx1977

    nx1977 Well-Known Member
    163

    Feb 8, 2010
    2,421
    174
    163
    UK
    Something must be blocking odin or the drivers arent being found.

    Look under device manager. If you get an unidentified USB device, manually install the drivers, and Odin should kick in.
     
  9. greaky

    greaky Member
    Thread Starter
    16

    Dec 30, 2009
    13
    3
    16
    Systems Manager
    Pune
    Updated the guide with the Device drivers screenshot.
     
  10. Orfeas91

    Orfeas91 Active Member
    15

    Feb 5, 2010
    26
    0
    15
    Okay, gonna try again now. Wish me luck :p
     
  11. Orfeas91

    Orfeas91 Active Member
    15

    Feb 5, 2010
    26
    0
    15
    Nope, same problem. Device gets recognised fine... I do as the guide says :/
    Don't know what's wrong :p Will try again later though
     
  12. FuriousAngel

    FuriousAngel New Member
    5

    Feb 25, 2010
    4
    0
    5
    Hello All,

    First thanks to greaky for this guide.

    I just got this I5700 recently and tried this guide.

    At first I did as the guide instructed, but it got stuck at "setup connection". (Connection was good by the way. Yellow and everything.) I tried several times with different PCs but it all ended the same. In the process I bricked the phone:eek:. After power on, there was Samsung and an icon showing ! mark between a cell and a PC.

    Then I downloaded Odin 3.98. Then tried again but it gave some weird error messages. I don't remember exactly but it was saying something about cache.rfs. In one of the forums, I found someone saying try it with removing CSC file from Odin. So I did and it worked like charm.

    I can make phone calls and send sms. But I can't configure APN so I can't use 3G or whatsoever to access internet. Maybe it has something to do with this CSC file.

    So I guess something wrong with the CSC file. Can anyone find a working CSC file to fix the internet issue?

    Cheers.

    Edit: I switched of and on again, now APN and 3G internet is working. Now I shall see it is stable or not , because of CSC file.
     
  13. Orfeas91

    Orfeas91 Active Member
    15

    Feb 5, 2010
    26
    0
    15
    Interesting...Let us know if everything is alright with apn and internet.

    This happened to me too, it's not a problem, just switch it off again and switch it on while connected to a pc.
     
  14. FuriousAngel

    FuriousAngel New Member
    5

    Feb 25, 2010
    4
    0
    5
    I didn't tried that. Actually after powering on and the ! icon appears, it was not possible to power off with the button, only removing battery. But it could be like that when it is not connected to a PC as you said.
     
  15. Orfeas91

    Orfeas91 Active Member
    15

    Feb 5, 2010
    26
    0
    15
    Yeah, it only powers off by removing the battery.
    Now you got 2.1 ? Is it working well?
     
  16. Gurdeep.Singh.Mander

    Gurdeep.Singh.Mander Well-Known Member
    16

    Feb 8, 2010
    82
    4
    16
    Software Engineer
    Chandigarh, INDIA
    I think i got it. The problem is not with the Odin, but the drivers itself. When in download mode, the drivers get automatically installed and under Modems, it shows "SAMSUNG Mobile Modem" in place of "SAMSUNG Android Mobile Modem". Similarly, under Universal Serial Bus controllers, it shows "SAMSUNG USB Composite Device" in place of "SAMSUNG Android USB Composite Device". On the other hand if u boot normally with 1.5, the devices those get listed are exactly what we want. I also tried unblocking .sys files from properties and update drivers, still no luck. Omitting CSC as well didn't work for me.
    BTW, if you get stuck at the screen with "!" mark, deattach the usb cable remove phone battery, replace it and then again plug-in the cable. It'll show as charging, and at this point press power-on button. It should boot normally :)
     
  17. Gurdeep.Singh.Mander

    Gurdeep.Singh.Mander Well-Known Member
    16

    Feb 8, 2010
    82
    4
    16
    Software Engineer
    Chandigarh, INDIA
    The moral of the story : If it doesn't show devices having word "Android", you won't brick ur handset. (most probably)

    No communication = No brick :D
     
  18. Orfeas91

    Orfeas91 Active Member
    15

    Feb 5, 2010
    26
    0
    15
    It won't brick but it won't upgrade as well :p We are trying to get 2.1 on, not brick it ;)
     
  19. Gurdeep.Singh.Mander

    Gurdeep.Singh.Mander Well-Known Member
    16

    Feb 8, 2010
    82
    4
    16
    Software Engineer
    Chandigarh, INDIA
    he he he ;)) then lets wait for official news bro ;))
     
  20. Orfeas91

    Orfeas91 Active Member
    15

    Feb 5, 2010
    26
    0
    15
    Yeah I guess ^^
     
  21. Gurdeep.Singh.Mander

    Gurdeep.Singh.Mander Well-Known Member
    16

    Feb 8, 2010
    82
    4
    16
    Software Engineer
    Chandigarh, INDIA
    @Orfeas91 which os are you trying on btw?
     
  22. Orfeas91

    Orfeas91 Active Member
    15

    Feb 5, 2010
    26
    0
    15
    The 2.1. Got it from here.
     
  23. Gurdeep.Singh.Mander

    Gurdeep.Singh.Mander Well-Known Member
    16

    Feb 8, 2010
    82
    4
    16
    Software Engineer
    Chandigarh, INDIA
    Thanx :) but i meant the Desktop os you are trying on. Well i'm done with this business. Will better wait for the official stuff...
     
  24. Orfeas91

    Orfeas91 Active Member
    15

    Feb 5, 2010
    26
    0
    15
    Oh, my bad.I'm using Windows XP sp3 for the process.
     
  25. Gurdeep.Singh.Mander

    Gurdeep.Singh.Mander Well-Known Member
    16

    Feb 8, 2010
    82
    4
    16
    Software Engineer
    Chandigarh, INDIA
    okk thanks. BTW u n me both have equal no. of total posts :)) c u bro :)
     

Share This Page

Loading...