1. Check out our companion app, Forums for Android! Download from Google Play

Root Samsung Infuse - Can't connect USB

Discussion in 'Android Devices' started by gpramos, Nov 17, 2011.

  1. gpramos

    gpramos New Member
    Thread Starter

    Nov 17, 2011
    I'm having some problems when trying to connect my Samsung Infuse 4G to my PC.

    Everytime I plug the USB to the computer it does not recognize the device. Meanwhile when I look at the cellphone it also does not show that it there is an USB connection, even though it starts charging.

    So summarizing: I connect my phone to my PC, it starts charging but both the phone and the computer do not recognize the USB connection, so I can't use it for some functions as Mass Storage.
    In the phone screen it wont even open that three options to chose what kind of USB connection you want.

    I already tried changing my USB cable, turning on USB debugging but it also did not work.

    Any one has a clue about what might it be? So far I think it could be some problem in the phone's USB plug, although it still works for charging the device.


  2. olskool

    olskool Well-Known Member

    Apr 26, 2011
    Alabama in the woods.
    Try a different port. Many times the data port closes if you disconnect without using the safe removal tool but will still charge. If this solves your problem then you can turn the affected port back on through the device manager on the pc side. The drivers from the phone should automatically load.
  3. manixs

    manixs New Member

    May 14, 2012
    It seems its not recogning it as a system storage anymore.. i tried all the above bt couldnt connect it to pc!! grrr.. i do notsee how to fix this issue.. is it a hardware prblm (*although it does charge it (((most of the times)))
  4. jdv2727

    jdv2727 New Member

    May 18, 2012
    My wife had the same issue. I fixed it by going into settings-applications-usb settiings. Then I changed it from Ask on connection to mass storage. Hooked it up to my computer. It recognized mass storage. Went back in to the usb settings and changed it back to ask on connection.

Share This Page