1. Download our Official Android App: Forums for Android!

Support Samsung Kies :'( [FIXED!]

Discussion in 'Android Devices' started by jpjosey, Jan 24, 2012.

  1. jpjosey

    jpjosey Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Apr 26, 2011

    Apr 26, 2011
    10
    0
    15
    I can't get kies to connect to my phone. Ever.

    I was having problems on XP, I have since got Windows 7, reinstalled Kies and am having the same issue with connection.

    If I select kies mode upon usb connection, nothing happens, if I select mass storage (with or without mounting SD) kies says "connecting..." and just stays like that until I unplug.

    I've had a nosey around the forum, and there seem to be a billion-and-one workarounds, but I'm a little overwhelmed with where to begin.

    I'm still trying various things, and will keep updating this thread with them as I try them, so if anyone has any feedback on the results I'm getting and perhaps a suggestion, it would be welcomed.

    Hopefully by the end of it, this will be a nice thread someone can follow to get the same problem sorted.

    So, details:

    I have a Samsung Galaxy S, and am using the most current Kies version (as of the date this thread was started).

    Firmware version: 2.1-update1
    Kernel version: 2.6.29 root@SE-S604 #2
    Build number: ECLAIR.BOJG3

    Wi-Fi and Bluetooth are turned off when I attempt to connect via USB.

    Upon connection issues with Kies I have (several times) run the troubleshooter which has reinstalled the USB drivers, but the problem persists.

    I should also add that if there's any further information anyone would like me to check, I will gladly do so and post it asap.

    Thanks
     

    Advertisement

  2. jpjosey

    jpjosey Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Apr 26, 2011

    Apr 26, 2011
    10
    0
    15
    I should also add, I don't really care about Kies, I just want my firmware upgraded, and as far as I'm aware Kies is how to go about that. So if there's a safe alternative, I'll take it.
     
  3. jpjosey

    jpjosey Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Apr 26, 2011

    Apr 26, 2011
    10
    0
    15
    I have now tried the following:

    Installed Kies on my laptop, which is still running Windows Vista, exactly the same problem persists, that's three different OS I've tried now, so I am assuming it's a phone problem, not PC. But that's just me.

    I installed Windows Mobile Device Centre, problem persists.

    I formatted my phone's SD card(s), problem persists.
     
  4. jpjosey

    jpjosey Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Apr 26, 2011

    Apr 26, 2011
    10
    0
    15
    Enabled debugging mode, when I connect USB with debugging enabled both computers (Vista and 7) automatically give me the little "Installing Device Drivers" popup. Then kies starts "Connecting..." - then as soon as the driver install is successful Kies stops trying to connect and tells me to connect via PC mode (kies mode).
     
  5. jpjosey

    jpjosey Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Apr 26, 2011

    Apr 26, 2011
    10
    0
    15
    Installed Home Switcher app and switched Twlauncher back to my default launcher. Tried all of the above, problem persists!
     
  6. jpjosey

    jpjosey Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Apr 26, 2011

    Apr 26, 2011
    10
    0
    15
    EUREKA!

    Okay... I'm not -exactly- sure precisely which step worked, so I'm going to try and write exactly what I did before I forget it....

    I followed the Kies instructions for setting up Wi-Fi connection on both computers. Then downloaded the Kies Air app from the android market.

    Once the app finally installed and opened up on the phone, I connected my phone to my home wifi network, then Air prompted me to visit a url on the computer.

    First I tried it on the laptop (Running Vista and connected wirelessly on the same network) - page didn't load.

    Then I tried it on the desktop (running Windows 7 and connected by ethernet only, same network obviously) - page loaded up and I was able to access media, contacts etc.

    So, I still couldn't upgrade my firmware, (cant do this wirelessly apparently), but I figured that was progress, so while that was all still active I plugged the USB in, usual story, nothing happened in Kies mode, Mass Storage got stuck on infinite connecting.

    Then, now I'm not 100% on the exact order here, but it was something like this:

    Whilst still connected to Kies Air, with wifi still on etc:

    I closed samsung Kies on the computer (not the web browser I was using with Air)

    Reconnected my phone by USB and selected Kies mode.

    At this point my phone, for the first time ever i think, gave me the "MTP Application" screen, with the message "Press the home key to quit samsung kies"

    I then ran Kies on the PC again, and BOOM.. straight into the phone, firmware upgrade offered.

    I am now going to upgrade the firmware before trying to disconnect ANYTHING.

    Once that's done I'll report back.
     
  7. jpjosey

    jpjosey Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Apr 26, 2011

    Apr 26, 2011
    10
    0
    15
    Well, whatever the problem was, it was on the phone. After I factory reset Kies recognised the phone immediately, then upgraded firmware again to the latest version. Now the LAPTOP (which even Kies Air didn't work on) connects to Kies without a hitch.

    I don't have a clue what would have been on my phone causing the issue, but my phone is now running better than the day I bought it, and Kies works.

    So to anyone out there feeling the frustration I felt over the past year or so (especially the last 24 hours) here's what I would advise:

    Copy your phone contacts to SD card
    Backup SD cards
    Factory Reset

    There are other options for backups online etc, but if you're stuck on an old version you might not get them working.

    Obviously this isnt the only way, because I got Kies to recognise my phone before I upgraded and factory reset, I'm not sure if playing with Kies Air did the trick, or it was as simple as connecting to Kies mode on the phone, THEN running Kies on the computer.

    If you're still stuck, remember I did a bunch of other things first, here's a short summary of them:


    - Reinstall Kies
    - Have Kies reinstall USB drivers
    - Install Windows Mobile Device Centre
    - Format SD cards (back em up first!)
    - Go back to stock launcher
    - Go through the Kies instructions for setting up Wireless Connections, this might sound pointless if you're trying to get the USB to work, but there were a couple of steps, such as editing a couple of services, and making sure mobile devices were allowed in Windows Firewall, which MAY have had a positive effect.

    Good luck!

    If anyone has the power you might want to mark this thread as fixed. :)
     
  8. Matt31

    Matt31 Well-Known Member
    Rank:
    None
    Points:
    56
    Posts:
    111
    Joined:
    Aug 30, 2011

    Aug 30, 2011
    111
    9
    56
    South Korea
    I might have the same problem.

    Kies used to work no problem.
    But ever since I put my new ROM on the phone, Kies wont detect it.
    I just keeps saying connecting....I have tried uninstalling and reinstalling the drivers, but that didn't work.

    Not a big deal, I can just use the custom ROMS I guess, but not many available for my Korean SGS.
    Id like to be able to use Kies again, even just for backing up contacts and such....
     
  9. deadkenny

    deadkenny Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Apr 28, 2012

    Apr 28, 2012
    2
    0
    5
    Same problems here. Tried Kies on my Win 7 32 bit netbook, my Win 7 64bit desktop, my spare PC running XP (clean install). None will connect. It's the device (Galaxy S2 I9100P NFC version, Orange UK firmware, 2.3.4).

    Just want to be able to update the firmware when it's finally out as Orange UK are slowly rolling out ICS. Yes I could get unofficial ones but I'm happy with the branded stuff as it's not very branded/bloated, works fine, and does include the rather useful Signal Boost app which doesn't appear to be downloadable (routes Orange calls & texts through WiFi instead of GSM/3G in poor signal areas).

    Factory reset is a very last option as I really don't want to go through, backup/restores, reinstalling everything and the associated hassles.

    Thinking maybe Safe Mode on the phone might do it, if it disables whatever service and apps are blocking Kies. Yet to try.
     
  10. LateNiteMike

    LateNiteMike Well-Known Member
    Rank:
    None
    Points:
    58
    Posts:
    212
    Joined:
    Jul 24, 2010

    Jul 24, 2010
    212
    14
    58
    Retired
    American Expat now living in Thailand
    I cheat. I take my SGS to my friend who's a Samsung tech. He uses ODIN and the whole procedure is a snap. He doesn't mess with Kies, and I won't either. After reading all the postings regarding Kies over these past 20 months I'm convinced that the piece of Crapware called Kies has caused more people more grief than any one software product out there.
    I refuse to use Kies. I've got better things to do in my life than spending hours, or DAYS...TRYING to get some crap software to do what it was (supposedly) designed to do.

    Kies is a big FAIL and should have been replaced by Samsung LONG ago. Most people who try to use it are in for a lot of (needless) hassle and frustration.

    IMHO.....Odin is the way to go,...and having a friend who is a Samsung tech do the FW upgrade for you is even better.
     
  11. deadkenny

    deadkenny Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Apr 28, 2012

    Apr 28, 2012
    2
    0
    5
    Well, after a lot of attempts, somehow it suddenly connected! I'd actually at first attempted getting it going on an install of Win 8 Preview I've got just to see if that helps. It didn't, but going back to an install on XP it finally did.

    Failed to install my update of course. Half way through and lost the connection. Tried again and it redownloaded from scratch and eventually worked.

    Was almost going to go the Odin route. Should have really. Wasn't sure about it though as want to stick with the official stuff.

    Kies however needs to be killed at the next opportunity. Used to grumble at PC/Ovi Suite and NSU from Nokia, but theirs is bliss by comparison!

    Oh, and Kies stays on my spare XP machine. Won't put it on my main machines. It has a habit of killing things (have to reinstall SyncToy for a start if you install it).
     

Share This Page

Loading...